antlr-bootstrap-2.7.7-180.1.noarch.rpm


Advertisement

Description

antlr-bootstrap - Antlr for bootstrapping purposes

Property Value
Distribution openSUSE Tumbleweed
Repository JAVA all
Package filename antlr-bootstrap-2.7.7-180.1.noarch.rpm
Package name antlr-bootstrap
Package version 2.7.7
Package release 180.1
Package architecture noarch
Package type rpm
Category Development/Libraries/Java
Homepage http://www.antlr.org
License BSD-3-Clause AND SUSE-Public-Domain
Maintainer -
Download size 442.84 KB
Installed size 458.05 KB
This antlr package is used for bootstrapping purposes only.

Alternatives

Package Version Architecture Repository
antlr-bootstrap - - -

Provides

Name Value
antlr-bootstrap = 2.7.7-180.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package antlr-bootstrap-2.7.7-180.1.noarch.rpm
Source Package antlr-bootstrap-2.7.7-180.1.src.rpm

Install Howto

  1. Add the JAVA repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/Java:/packages/openSUSE_Tumbleweed/ java
  2. Install antlr-bootstrap rpm package:
    # zypper install antlr-bootstrap

Files

Path
/usr/share/java/antlr-bootstrap-2.7.7.jar
/usr/share/java/antlr-bootstrap.jar

Changelog

2019-02-01 - Fridrich Strba <fstrba@suse.com>
- Speed-up build by compiling all *.java files in one javac
invocation
2018-05-15 - fstrba@suse.com
- Build with source and target 8 to prepare for a possible removal
of 1.6 compatibility
2017-12-07 - dimstar@opensuse.org
- Escape the usage of %{VERSION} when calling out to rpm.
RPM 4.14 has %{VERSION} defined as 'the main packages version'.
2017-10-09 - fstrba@suse.com
- Remove requirement of gcc-java all together and build with
any java version that exists and is able to use source and target
1.6
2017-09-20 - fstrba@suse.com
- Remove requirements of ecj-bootstrap and fastjar
* use the gcj.jar that comes with gccN-java
* use gjar-N instead of fastjar
2014-07-04 - tchvatal@suse.com
- Cleanup a bit with spec-cleaner
2013-07-17 - schwab@suse.de
- Fix quoting of $
2010-08-31 - mvyskocil@suse.cz
- Do not install antlr.jar to avoid conflicts with a regular
antlr-java packages. Packages using antlr-bootstrap needs to have
antlr-bootstrap in their CLASSPATH
2010-08-23 - mvyskocil@suse.cz
- do not Provide antlr
2008-03-03 - mvyskocil@suse.cz
- updated to 2.7.7

See Also

Package Description
antlr-devel-2.7.7-180.7.i586.rpm ANother Tool for Language Recognition (c++ runtime)
antlr-devel-2.7.7-180.7.x86_64.rpm ANother Tool for Language Recognition (c++ runtime)
antlr-java-2.7.7-180.7.noarch.rpm ANother Tool for Language Recognition (Manual)
antlr-manual-2.7.7-180.7.noarch.rpm ANother Tool for Language Recognition (Manual)
antlr-maven-plugin-2.2-2.26.noarch.rpm Maven plugin that generates files based on grammar file(s)
antlr-maven-plugin-javadoc-2.2-2.26.noarch.rpm Javadocs for antlr-maven-plugin
aopalliance-1.0-5.1.noarch.rpm Java/J2EE AOP standards
aopalliance-javadoc-1.0-5.1.noarch.rpm API documentation for aopalliance
apache-commons-beanutils-1.9.3-30.52.noarch.rpm Utility methods for accessing and modifying the properties of JavaBeans
apache-commons-beanutils-javadoc-1.9.3-30.52.noarch.rpm Javadoc for jakarta-commons-beanutils
apache-commons-chain-1.2-6.2.noarch.rpm An implementation of the GoF Chain of Responsibility pattern
apache-commons-chain-javadoc-1.2-6.2.noarch.rpm Javadoc for apache-commons-chain
apache-commons-cli-1.4-40.6.noarch.rpm Command Line Interface Library for Java
apache-commons-cli-javadoc-1.4-40.6.noarch.rpm Javadoc for apache-commons-cli
apache-commons-codec-1.11-61.13.noarch.rpm Apache Commons Codec Package
Advertisement
Advertisement