libratbag-tools-0.9.905-13.1.x86_64.rpm


Advertisement

Description

libratbag-tools - Utilities for configuring gaming mice

Property Value
Distribution openSUSE Tumbleweed
Repository Hardware all
Package filename libratbag-tools-0.9.905-13.1.x86_64.rpm
Package name libratbag-tools
Package version 0.9.905
Package release 13.1
Package architecture x86_64
Package type rpm
Category Hardware/Other
Homepage https://github.com/libratbag/libratbag
License MIT
Maintainer -
Download size 34.73 KB
Installed size 105.38 KB
libratbag is a configuration library for gaming mice. It provides a
generic way to access the various features exposed by these mice and
abstracts away hardware-specific and kernel-specific quirks.
This subpackage contains the ratbag utilities allowing to inspect and configure
mice.

Alternatives

Package Version Architecture Repository
libratbag-tools-0.9.905-13.1.i586.rpm 0.9.905 i586 Hardware
libratbag-tools-0.9.905-1.1.x86_64.rpm 0.9.905 x86_64 openSUSE Oss
libratbag-tools-0.9.905-1.1.i586.rpm 0.9.905 i586 openSUSE Oss
libratbag-tools - - -

Requires

Name Value
/usr/bin/python3 -
libc.so.6(GLIBC_2.4)(64bit) -
liblur.so.3()(64bit) -
liblur.so.3(LIBLUR_0.4.0)(64bit) -
python3-evdev -
ratbagd -

Provides

Name Value
libratbag-tools = 0.9.905-13.1
libratbag-tools(x86-64) = 0.9.905-13.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libratbag-tools-0.9.905-13.1.x86_64.rpm
Source Package libratbag-0.9.905-13.1.src.rpm

Install Howto

  1. Add the Hardware repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/hardware/openSUSE_Tumbleweed/ hardware
  2. Install libratbag-tools rpm package:
    # zypper install libratbag-tools

Files

Path
/usr/bin/lur-command
/usr/bin/ratbagctl
/usr/share/man/man1/lur-command.1.gz
/usr/share/man/man1/ratbagctl.1.gz

Changelog

2019-03-31 - Matthias Bach <marix@marix.org>
- Dropped the no longer required build requirement python3-lxml.
2019-03-29 - Matthias Bach <marix@marix.org>
- Update to version 0.9.905:
* Added Devices:
+ Logitech G603
* Breaking changes in DBus API to move it towards a 1.0 release.
* SVG handling has been dropped.
* Ratbagctl interface changed:
* Device IDs or Device name matching is now used instead of
event nodes. Use `ratbagctl list` to see device IDs and
names.
* Device is now taken as the first argument.
* Ratbagctl is now case sensitive.
2019-01-30 - marix@marix.org
- Update to version 0.9.904:
* Added Devices:
+ Logitech G PowerPlay
+ Logitech G Pro
+ Logitech G402
+ Logitech G502 HERO
+ Logitech MX Anywhere 2
+ Logitech MX Anywhere 2S
+ Logitech MX Master 2S
+ Steelseries Rival 600
* Improved Devices:
+ All supported Roccat Devices
+ Logitech G102/203
+ Logitech G502
+ Logitech G600
+ Logitech G603
+ Logitech G903
+ Logitech MX Master
* Improved error messages provided by the command line tools.
2018-10-16 - opensuse-packaging@opensuse.org
- Update to version 0.9.903:
* Adds GetSvgFd() function on D-BUS required by Piper
* Add a --version commandline argument ratbagd
* Added support for the Steelseries Sensei Raw
* Added support for the Logitech G600
* Added support for the Logitech G302
2018-07-31 - marix@marix.org
- Drop rpmlint configuration as the D-Bus service of the package
has been whitelisted via bsc#1076467.
2018-07-28 - marix@marix.org
- Ensure that group games is present.
2018-07-27 - marix@marix.org
- Add install-daemon-into-sbindir-patch.patch: Installs ratbagd
into /usr/sbin as can only be run by root.
2018-07-10 - marix@marix.org
- Move the daemon into a separate subpackage as applications like
piper can use it without having the command line tools installed.
2018-07-05 - marix@marix.org
- Run tests as part of package build.
- Fix disabling of documentation build.
2018-07-05 - marix@marix.org
- Suppress the suse-dbus-unauthorized-service lintian error for
easier testing.

See Also

Package Description
libsoc-common-0.8.2-9.31.i586.rpm Common files for libsoc
libsoc-common-0.8.2-9.31.x86_64.rpm Common files for libsoc
libsoc-devel-0.8.2-9.31.i586.rpm Development files for libsoc
libsoc-devel-0.8.2-9.31.x86_64.rpm Development files for libsoc
libsoc2-0.8.2-9.31.i586.rpm C library for interfacing with common SoC peripherals
libsoc2-0.8.2-9.31.x86_64.rpm C library for interfacing with common SoC peripherals
libspeechd-devel-0.9.0-70.2.i586.rpm Device independent layer for speech synthesis - Development files
libspeechd-devel-0.9.0-70.2.x86_64.rpm Device independent layer for speech synthesis - Development files
libspeechd2-0.9.0-70.2.i586.rpm Device independent layer for speech synthesis - Client library
libspeechd2-0.9.0-70.2.x86_64.rpm Device independent layer for speech synthesis - Client library
libspeechd2-32bit-0.9.0-70.2.x86_64.rpm Device independent layer for speech synthesis - Client library
libtinyb0-0.5.1-9.7.i586.rpm Shared library for tinyb
libtinyb0-0.5.1-9.7.x86_64.rpm Shared library for tinyb
libts0-1.16-34.12.i586.rpm Abstraction layer for touchscreens
libts0-1.16-34.12.x86_64.rpm Abstraction layer for touchscreens
Advertisement
Advertisement