python3-pwquality-1.4.1-32.11.i586.rpm


Advertisement

Description

python3-pwquality - Python 3 bindings for libpwquality

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename python3-pwquality-1.4.1-32.11.i586.rpm
Package name python3-pwquality
Package version 1.4.1
Package release 32.11
Package architecture i586
Package type rpm
Category Development/Libraries/Python
Homepage https://github.com/libpwquality/libpwquality
License BSD-3-Clause OR GPL-2.0-or-later
Maintainer -
Download size 15.34 KB
Installed size 18.46 KB
libpwquality is a library for password quality checks and generation
of random passwords that pass the checks.
This package provides Python 3 bindings for the libpwquality library.

Alternatives

Package Version Architecture Repository
python3-pwquality-1.4.1-41.12.i586.rpm 1.4.1 i586 GNOME Next
python3-pwquality-1.4.1-41.12.x86_64.rpm 1.4.1 x86_64 GNOME Next
python3-pwquality-1.4.1-32.6.x86_64.rpm 1.4.1 x86_64 GNOME Factory
python3-pwquality-1.4.1-1.1.i586.rpm 1.4.1 i586 openSUSE Oss
python3-pwquality-1.4.1-1.1.x86_64.rpm 1.4.1 x86_64 openSUSE Oss
python3-pwquality - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libpwquality.so.1 -
libpwquality.so.1(LIBPWQUALITY_1.0) -
libpython3.7m.so.1.0 -
python(abi) = 3.7

Provides

Name Value
python-pwquality = 1.4.1-32.11
python3-pwquality = 1.4.1-32.11
python3-pwquality(x86-32) = 1.4.1-32.11

Obsoletes

Name Value
python-pwquality < 1.4.1-32.11

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-pwquality-1.4.1-32.11.i586.rpm
Source Package libpwquality-1.4.1-32.11.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install python3-pwquality rpm package:
    # zypper install python3-pwquality

Files

Path
/usr/lib/python3.7/site-packages/pwquality-1.4.1-py3.7.egg-info
/usr/lib/python3.7/site-packages/pwquality.cpython-37m-i386-linux-gnu.so

Changelog

2019-09-19 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 1.4.1:
+ Minor bugfix update of the library.
- Drop libpwquality-pythons.patch: Fixed upstream. Following this,
drop autoconf, automake and libtool BuildRequires and autoreconf
call.
- Use modern macros.
2019-09-19 - Ludwig Nussel <lnussel@suse.de>
- Do not recommend lang package. The lang package already has a
supplements.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2018-01-08 - jengelh@inai.de
- Update RPM groups and summaries.
2018-01-08 - tchvatal@suse.com
- Switch url to https://github.com/libpwquality/libpwquality/
- Update to release 1.4.0:
* Fix possible buffer overflow with data from /dev/urandom
in pwquality_generate().
* Do not try to check presence of too short username in password.
(thanks to Nikos Mavrogiannopoulos)
* Make the user name check optional (via usercheck option).
* Add an 'enforcing' option to make the checks to be warning-only
in PAM.
* The difok = 0 setting will disable all old password similarity
checks except new and old passwords being identical.
* Updated translations from Zanata.
- Add patch libpwquality-pythons.patch to avoid duping pythondir
- Make python3 default and enable py2 only when needed
2017-11-09 - mpluskal@suse.com
- Build python3 version of bindings as well
2016-04-15 - mgorse@suse.com
- Update to GNOME 3.20  Fate#318572
2015-07-25 - zaitor@opensuse.org
- Update to version 1.3.0:
+ Change the defaults for credits, difok, and minlen.
+ Make the cracklib check optional but on by default.
+ Add implicit support for parsing  <cfgfile>.d/*.conf files.
+ Add libpwquality API manual page.
2014-08-23 - dimstar@opensuse.org
- Update to version 1.2.4:
+ Add Python3 module subpackage.
2014-08-15 - mlin@suse.com
- Avoid conflict in installation-images-openSUSE with cryptsetup:
+ Only recommend, insted of Require cracklib-dict-full.
+ Require cracklib-dict.

See Also

Package Description
quadrapassel-3.34.1-56.6.x86_64.rpm Tetris Game for GNOME
quadrapassel-3.34.1-59.2.i586.rpm Tetris Game for GNOME
quadrapassel-lang-3.34.1-56.6.noarch.rpm Translations for package quadrapassel
quadrapassel-lang-3.34.1-59.2.noarch.rpm Translations for package quadrapassel
retro-gtk-devel-0.18.0-26.4.x86_64.rpm Development files for retro-gtk, a Gtk+3 wrapper for libretro
retro-gtk-devel-0.18.1-28.1.i586.rpm Development files for retro-gtk, a Gtk+3 wrapper for libretro
rsvg-convert-2.46.4-175.10.i586.rpm SVG Convert using the GNOME Render SVG library
rsvg-convert-2.46.4-175.2.x86_64.rpm SVG Convert using the GNOME Render SVG library
rsvg-thumbnailer-2.46.4-175.10.noarch.rpm SVG thumbnailer using the GNOME Render SVG library
rsvg-thumbnailer-2.46.4-175.2.noarch.rpm SVG thumbnailer using the GNOME Render SVG library
rygel-0.38.3-184.1.x86_64.rpm UPnP/DLNA home media server for GNOME
rygel-0.38.3-187.2.i586.rpm UPnP/DLNA home media server for GNOME
rygel-devel-0.38.3-184.1.x86_64.rpm Development files for the Rygel UPnP/DLNA media server
rygel-devel-0.38.3-187.2.i586.rpm Development files for the Rygel UPnP/DLNA media server
rygel-lang-0.38.3-184.1.noarch.rpm Translations for package rygel
Advertisement
Advertisement