pipewire-spa-tools-0.2.7-16.7.i586.rpm


Advertisement

Description

pipewire-spa-tools - The PipeWire SPA Tools

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename pipewire-spa-tools-0.2.7-16.7.i586.rpm
Package name pipewire-spa-tools
Package version 0.2.7
Package release 16.7
Package architecture i586
Package type rpm
Category Productivity/Multimedia/Other
Homepage https://pipewire.org/
License LGPL-2.1-or-later
Maintainer -
Download size 21.90 KB
Installed size 75.30 KB
SPA or Simple Plugin API is a plugin API.
This package provides spa-inspect and spa-monitor tools.

Alternatives

Package Version Architecture Repository
pipewire-spa-tools-0.2.7-35.7.i586.rpm 0.2.7 i586 GNOME Next
pipewire-spa-tools-0.2.7-35.7.x86_64.rpm 0.2.7 x86_64 GNOME Next
pipewire-spa-tools-0.2.7-16.3.x86_64.rpm 0.2.7 x86_64 GNOME Factory
pipewire-spa-tools-0.2.7-1.1.i586.rpm 0.2.7 i586 openSUSE Oss
pipewire-spa-tools-0.2.7-1.1.x86_64.rpm 0.2.7 x86_64 openSUSE Oss
pipewire-spa-tools - - -

Requires

Name Value
libc.so.6(GLIBC_2.16) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -

Provides

Name Value
pipewire-spa-tools = 0.2.7-16.7
pipewire-spa-tools(x86-32) = 0.2.7-16.7

Download

Type URL
Mirror widehat.opensuse.org
Binary Package pipewire-spa-tools-0.2.7-16.7.i586.rpm
Source Package pipewire-0.2.7-16.7.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install pipewire-spa-tools rpm package:
    # zypper install pipewire-spa-tools

Files

Path
/usr/bin/spa-inspect
/usr/bin/spa-monitor

Changelog

2019-11-06 - Fabian Vogt <fvogt@suse.com>
- Update to version 0.2.7:
+ Add support for alsa-lib 1.1.9 which changed the include path
+ Improve error checking and reporting in the protocol
+ deviceprovider: fix probing without starting
+ add sentinel to some functions
+ compiler fixes for musl
+ Revert object tree permission checks that broke things, this is
probably not a good idea (and the tree of objects is going to
be removed later)
2019-05-22 - Markus S <kamikazow@opensuse.org>
- Update to version 0.2.6:
+ Improve error checking for threads.
+ Fix some memory and fd leaks.
+ Fix compilation with C++ compilers and clang.
+ DISABLE_RTKIT should now not try to use dbus at all.
+ Camera Portal fixes:
- add Camera media.role.
- Rename module-flatpak to module-portal.
- Use the portal permissions store for camera checks.
+ Actually use the passed fd in pipewiresrc.
+ Make properties with "pipewire." prefix read-only.
+ Add security label to client object.
+ Enforce link permissions.
+ Permissions of objects are now combined with parent
permissions.
+ Remove libv4l2 dependency, it is not used.
+ Improve format negotiation in autolink #146.
+ Try to avoid list corruption with event emmission #143.
+ Fix destroy of client-node memory corruption.
+ Various small improvements.
- Remove pkgconfig(libv4l2) BuildRequires: follow upstreams cleanup
of build dependencies.
- Drop avoid-invalid-conversion-error-with-C++.patch: fixed
upstream.
2019-04-19 - Fabian Vogt <fabian@ritter-vogt.de>
- Add patch to fix use of headers from C++:
* avoid-invalid-conversion-error-with-C++.patch
2019-02-21 - bjorn.lie@gmail.com
- Update to version 0.2.5:
+ Build fixes for systemd.
+ Add cursor and bitmap metadata. This can be used to send a
cursor sprite with the video stream.
+ Permissions were set too strict for non-flatpak clients.
+ Fix crash in loop caused by thread unsafe hook emission.
+ Add more error checking for thread-loop.
+ Small cleanups and bugfixes.
- Drop libspa define and add spa_ver define, and following this
drop libspa-lib1 subpackage, no longer built.
- Drop doxygen BuildRequires and manpages source, follow upstream
in not building docs nor manually installing manpages that have
to be updated every version bump to ensure they are current.
- Add pkgconfig(libsystemd) BuildRequires: New dependency.
- Update options passed to meson following upstream changes.
2018-08-13 - bjorn.lie@gmail.com
- Update to version 0.2.2:
+ Add apiversion to pkgconfig as well.
- Add apiver define and set it to 0.2.
- Bump libpipewire define to libpipewire-0_2-1 and libspa define to
libspa-lib1 following upstream changes.
2018-07-23 - bjorn.lie@gmail.com
- Update to version 0.2.1:
+ stream: update to latest API.
+ hook: add private data for future expansion.
2018-07-17 - alarrosa@suse.com
- Update to version 0.2.0
* No changelog provided by upstream. To see the changes in this
version, please browse the commit logs at
https://github.com/PipeWire/pipewire/commits/0.2.0 .
2018-03-13 - luc14n0@linuxmail.org
- Initial package, version 0.1.9.

See Also

Package Description
pipewire-tools-0.2.7-16.3.x86_64.rpm The PipeWire Tools
pipewire-tools-0.2.7-16.7.i586.rpm The PipeWire Tools
polari-3.34.0-95.4.x86_64.rpm An IRC Client for GNOME
polari-3.34.1-100.4.i586.rpm An IRC Client for GNOME
polari-lang-3.34.0-95.4.noarch.rpm Translations for package polari
polari-lang-3.34.1-100.4.noarch.rpm Translations for package polari
polkit-gnome-0.105-49.28.x86_64.rpm PolicyKit integration for the GNOME desktop
polkit-gnome-0.105-52.1.i586.rpm PolicyKit integration for the GNOME desktop
polkit-gnome-lang-0.105-49.28.noarch.rpm Translations for package polkit-gnome
polkit-gnome-lang-0.105-52.1.noarch.rpm Translations for package polkit-gnome
psiconv-0.9.9-496.26.x86_64.rpm EPOC32 PSION 5(MX) File Format Data Conversion Utilities
psiconv-0.9.9-496.30.i586.rpm EPOC32 PSION 5(MX) File Format Data Conversion Utilities
psiconv-devel-0.9.9-496.26.x86_64.rpm EPOC32 PSION 5(MX) File Format Data Conversion Utilities
psiconv-devel-0.9.9-496.30.i586.rpm EPOC32 PSION 5(MX) File Format Data Conversion Utilities
python-gobject-common-devel-3.34.0-116.4.x86_64.rpm Shared development files for GObject's Python bindings
Advertisement
Advertisement