libxml++-3_0-1-32bit-3.2.0-73.5.x86_64.rpm


Advertisement

Description

libxml++-3_0-1-32bit - C++ Interface for XML Files

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libxml++-3_0-1-32bit-3.2.0-73.5.x86_64.rpm
Package name libxml++-3_0-1-32bit
Package version 3.2.0
Package release 73.5
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://sourceforge.net/projects/libxmlplusplus/
License LGPL-2.1-or-later
Maintainer -
Download size 81.01 KB
Installed size 203.05 KB
libXML++ provides a C++ interface for XML files. It presently uses
libxml2 to access the XML files.

Alternatives

Package Version Architecture Repository
libxml++-3_0-1-32bit-3.2.0-94.5.x86_64.rpm 3.2.0 x86_64 GNOME Next
libxml++-3_0-1-32bit-3.0.1-3.1.x86_64.rpm 3.0.1 x86_64 openSUSE Oss
libxml++-3_0-1-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.3.1) -
libglibmm-2.4.so.1 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.5.0) -
libxml2.so.2(LIBXML2_2.5.2) -
libxml2.so.2(LIBXML2_2.5.7) -
libxml2.so.2(LIBXML2_2.5.8) -
libxml2.so.2(LIBXML2_2.6.0) -
libxml2.so.2(LIBXML2_2.6.15) -
libxml2.so.2(LIBXML2_2.6.2) -
libxml2.so.2(LIBXML2_2.6.20) -
libxml2.so.2(LIBXML2_2.6.3) -

Provides

Name Value
libxml++-3.0.so.1 -
libxml++-3_0-1-32bit = 3.2.0-73.5
libxml++-3_0-1-32bit(x86-32) = 3.2.0-73.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libxml++-3_0-1-32bit-3.2.0-73.5.x86_64.rpm
Source Package libxml++-3.2.0-73.5.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libxml++-3_0-1-32bit rpm package:
    # zypper install libxml++-3_0-1-32bit

Files

Path
/usr/lib/libxml++-3.0.so.1
/usr/lib/libxml++-3.0.so.1.0.0

Changelog

2020-01-11 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 3.2.0:
+ Document, DomParser: Improve XInclude processing:
- Document: Add process_xinclude() overload that takes a
fixup_base_uris parameter.
- DomParser: Add set/get_xinclude_options() and add optional
XInclude processing to the parse methods (bgo#781566).
+ Add explicit keyword to some single-parameter constructors.
+ tests: Don't require C++17.
+ Build: Fix srcdir != buildir build.
- Modernize spec.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2016-11-14 - dimstar@opensuse.org
- Update to version 3.0.1 (jsc#SLE-8163, FATE#324347):
+ Element::remove_attribute(): Delete the C++ wrapper
(bgo#768404).
2016-02-02 - dimstar@opensuse.org
- Update to version 3.0.0:
+ This release is identical to the unstable 2.91.3, except for
the so name, which has now been bumped (bgo#760574).
- Rename libxml++-3_0-0 subpackage to libxml++-3_0-1, following
upstreams soname bump (also in baselibs.conf).
2016-01-12 - zaitor@opensuse.org
- Update to version 2.91.3:
+ Element: Remove a redundant nullptr check (bgo#757515).
+ Use scoped enums (enum class) instead of unscoped enums.
+ Document: Test for nullptr in a constructor.
+ DomParser: Make operator bool() explicit.
+ The ABI and API are not identical to libxml++ 2.91.2.
2015-11-27 - zaitor@opensuse.org
- Update to version 2.91.2:
+ Remove the preprocessor constant LIBXMLCPP_EXCEPTIONS_ENABLED.
It was always 1.
+ Add a config-time test for support of std::exception_ptr. Don't
try to use std::exception_ptr on a system where it does not
exist. This includes re-implementing the wrapped_exception
class and the raise() and clone() methods in xmlpp::exception
and its subclasses (bgo##757042).
+ The ABI is not identical to that of libxml++ 2.91.1. There may
be more changes in ABI and/or API before the first stable
libxml++-3.0 release.
- Changes from version 2.91.1:
+ Renamed ABI from libxml++-2.6 to libxml++-3.0.
+ This requires applications to change their pkg-config check to
libxml++-3.0 when they wish to use libxml++ 2.9x or 3.x instead
of libxml++2.x. (bgo#754673).
+ There may be more changes in ABI and/or API before the first
stable libxml++-3.0 release.
+ Node: Add const_NodeList and use it in a const version of
get_children().
+ Add const_NodeSet and use it in a const version of find().
+ Replace xmlpp::NodeSet by xmlpp::Node::NodeSet.
+ Element: Add const_Attribute_list and use it in a const
version of get_attributes() (bgo#338907).
+ Document: Add a non-const version of get_root_node(). Let the
const version return a const pointer (bgo#632522).
+ Element: Add a non-const version of get_attribute(). Let the
const version return a const pointer (bgo#632524).
+ Replace the deprecated std::auto_ptr by std::unique_ptr
(bgo#753123).
+ DomParser: The default behaviour is to throw both parse errors
and validity errors in an exception instead of printing some
messages on stderr.
+ Parser: Some protected data has become private.
+ Several classes: Some virtual methods have become non-virtual,
and some non-virtual methods have become virtual.
+ Remove class xmlpp::wrapped_exception and the deprecated
classes Schema and SchemaValidator.
+ xmlpp::exception and its subclasses: Remove Raise() and
Clone().
+ SaxParser: Start each parsing with a new Document for entity
resolution.
+ Move all Node::add_child*() methods to Element and rename them
to add_child_element*().
+ Attribute: Move set_value() to AttributeNode.
+ Use std::string instead of Glib::ustring for filenames.
+ Node: Replace remove_child() by remove_node().
+ Move some code from DtdValidator to Dtd.
+ Element: Rename set/get_child_text() to
set/get_first_child_text().
+ Rename subpackages following upstreams soname bump.
+ Bump version in baselibs.conf.
2015-09-30 - zaitor@opensuse.org
- Update to version 2.40.0:
+ Build improvements.

See Also

Package Description
libxml++-devel-3.0.1-72.6.x86_64.rpm C++ Interface for XML Files -- Development Files
libxml++-devel-3.2.0-73.5.i586.rpm C++ Interface for XML Files -- Development Files
libxml++26-devel-2.40.1-6.30.x86_64.rpm C++ Interface for XML Files -- Development Files
libxml++26-devel-2.40.1-6.36.i586.rpm C++ Interface for XML Files -- Development Files
libyelp0-3.34.0-186.5.x86_64.rpm Core library for the GNOME Desktop help browser
libyelp0-3.34.0-189.1.i586.rpm Core library for the GNOME Desktop help browser
libzapojit-0_0-0-0.0.3-14.25.x86_64.rpm Library for the SkyDrive and Hotmail REST APIs
libzapojit-0_0-0-0.0.3-14.26.i586.rpm Library for the SkyDrive and Hotmail REST APIs
libzapojit-devel-0.0.3-14.25.x86_64.rpm Library for the SkyDrive and Hotmail REST APIs -- Development Files
libzapojit-devel-0.0.3-14.26.i586.rpm Library for the SkyDrive and Hotmail REST APIs -- Development Files
libzeitgeist-1_0-1-0.3.18-26.25.x86_64.rpm Client library for interacting with the Zeitgeist daemon
libzeitgeist-1_0-1-0.3.18-26.30.i586.rpm Client library for interacting with the Zeitgeist daemon
libzeitgeist-1_0-1-32bit-0.3.18-26.30.x86_64.rpm Client library for interacting with the Zeitgeist daemon
libzeitgeist-2_0-0-1.0.2-82.30.x86_64.rpm Client library for interacting with the Zeitgeist daemon
libzeitgeist-2_0-0-1.0.2-82.35.i586.rpm Client library for interacting with the Zeitgeist daemon
Advertisement
Advertisement