libxklavier16-5.3-48.36.i586.rpm


Advertisement

Description

libxklavier16 - Library with X keyboard related functions

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libxklavier16-5.3-48.36.i586.rpm
Package name libxklavier16
Package version 5.3
Package release 48.36
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.freedesktop.org/Software/LibXklavier
License LGPL-2.0-or-later
Maintainer -
Download size 63.22 KB
Installed size 138.97 KB
This library allows you to simplify XKB-related development.

Alternatives

Package Version Architecture Repository
libxklavier16-5.3-54.40.i586.rpm 5.3 i586 GNOME Next
libxklavier16-5.3-54.40.x86_64.rpm 5.3 x86_64 GNOME Next
libxklavier16-5.3-48.30.x86_64.rpm 5.3 x86_64 GNOME Factory
libxklavier16-5.3-10.7.i586.rpm 5.3 i586 openSUSE Oss
libxklavier16-5.3-10.7.x86_64.rpm 5.3 x86_64 openSUSE Oss
libxklavier16 - - -

Requires

Name Value
/sbin/ldconfig -
iso-codes -
libX11.so.6 -
libXi.so.6 -
libc.so.6(GLIBC_2.4) -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libxkbfile.so.1 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.6.0) -

Provides

Name Value
libxklavier = 5.3
libxklavier.so.16 -
libxklavier16 = 5.3-48.36
libxklavier16(x86-32) = 5.3-48.36

Obsoletes

Name Value
libxklavier < 5.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libxklavier16-5.3-48.36.i586.rpm
Source Package libxklavier-5.3-48.36.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libxklavier16 rpm package:
    # zypper install libxklavier16

Files

Path
/usr/lib/libxklavier.so.16
/usr/lib/libxklavier.so.16.3.0
/usr/share/doc/packages/libxklavier16/AUTHORS
/usr/share/doc/packages/libxklavier16/CREDITS
/usr/share/doc/packages/libxklavier16/ChangeLog
/usr/share/doc/packages/libxklavier16/NEWS
/usr/share/doc/packages/libxklavier16/README
/usr/share/licenses/libxklavier16/COPYING.LIB

Changelog

2018-03-05 - jengelh@inai.de
- Fix RPM groups. Update summaries. Remove --with-pic.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2016-02-01 - dimstar@opensuse.org
- Pass --with-xkb-bin-base=%{_bindir} to configure: we know that
xkbcomp is installed there (boo#964360).
- Add xkbcomp Requires to libxklavier16: the xkbcomp binary is
required for proper functioning of the library.
2014-10-18 - crrodriguez@opensuse.org
- Discontinue the use of xorg-x11-devel metapackage, just
buildrequire pkgconfig(xi), pkgconfig(x11), pkgconfig(xkbfile).
2012-09-24 - dimstar@opensuse.org
- Update to version 5.3:
+  A number of introspection and build fixes.
2012-02-16 - dimstar@opensuse.org
- Update to version 5.2.1:
+ Fixed GIR params for introspection (broken build)
- Remove xz BuildRequires now that it comes for free in the build
system.
- Drop libxklavier-fix-gir-build.patch: fixed upstream.
- Change glib2-devel and libxml2-devel BuildRequires to their
pkgconfig() equivalents: glib-2.0 and libxml-2.0.
- Clean spec file using spec-cleaner.
2012-01-26 - vuntz@opensuse.org
- license update: LGPL-2.0+
No indication of GPL-2.0+ tools or utilities (apart from
configure, etc.)
2012-01-18 - vuntz@opensuse.org
- Update to version 5.2:
+ Optional introspection introduced
+ Some minor fixes (runtime and build-time)
- Add xz BuildRequires because we can't build a package for a
xz-compressed tarball without explicitly specifying that... See
bnc#697467 for more details.
- Add gobject-introspection-devel BuildRequires to build
introspection support.
- Add libxklavier-fix-gir-build.patch to fix build of introspection
support.
- Create typelib-1_0-Xkl-1_0 subpackage for typelib file.
- Add typelib-1_0-Xkl-1_0 Requires to devel subpackage.
- Remove glib2-devel and libxml2-devel Requires from devel
subpackage: they will automatically be added the pkgconfig() way.
- Remove Requires for the XFree86-devel provider from devel
subpackage: it's not needed according to the pkgconfig file.
- Change group of libxklavier16 from Development/Libraries/X11 to
System/Libraries.
2011-10-06 - vuntz@opensuse.org
- Add iso-codes Requires to libxklavier16 since the iso-codes data
is used at runtime.
2011-04-19 - ro@suse.de
- Update baselibs.conf (libxklavier16 instead of libxklavier12)

See Also

Package Description
libxml++-2_6-2-2.40.1-6.30.x86_64.rpm C++ Interface for XML Files
libxml++-2_6-2-2.40.1-6.36.i586.rpm C++ Interface for XML Files
libxml++-2_6-2-32bit-2.40.1-6.36.x86_64.rpm C++ Interface for XML Files
libxml++-3_0-1-3.0.1-72.6.x86_64.rpm C++ Interface for XML Files
libxml++-3_0-1-3.2.0-73.5.i586.rpm C++ Interface for XML Files
libxml++-3_0-1-32bit-3.2.0-73.5.x86_64.rpm C++ Interface for XML Files
libxml++-devel-3.0.1-72.6.x86_64.rpm C++ Interface for XML Files -- Development Files
libxml++-devel-3.2.0-73.5.i586.rpm C++ Interface for XML Files -- Development Files
libxml++26-devel-2.40.1-6.30.x86_64.rpm C++ Interface for XML Files -- Development Files
libxml++26-devel-2.40.1-6.36.i586.rpm C++ Interface for XML Files -- Development Files
libyelp0-3.34.0-186.5.x86_64.rpm Core library for the GNOME Desktop help browser
libyelp0-3.34.0-189.1.i586.rpm Core library for the GNOME Desktop help browser
libzapojit-0_0-0-0.0.3-14.25.x86_64.rpm Library for the SkyDrive and Hotmail REST APIs
libzapojit-0_0-0-0.0.3-14.26.i586.rpm Library for the SkyDrive and Hotmail REST APIs
libzapojit-devel-0.0.3-14.25.x86_64.rpm Library for the SkyDrive and Hotmail REST APIs -- Development Files
Advertisement
Advertisement