libwpe-devel-1.4.0.1-7.9.i586.rpm


Advertisement

Description

libwpe-devel - Development files for libwpe

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libwpe-devel-1.4.0.1-7.9.i586.rpm
Package name libwpe-devel
Package version 1.4.0.1
Package release 7.9
Package architecture i586
Package type rpm
Homepage https://github.com/WebPlatformForEmbedded/libwpe
License BSD-2-Clause
Maintainer -
Download size 38.66 KB
Installed size 229.51 KB
The libwpe-devel package contains libraries, build data, and
header files for developing applications that use libwpe.

Alternatives

Package Version Architecture Repository
libwpe-devel-1.4.0.1-22.9.i586.rpm 1.4.0.1 i586 GNOME Next
libwpe-devel-1.4.0.1-22.9.x86_64.rpm 1.4.0.1 x86_64 GNOME Next
libwpe-devel-1.4.0.1-7.4.x86_64.rpm 1.4.0.1 x86_64 GNOME Factory
libwpe-devel-1.4.0.1-1.1.i586.rpm 1.4.0.1 i586 openSUSE Oss
libwpe-devel-1.4.0.1-1.1.x86_64.rpm 1.4.0.1 x86_64 openSUSE Oss
libwpe-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libwpe-1_0-1 = 1.4.0.1
pkgconfig(xkbcommon) -

Provides

Name Value
libwpe-devel = 1.4.0.1-7.9
libwpe-devel(x86-32) = 1.4.0.1-7.9
pkgconfig(wpe-1.0) = 1.4.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libwpe-devel-1.4.0.1-7.9.i586.rpm
Source Package libwpe-1.4.0.1-7.9.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libwpe-devel rpm package:
    # zypper install libwpe-devel

Files

Path
/usr/include/wpe-1.0/
/usr/include/wpe-1.0/wpe/export.h
/usr/include/wpe-1.0/wpe/input.h
/usr/include/wpe-1.0/wpe/keysyms.h
/usr/include/wpe-1.0/wpe/loader.h
/usr/include/wpe-1.0/wpe/pasteboard.h
/usr/include/wpe-1.0/wpe/renderer-backend-egl.h
/usr/include/wpe-1.0/wpe/renderer-host.h
/usr/include/wpe-1.0/wpe/version-deprecated.h
/usr/include/wpe-1.0/wpe/version.h
/usr/include/wpe-1.0/wpe/view-backend.h
/usr/include/wpe-1.0/wpe/wpe-egl.h
/usr/include/wpe-1.0/wpe/wpe.h
/usr/lib/libwpe-1.0.so
/usr/lib/pkgconfig/wpe-1.0.pc

Changelog

2019-10-05 - Bjørn Lie <bjorn.lie@gmail.com>
- Add baselibs.conf, build 32-bit support lib.
2019-10-03 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 1.4.0.1:
+ Fix the version numbers to ensure 1.4.0 is used when building
from tarballs.
- Drop no longer needed Group tag.
2019-09-19 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 1.4.0:
+ New API to set the device scaling factor. Backends and WebKit
embedders can use this to e.g. support HiDPI displays.
+ New API to to obtain the root accessibility object for a view
backend.
+ API reference documentation can now be built with HotDoc.
Descriptions for most functionality is still missing, though.
+ Fix build failure on systems where libxkbcommon has its headers
installed in a non-standard location.
2019-09-17 - Michael Gorse <mgorse@suse.com>
- Update to version 1.3.91:
+ Enabled compiler warnings.
+ Fix build failure on systems where libxkbcommon has its headers
installed in a non-standard location.
+ Fix documentation build.
- Drop libwpe-fix-include-dir.patch: fixed upstream.
2019-07-24 - Bjørn Lie <bjorn.lie@gmail.com>
- Initial packaging for openSUSE, version 1.3.1.

See Also

Package Description
libxklavier-devel-5.3-48.30.x86_64.rpm Development files for libxklavier
libxklavier-devel-5.3-48.36.i586.rpm Development files for libxklavier
libxklavier-doc-5.3-48.30.x86_64.rpm Additional Package Documentation for libxklavier
libxklavier-doc-5.3-48.36.i586.rpm Additional Package Documentation for libxklavier
libxklavier16-32bit-5.3-48.36.x86_64.rpm Library with X keyboard related functions
libxklavier16-5.3-48.30.x86_64.rpm Library with X keyboard related functions
libxklavier16-5.3-48.36.i586.rpm Library with X keyboard related functions
libxml++-2_6-2-2.40.1-6.30.x86_64.rpm C++ Interface for XML Files
libxml++-2_6-2-2.40.1-6.36.i586.rpm C++ Interface for XML Files
libxml++-2_6-2-32bit-2.40.1-6.36.x86_64.rpm C++ Interface for XML Files
libxml++-3_0-1-3.0.1-72.6.x86_64.rpm C++ Interface for XML Files
libxml++-3_0-1-3.2.0-73.5.i586.rpm C++ Interface for XML Files
libxml++-3_0-1-32bit-3.2.0-73.5.x86_64.rpm C++ Interface for XML Files
libxml++-devel-3.0.1-72.6.x86_64.rpm C++ Interface for XML Files -- Development Files
libxml++-devel-3.2.0-73.5.i586.rpm C++ Interface for XML Files -- Development Files
Advertisement
Advertisement