libwnck-1-22-2.31.0-28.3.i586.rpm


Advertisement

Description

libwnck-1-22 - Window Navigator Construction Kit (Library Package)

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libwnck-1-22-2.31.0-28.3.i586.rpm
Package name libwnck-1-22
Package version 2.31.0
Package release 28.3
Package architecture i586
Package type rpm
Category Development/Libraries/GNOME
Homepage -
License LGPL-2.1-or-later
Maintainer -
Download size 145.55 KB
Installed size 386.21 KB
The Window Navigator Construction Kit is a library that can be used to
write task lists, pagers, and similar GNOME programs.

Alternatives

Package Version Architecture Repository
libwnck-1-22-2.31.0-33.3.i586.rpm 2.31.0 i586 GNOME Next
libwnck-1-22-2.31.0-33.3.x86_64.rpm 2.31.0 x86_64 GNOME Next
libwnck-1-22-2.31.0-25.27.x86_64.rpm 2.31.0 x86_64 GNOME Factory
libwnck-1-22-2.31.0-10.6.i586.rpm 2.31.0 i586 openSUSE Oss
libwnck-1-22-2.31.0-10.6.x86_64.rpm 2.31.0 x86_64 openSUSE Oss
libwnck-1-22 - - -

Requires

Name Value
/sbin/ldconfig -
libX11.so.6 -
libXRes.so.1 -
libatk-1.0.so.0 -
libc.so.6(GLIBC_2.7) -
libcairo.so.2 -
libgdk-x11-2.0.so.0 -
libgdk_pixbuf-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgtk-x11-2.0.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpango-1.0.so.0 -
libstartup-notification-1.so.0 -

Provides

Name Value
libwnck-1-22 = 2.31.0-28.3
libwnck-1-22(x86-32) = 2.31.0-28.3
libwnck-1.so.22 -
libwnck2 = 2.31.0

Obsoletes

Name Value
libwnck2 < 2.31.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libwnck-1-22-2.31.0-28.3.i586.rpm
Source Package libwnck2-2.31.0-28.3.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libwnck-1-22 rpm package:
    # zypper install libwnck-1-22

Files

Path
/usr/lib/libwnck-1.so.22
/usr/lib/libwnck-1.so.22.4.0
/usr/share/doc/packages/libwnck-1-22/AUTHORS
/usr/share/doc/packages/libwnck-1-22/ChangeLog
/usr/share/doc/packages/libwnck-1-22/NEWS
/usr/share/doc/packages/libwnck-1-22/README
/usr/share/licenses/libwnck-1-22/COPYING

Changelog

2020-01-25 - Dominique Leuenberger <dimstar@opensuse.org>
- No longer recommend -lang: supplements are in use
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2012-03-07 - praful.johari@gmail.com
- Update to version 2.31.0:
+ Add wnck_pager_set_layout_policy() API.
+ Add macros to determine libwnck version at build time.
2012-02-20 - vuntz@opensuse.org
- Add explicit pkgconfig(x11) and pkgconfig(xres) BuildRequires, to
avoid issues after the big xorg-x11 packaging change.
2011-12-09 - dimstar@opensuse.org
- Split typelib file into typelib-1_0-Wnck-1_0 subpackage.
- Add typelib-1_0-Wnck-1_0 Requires to devel subpackage.
2011-10-17 - vuntz@opensuse.org
- Add libwnck2 Obsoletes to libwnck-1-22, since we dropped the
libwnck2 subpackage back in April, but forgot the Obsoletes (the
Provides is there already).
2011-08-31 - vuntz@opensuse.org
- Update to version 2.30.7:
+ Misc:
- Link against libX11
- Link against libm
+ Updated translations.
2011-05-04 - vuntz@opensuse.org
- Fix License tag of devel subpackage to be LGPLv2.1+ instead of
GPLv2+. Fix bnc#691447.
2011-04-21 - vuntz@opensuse.org
- Add missing startup-notification-devel BuildRequires.
- Remove wnck-urgency-monitor and wnckprop binaries, as they will
now be provided by the GTK+ 3 version of libwnck. This means we
have no libwnck2 binary package anymore.
- Add a libwnck2 Provides to libwnck-1-22 to make the lang package
installable.
- Change libwnck2 Requires in devel package to libwnck-1-22.
- Drop old Obsoletes/Provides for libwnck2-64bit,
libwnck2-devel-64bit and libwnck2-doc after the renaming, since
those packages never existed.
- Remove explicit Requires for glib2-devel and gtk2-devel in devel
package: they will be added automatically the pkg-config way.
2011-04-06 - fcrozat@novell.com
- Rename package to libwnck2 and adapt specfile accordingly.

See Also

Package Description
libwnck-1-22-32bit-2.31.0-28.3.x86_64.rpm Window Navigator Construction Kit (Library Package)
libwnck-3-0-3.32.0-124.14.x86_64.rpm Window Navigator Construction Kit (Library Package)
libwnck-3-0-3.32.0-127.3.i586.rpm Window Navigator Construction Kit (Library Package)
libwnck-3-0-32bit-3.32.0-127.3.x86_64.rpm Window Navigator Construction Kit (Library Package)
libwnck-devel-3.32.0-124.14.x86_64.rpm Include Files and Libraries mandatory for Development
libwnck-devel-3.32.0-127.3.i586.rpm Include Files and Libraries mandatory for Development
libwnck-lang-3.32.0-124.14.noarch.rpm Translations for package libwnck
libwnck-lang-3.32.0-127.3.noarch.rpm Translations for package libwnck
libwnck-tools-3.32.0-124.14.x86_64.rpm Window Navigator Construction Kit -- Tools
libwnck-tools-3.32.0-127.3.i586.rpm Window Navigator Construction Kit -- Tools
libwnck2-devel-2.31.0-25.27.x86_64.rpm Include Files and Libraries mandatory for Development
libwnck2-devel-2.31.0-28.3.i586.rpm Include Files and Libraries mandatory for Development
libwnck2-lang-2.31.0-25.27.noarch.rpm Translations for package libwnck2
libwnck2-lang-2.31.0-28.3.noarch.rpm Translations for package libwnck2
libwpe-1_0-1-1.4.0.1-7.4.x86_64.rpm Shared library for libwpe
Advertisement
Advertisement