libtotem-plparser18-3.26.3-140.2.x86_64.rpm


Advertisement

Description

libtotem-plparser18 - A GObject-based library to parse playlist formats

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory all
Package filename libtotem-plparser18-3.26.3-140.2.x86_64.rpm
Package name libtotem-plparser18
Package version 3.26.3
Package release 140.2
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.gnome.org/projects/totem/
License LGPL-2.0-or-later AND GPL-2.0-or-later
Maintainer -
Download size 71.97 KB
Installed size 181.18 KB
totem-pl-parser is a GObject-based library to parse a host of
playlist formats, to save them too.

Alternatives

Package Version Architecture Repository
libtotem-plparser18-3.26.3-184.2.x86_64.rpm 3.26.3 x86_64 GNOME Next
libtotem-plparser18-3.26.3-184.2.i586.rpm 3.26.3 i586 GNOME Next
libtotem-plparser18-3.26.3-140.2.i586.rpm 3.26.3 i586 GNOME Factory
libtotem-plparser18-3.26.3-1.1.x86_64.rpm 3.26.3 x86_64 openSUSE Oss
libtotem-plparser18-3.26.3-1.1.i586.rpm 3.26.3 i586 openSUSE Oss
libtotem-plparser18 - - -

Requires

Name Value
/sbin/ldconfig -
libarchive.so.13()(64bit) -
libc.so.6(GLIBC_2.8)(64bit) -
libgcrypt.so.20()(64bit) -
libgcrypt.so.20(GCRYPT_1.6)(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libpthread.so.0()(64bit) -
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -
totem-pl-parser >= 3.26.3

Provides

Name Value
libtotem-plparser.so.18()(64bit) -
libtotem-plparser.so.18(LIBTOTEM_PL_PARSER_MINI_1.0)(64bit) -
libtotem-plparser18 = 3.26.3-140.2
libtotem-plparser18(x86-64) = 3.26.3-140.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libtotem-plparser18-3.26.3-140.2.x86_64.rpm
Source Package totem-pl-parser-3.26.3-140.2.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libtotem-plparser18 rpm package:
    # zypper install libtotem-plparser18

Files

Path
/usr/lib64/libtotem-plparser.so.18
/usr/lib64/libtotem-plparser.so.18.1.4
/usr/share/licenses/libtotem-plparser18/COPYING.LIB

Changelog

2019-03-05 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 3.26.3:
+ Atom parsing bug fixes.
2019-01-16 - bjorn.lie@gmail.com
- Update to version 3.26.2:
+ tests: Update for podcast URL change
+ build: honor 'includedir' meson parameter
+ Updated translations.
- Add revision to _service file, check out explicit released tag.
2018-07-28 - bjorn.lie@gmail.com
- Update to version 3.26.1+20180713.b7f36dd:
+ build: Add CI
+ podcast: Remove GMIME dependency
- Drop pkgconfig(gmime-3.0) BuildRequires and stop passing
disable-gmime-i-know-what-im-doing=false to meson: No longer
needed after upstream changes.
2018-06-15 - bjorn.lie@gmail.com
- Update to version 3.26.1+20180614.d22b155:
+ docs: Add headers to the ignore list
+ core: Fix compile-time warnings in XML parser
+ Update translations.
- Update service to point to new gitlab home.
2018-04-10 - jengelh@inai.de
- Ensure neutrality of descriptions. Update summaries.
2018-03-22 - bjorn.lie@gmail.com
- Update to version 3.26.0+20180301.0091a56:
+ plparse: Don't consider MJPEG streams as JPEG images.
+ build: Remove libsoup dependency.
+ podcast: Add support for "medium" property.
+ videosite: Fix leak in totem_pl_parser_add_videosite.
+ Updated translations.
- Switch to git checkout via source service.
- Drop pkgconfig(libsoup-2.4) BuildRequires following upstreams
changes.
- Use autosetup macro.
- Pass explicit disable-gmime-i-know-what-im-doing=false,
enable-quvi=yes, enable-libarchive=yes and enable-libgcrypt=yes
to meson, make sure we build the features we want.
2018-03-20 - dimstar@opensuse.org
- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).
2018-02-26 - dimstar@opensuse.org
- Use SPDX3.0 license tags and package COPYING as %license.
2017-09-14 - zaitor@opensuse.org
- Update to version 3.26.0:
+ Updated translations.
2017-08-29 - dimstar@opensuse.org
- Update license following legal review: LGPL-2.1+ AND GPL-2.0+.

See Also

Package Description
libtpl-extensions3-0.8.2-48.22.i586.rpm Extensions for the Telepathy Framework Centralized Logging
libtpl-extensions3-0.8.2-48.22.x86_64.rpm Extensions for the Telepathy Framework Centralized Logging
libtracker-common-2_0-2.2.1-185.5.i586.rpm Convenience libraries for Tracker
libtracker-common-2_0-2.2.1-185.5.x86_64.rpm Convenience libraries for Tracker
libtracker-control-2_0-0-2.2.1-185.5.i586.rpm Control library for Tracker
libtracker-control-2_0-0-2.2.1-185.5.x86_64.rpm Control library for Tracker
libtracker-miner-2_0-0-2.2.1-185.5.i586.rpm Miner library for Tracker
libtracker-miner-2_0-0-2.2.1-185.5.x86_64.rpm Miner library for Tracker
libtracker-sparql-2_0-0-2.2.1-185.5.i586.rpm Sparql library for Tracker
libtracker-sparql-2_0-0-2.2.1-185.5.x86_64.rpm Sparql library for Tracker
libuhttpmock-0_0-0-0.5.1-15.6.i586.rpm HTTP web service mocking library
libuhttpmock-0_0-0-0.5.1-15.6.x86_64.rpm HTTP web service mocking library
libunique-1_0-0-1.1.6-41.13.i586.rpm A library for writing single instance applications
libunique-1_0-0-1.1.6-41.13.x86_64.rpm A library for writing single instance applications
libunique1-devel-1.1.6-41.13.i586.rpm Development files for libunique
Advertisement
Advertisement