libsoup-devel-2.68.3-248.3.i586.rpm


Advertisement

Description

libsoup-devel - HTTP client/server library for GNOME - Development Files

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libsoup-devel-2.68.3-248.3.i586.rpm
Package name libsoup-devel
Package version 2.68.3
Package release 248.3
Package architecture i586
Package type rpm
Category Development/Libraries/GNOME
Homepage https://wiki.gnome.org/Projects/libsoup
License LGPL-2.1-or-later
Maintainer -
Download size 425.12 KB
Installed size 3.73 MB
Libsoup is an HTTP client/server library for GNOME. It uses GObjects
and the glib main loop, to integrate well with GNOME applications.
Features:
* Both asynchronous (GMainLoop and callback-based) and synchronous APIs
* Automatically caches connections
* SSL Support using GnuTLS
* Proxy support, including authentication and SSL tunneling
* Client support for Digest, NTLM, and Basic authentication
* Server support for Digest and Basic authentication
* XML-RPC support

Alternatives

Package Version Architecture Repository
libsoup-devel-2.68.3-389.3.i586.rpm 2.68.3 i586 GNOME Next
libsoup-devel-2.68.3-389.3.x86_64.rpm 2.68.3 x86_64 GNOME Next
libsoup-devel-2.68.3-239.1.x86_64.rpm 2.68.3 x86_64 GNOME Factory
libsoup-devel-2.68.3-2.1.i586.rpm 2.68.3 i586 openSUSE Oss
libsoup-devel-2.68.3-2.1.x86_64.rpm 2.68.3 x86_64 openSUSE Oss
libsoup-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libsoup = 2.68.3
pkgconfig(gio-2.0) >= 2.38
pkgconfig(glib-2.0) >= 2.38
pkgconfig(gobject-2.0) >= 2.38
pkgconfig(libbrotlidec) -
pkgconfig(libpsl) >= 0.20
pkgconfig(libsoup-2.4) -
pkgconfig(libxml-2.0) -
pkgconfig(sqlite3) -
pkgconfig(zlib) -
typelib-1_0-Soup-2_4 = 2.68.3

Provides

Name Value
libsoup-devel = 2.68.3-248.3
libsoup-devel(x86-32) = 2.68.3-248.3
libsoup-doc = 2.68.3
pkgconfig(libsoup-2.4) = 2.68.3
pkgconfig(libsoup-gnome-2.4) = 2.68.3

Obsoletes

Name Value
libsoup-doc < 2.68.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libsoup-devel-2.68.3-248.3.i586.rpm
Source Package libsoup-2.68.3-248.3.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libsoup-devel rpm package:
    # zypper install libsoup-devel

Files

Path
/usr/include/libsoup-2.4/
/usr/include/libsoup-2.4/libsoup/soup-address.h
/usr/include/libsoup-2.4/libsoup/soup-auth-domain-basic.h
/usr/include/libsoup-2.4/libsoup/soup-auth-domain-digest.h
/usr/include/libsoup-2.4/libsoup/soup-auth-domain.h
/usr/include/libsoup-2.4/libsoup/soup-auth-manager.h
/usr/include/libsoup-2.4/libsoup/soup-auth.h
/usr/include/libsoup-2.4/libsoup/soup-autocleanups.h
/usr/include/libsoup-2.4/libsoup/soup-cache.h
/usr/include/libsoup-2.4/libsoup/soup-content-decoder.h
/usr/include/libsoup-2.4/libsoup/soup-content-sniffer.h
/usr/include/libsoup-2.4/libsoup/soup-cookie-jar-db.h
/usr/include/libsoup-2.4/libsoup/soup-cookie-jar-text.h
/usr/include/libsoup-2.4/libsoup/soup-cookie-jar.h
/usr/include/libsoup-2.4/libsoup/soup-cookie.h
/usr/include/libsoup-2.4/libsoup/soup-date.h
/usr/include/libsoup-2.4/libsoup/soup-enum-types.h
/usr/include/libsoup-2.4/libsoup/soup-form.h
/usr/include/libsoup-2.4/libsoup/soup-headers.h
/usr/include/libsoup-2.4/libsoup/soup-hsts-enforcer-db.h
/usr/include/libsoup-2.4/libsoup/soup-hsts-enforcer.h
/usr/include/libsoup-2.4/libsoup/soup-hsts-policy.h
/usr/include/libsoup-2.4/libsoup/soup-logger.h
/usr/include/libsoup-2.4/libsoup/soup-message-body.h
/usr/include/libsoup-2.4/libsoup/soup-message-headers.h
/usr/include/libsoup-2.4/libsoup/soup-message.h
/usr/include/libsoup-2.4/libsoup/soup-method.h
/usr/include/libsoup-2.4/libsoup/soup-misc.h
/usr/include/libsoup-2.4/libsoup/soup-multipart-input-stream.h
/usr/include/libsoup-2.4/libsoup/soup-multipart.h
/usr/include/libsoup-2.4/libsoup/soup-password-manager.h
/usr/include/libsoup-2.4/libsoup/soup-portability.h
/usr/include/libsoup-2.4/libsoup/soup-proxy-resolver-default.h
/usr/include/libsoup-2.4/libsoup/soup-proxy-resolver.h
/usr/include/libsoup-2.4/libsoup/soup-proxy-uri-resolver.h
/usr/include/libsoup-2.4/libsoup/soup-request-data.h
/usr/include/libsoup-2.4/libsoup/soup-request-file.h
/usr/include/libsoup-2.4/libsoup/soup-request-http.h
/usr/include/libsoup-2.4/libsoup/soup-request.h
/usr/include/libsoup-2.4/libsoup/soup-requester.h
/usr/include/libsoup-2.4/libsoup/soup-server.h
/usr/include/libsoup-2.4/libsoup/soup-session-async.h
/usr/include/libsoup-2.4/libsoup/soup-session-feature.h
/usr/include/libsoup-2.4/libsoup/soup-session-sync.h
/usr/include/libsoup-2.4/libsoup/soup-session.h
/usr/include/libsoup-2.4/libsoup/soup-socket.h
/usr/include/libsoup-2.4/libsoup/soup-status.h
/usr/include/libsoup-2.4/libsoup/soup-tld.h
/usr/include/libsoup-2.4/libsoup/soup-types.h
/usr/include/libsoup-2.4/libsoup/soup-uri.h
/usr/include/libsoup-2.4/libsoup/soup-value-utils.h
/usr/include/libsoup-2.4/libsoup/soup-version.h
/usr/include/libsoup-2.4/libsoup/soup-websocket-connection.h
/usr/include/libsoup-2.4/libsoup/soup-websocket-extension-deflate.h
/usr/include/libsoup-2.4/libsoup/soup-websocket-extension-manager.h
/usr/include/libsoup-2.4/libsoup/soup-websocket-extension.h
/usr/include/libsoup-2.4/libsoup/soup-websocket.h
/usr/include/libsoup-2.4/libsoup/soup-xmlrpc-old.h
/usr/include/libsoup-2.4/libsoup/soup-xmlrpc.h
/usr/include/libsoup-2.4/libsoup/soup.h
/usr/include/libsoup-gnome-2.4/
/usr/include/libsoup-gnome-2.4/libsoup/soup-cookie-jar-sqlite.h
/usr/include/libsoup-gnome-2.4/libsoup/soup-gnome-features.h
/usr/include/libsoup-gnome-2.4/libsoup/soup-gnome.h
/usr/lib/libsoup-2.4.so
/usr/lib/libsoup-gnome-2.4.so
/usr/lib/pkgconfig/libsoup-2.4.pc
/usr/lib/pkgconfig/libsoup-gnome-2.4.pc
/usr/share/doc/packages/libsoup-devel/AUTHORS
/usr/share/doc/packages/libsoup-devel/README
/usr/share/gir-1.0/Soup-2.4.gir
/usr/share/gir-1.0/SoupGNOME-2.4.gir
/usr/share/gtk-doc/html/libsoup-2.4/SoupAddress.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupAuth.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupAuthDomain.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupAuthDomainBasic.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupAuthDomainDigest.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupAuthManager.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupCache.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupContentDecoder.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupContentSniffer.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupCookie.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupCookieJar.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupCookieJarDB.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupCookieJarText.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupHSTSEnforcer.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupHSTSEnforcerDB.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupLogger.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupMessage.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupMessageBody.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupMessageHeaders.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupMultipart.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupMultipartInputStream.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupProxyResolverDefault.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupRequest.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupRequestData.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupRequestFile.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupRequestHTTP.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupServer.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupSession.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupSessionAsync.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupSessionFeature.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupSessionSync.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupSocket.html
/usr/share/gtk-doc/html/libsoup-2.4/SoupURI.html
/usr/share/gtk-doc/html/libsoup-2.4/annotation-glossary.html
/usr/share/gtk-doc/html/libsoup-2.4/ch01.html
/usr/share/gtk-doc/html/libsoup-2.4/ch02.html
/usr/share/gtk-doc/html/libsoup-2.4/ch03.html
/usr/share/gtk-doc/html/libsoup-2.4/ch04.html
/usr/share/gtk-doc/html/libsoup-2.4/ch05.html
/usr/share/gtk-doc/html/libsoup-2.4/home.png
/usr/share/gtk-doc/html/libsoup-2.4/index.html
/usr/share/gtk-doc/html/libsoup-2.4/ix01.html
/usr/share/gtk-doc/html/libsoup-2.4/left-insensitive.png
/usr/share/gtk-doc/html/libsoup-2.4/left.png
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4-HTML-Form-Support.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4-Soup-Miscellaneous-Utilities.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4-SoupServer-deprecated-API.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4-Top-Level-Domain-utils.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4-Version-Information.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4-WebSockets.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4-XMLRPC-Support.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4-soup-method.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4-soup-status.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-2.4.devhelp2
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-build-howto.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-client-howto.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-request-howto.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-server-howto.html
/usr/share/gtk-doc/html/libsoup-2.4/libsoup-session-porting.html
/usr/share/gtk-doc/html/libsoup-2.4/right-insensitive.png
/usr/share/gtk-doc/html/libsoup-2.4/right.png
/usr/share/gtk-doc/html/libsoup-2.4/style.css
/usr/share/gtk-doc/html/libsoup-2.4/up-insensitive.png
/usr/share/gtk-doc/html/libsoup-2.4/up.png
/usr/share/vala/vapi/libsoup-2.4.deps
/usr/share/vala/vapi/libsoup-2.4.vapi

Changelog

2020-01-25 - Dominique Leuenberger <dimstar@opensuse.org>
- No longer recommend -lang: supplements are in use
2020-01-09 - olaf@aepfle.de
- Usage of g_canonicalize_filename requires glib 2.58
2019-12-20 - olaf@aepfle.de
- meson >=0.50 is required for building
2019-12-04 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.68.3:
+ Fixes to testing infrastructure.
+ Enable GNOME support in mingw.
+ Allow introspection in cross builds.
+ Updated translations.
2019-10-15 - Dominique Leuenberger <dimstar@opensuse.org>
- Disable NTLM for the time being (causes build cycle):
+ Drop samba-winbind BuildRequires.
+ Pass -Dntlm=disabled to meson.
2019-10-09 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.68.2:
+ Documentation fixes.
+ Windows compatibility test fixes.
+ WebSockets: client_max_window_bits in server must have a value.
+ build: improve diagnostics when detecting Apache.
+ NTLM: Make v2 authentication more robust.
+ Updated translations.
2019-09-12 - Michael Gorse <mgorse@suse.com>
- Update to version 2.68.1:
+ Several memory leaks fixed in tests, examples, and parsing
code.
+ SoupServer: Fixes to Windows path handling.
+ Changes in version 2.68.0:
+ Updated translations.
+ Changes in version 2.67.93:
+ SoupMessage: Handle Transfer-Encoding: identity for
compatibility reasons.
+ WebSockets: Only poll IO stream when needed.
+ WebSockets: Properly set cookies received during handshake.
+ WebSockets: Plug a couple of memory leaks and fix a few
read-after-free memory errors.
+ WebSockets: document how web socket extensions should treat
buffers in case of error.
+ SoupSession: Don't reset user GCancellable internally.
+ Tests: Make tests installable.
+ Remove deprecate GTimeVal internal usage.
+ CI: increase coverage by enabling all features during testing.
+ Updated translations.

See Also

Package Description
libsoup-devel-32bit-2.68.3-248.3.x86_64.rpm HTTP client/server library for GNOME - Development Files
libsoup-lang-2.68.3-239.1.noarch.rpm Translations for package libsoup
libsoup-lang-2.68.3-248.3.noarch.rpm Translations for package libsoup
libstartup-notification-1-0-0.12-41.23.x86_64.rpm Reference Implementation for the Startup-Notification Protocol
libstartup-notification-1-0-0.12-41.26.i586.rpm Reference Implementation for the Startup-Notification Protocol
libstartup-notification-1-0-32bit-0.12-41.26.x86_64.rpm Reference Implementation for the Startup-Notification Protocol
libtelepathy-farstream3-0.6.2-29.31.x86_64.rpm Telepathy library to handle Call channels
libtelepathy-farstream3-0.6.2-29.36.i586.rpm Telepathy library to handle Call channels
libtelepathy-farstream3-32bit-0.6.2-29.36.x86_64.rpm Telepathy library to handle Call channels
libtelepathy-glib0-0.24.1-173.39.x86_64.rpm GObject-based library for the Telepathy D-Bus API
libtelepathy-glib0-0.24.1-173.45.i586.rpm GObject-based library for the Telepathy D-Bus API
libtelepathy-glib0-32bit-0.24.1-173.45.x86_64.rpm GObject-based library for the Telepathy D-Bus API
libtelepathy-logger3-0.8.2-51.6.x86_64.rpm Centralized Logging for the Telepathy Framework
libtelepathy-logger3-0.8.2-51.9.i586.rpm Centralized Logging for the Telepathy Framework
libtemplate_glib-1_0-0-3.34.0-20.11.i586.rpm Library for generating text based on a template and user defined state
Advertisement
Advertisement