libsoup-2_4-1-2.68.3-248.3.i586.rpm


Advertisement

Description

libsoup-2_4-1 - HTTP client/server library for GNOME

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libsoup-2_4-1-2.68.3-248.3.i586.rpm
Package name libsoup-2_4-1
Package version 2.68.3
Package release 248.3
Package architecture i586
Package type rpm
Category Development/Libraries/GNOME
Homepage https://wiki.gnome.org/Projects/libsoup
License LGPL-2.1-or-later
Maintainer -
Download size 384.06 KB
Installed size 859.33 KB
Libsoup is an HTTP client/server library for GNOME. It uses GObjects
and the glib main loop, to integrate well with GNOME applications.
Features:
* Both asynchronous (GMainLoop and callback-based) and synchronous APIs
* Automatically caches connections
* SSL Support using GnuTLS
* Proxy support, including authentication and SSL tunneling
* Client support for Digest, NTLM, and Basic authentication
* Server support for Digest and Basic authentication
* XML-RPC support

Alternatives

Package Version Architecture Repository
libsoup-2_4-1-2.68.3-389.3.i586.rpm 2.68.3 i586 GNOME Next
libsoup-2_4-1-2.68.3-389.3.x86_64.rpm 2.68.3 x86_64 GNOME Next
libsoup-2_4-1-2.68.3-239.1.x86_64.rpm 2.68.3 x86_64 GNOME Factory
libsoup-2_4-1-2.68.3-2.1.i586.rpm 2.68.3 i586 openSUSE Oss
libsoup-2_4-1-2.68.3-2.1.x86_64.rpm 2.68.3 x86_64 openSUSE Oss
libsoup-2_4-1 - - -

Requires

Name Value
/sbin/ldconfig -
glib-networking >= 2.27.90
libbrotlidec.so.1 -
libc.so.6(GLIBC_2.7) -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgssapi_krb5.so.2 -
libgssapi_krb5.so.2(gssapi_krb5_2_MIT) -
libpsl.so.5 -
libsqlite3.so.0 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libz.so.1 -
libz.so.1(ZLIB_1.2.0) -

Provides

Name Value
libsoup = 2.68.3
libsoup-2.4.so.1 -
libsoup-2_4-1 = 2.68.3-248.3
libsoup-2_4-1(x86-32) = 2.68.3-248.3
libsoup-gnome-2.4.so.1 -

Obsoletes

Name Value
libsoup < 2.68.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libsoup-2_4-1-2.68.3-248.3.i586.rpm
Source Package libsoup-2.68.3-248.3.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libsoup-2_4-1 rpm package:
    # zypper install libsoup-2_4-1

Files

Path
/usr/lib/libsoup-2.4.so.1
/usr/lib/libsoup-2.4.so.1.8.0
/usr/lib/libsoup-gnome-2.4.so.1
/usr/lib/libsoup-gnome-2.4.so.1.8.0
/usr/share/doc/packages/libsoup-2_4-1/NEWS
/usr/share/licenses/libsoup-2_4-1/COPYING

Changelog

2020-01-25 - Dominique Leuenberger <dimstar@opensuse.org>
- No longer recommend -lang: supplements are in use
2020-01-09 - olaf@aepfle.de
- Usage of g_canonicalize_filename requires glib 2.58
2019-12-20 - olaf@aepfle.de
- meson >=0.50 is required for building
2019-12-04 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.68.3:
+ Fixes to testing infrastructure.
+ Enable GNOME support in mingw.
+ Allow introspection in cross builds.
+ Updated translations.
2019-10-15 - Dominique Leuenberger <dimstar@opensuse.org>
- Disable NTLM for the time being (causes build cycle):
+ Drop samba-winbind BuildRequires.
+ Pass -Dntlm=disabled to meson.
2019-10-09 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.68.2:
+ Documentation fixes.
+ Windows compatibility test fixes.
+ WebSockets: client_max_window_bits in server must have a value.
+ build: improve diagnostics when detecting Apache.
+ NTLM: Make v2 authentication more robust.
+ Updated translations.
2019-09-12 - Michael Gorse <mgorse@suse.com>
- Update to version 2.68.1:
+ Several memory leaks fixed in tests, examples, and parsing
code.
+ SoupServer: Fixes to Windows path handling.
+ Changes in version 2.68.0:
+ Updated translations.
+ Changes in version 2.67.93:
+ SoupMessage: Handle Transfer-Encoding: identity for
compatibility reasons.
+ WebSockets: Only poll IO stream when needed.
+ WebSockets: Properly set cookies received during handshake.
+ WebSockets: Plug a couple of memory leaks and fix a few
read-after-free memory errors.
+ WebSockets: document how web socket extensions should treat
buffers in case of error.
+ SoupSession: Don't reset user GCancellable internally.
+ Tests: Make tests installable.
+ Remove deprecate GTimeVal internal usage.
+ CI: increase coverage by enabling all features during testing.
+ Updated translations.

See Also

Package Description
libsoup-2_4-1-32bit-2.68.3-248.3.x86_64.rpm HTTP client/server library for GNOME
libsoup-devel-2.68.3-239.1.x86_64.rpm HTTP client/server library for GNOME - Development Files
libsoup-devel-2.68.3-248.3.i586.rpm HTTP client/server library for GNOME - Development Files
libsoup-devel-32bit-2.68.3-248.3.x86_64.rpm HTTP client/server library for GNOME - Development Files
libsoup-lang-2.68.3-239.1.noarch.rpm Translations for package libsoup
libsoup-lang-2.68.3-248.3.noarch.rpm Translations for package libsoup
libstartup-notification-1-0-0.12-41.23.x86_64.rpm Reference Implementation for the Startup-Notification Protocol
libstartup-notification-1-0-0.12-41.26.i586.rpm Reference Implementation for the Startup-Notification Protocol
libstartup-notification-1-0-32bit-0.12-41.26.x86_64.rpm Reference Implementation for the Startup-Notification Protocol
libtelepathy-farstream3-0.6.2-29.31.x86_64.rpm Telepathy library to handle Call channels
libtelepathy-farstream3-0.6.2-29.36.i586.rpm Telepathy library to handle Call channels
libtelepathy-farstream3-32bit-0.6.2-29.36.x86_64.rpm Telepathy library to handle Call channels
libtelepathy-glib0-0.24.1-173.39.x86_64.rpm GObject-based library for the Telepathy D-Bus API
libtelepathy-glib0-0.24.1-173.45.i586.rpm GObject-based library for the Telepathy D-Bus API
libtelepathy-glib0-32bit-0.24.1-173.45.x86_64.rpm GObject-based library for the Telepathy D-Bus API
Advertisement
Advertisement