libproxy1-config-kde-0.4.15-178.23.x86_64.rpm


Advertisement

Description

libproxy1-config-kde - Libproxy module for KDE configuration

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libproxy1-config-kde-0.4.15-178.23.x86_64.rpm
Package name libproxy1-config-kde
Package version 0.4.15
Package release 178.23
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://libproxy.github.io/libproxy/
License GPL-2.0-or-later AND LGPL-2.1-or-later
Maintainer -
Download size 21.64 KB
Installed size 34.66 KB
A module to extend libproxy with capabilities to query KDE4 about proxy
settings.

Alternatives

Package Version Architecture Repository
libproxy1-config-kde-0.4.15-216.28.i586.rpm 0.4.15 i586 GNOME Next
libproxy1-config-kde-0.4.15-216.28.x86_64.rpm 0.4.15 x86_64 GNOME Next
libproxy1-config-kde-0.4.15-178.27.i586.rpm 0.4.15 i586 GNOME Factory
libproxy1-config-kde-0.4.15-5.8.i586.rpm 0.4.15 i586 openSUSE Oss
libproxy1-config-kde-0.4.15-5.8.x86_64.rpm 0.4.15 x86_64 openSUSE Oss
libproxy1-config-kde - - -

Requires

Name Value
libKF5ConfigCore5 -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_3.3.1)(64bit) -
libproxy.so.1()(64bit) -
libproxy1 = 0.4.15
libqt5-qtpaths -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -

Provides

Name Value
libproxy-kde = 0.4.15
libproxy1-config-kde = 0.4.15-178.23
libproxy1-config-kde(x86-64) = 0.4.15-178.23

Obsoletes

Name Value
libproxy-kde < 0.4.15
libproxy1-config-kde4 < 0.4.12

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libproxy1-config-kde-0.4.15-178.23.x86_64.rpm
Source Package libproxy-plugins-0.4.15-178.23.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libproxy1-config-kde rpm package:
    # zypper install libproxy1-config-kde

Files

Path
/usr/lib64/libproxy-0.4.15/modules/config_kde.so

Changelog

2018-12-12 - Dominique Leuenberger <dimstar@opensuse.org>
- Convert package from multispec to multibuild.
2018-10-05 - Dominique Leuenberger <dimstar@opensuse.org>
- Update Url tag to point to http://libproxy.github.io/libproxy/
- Add libproxy-python3.7.patch: Support python 3.7 and 3.8.
- Drop py_requires: no longer needed.
2018-07-07 - bjorn.lie@gmail.com
- Drop favor_gtk2 conditional.
2018-02-22 - fvogt@suse.com
- Use %license (boo#1082318)
2017-09-07 - jengelh@inai.de
- Update descriptions and RPM categories.
2017-05-11 - dimstar@opensuse.org
- Update to version 0.4.15:
+ Port to, and require, SpiderMonkey 38.
+ Fix "NetworkManager plugin not being built"
(gh#libproxy/libproxy#53).
+ Fix "networkmanager plugin not working
(gh#libproxy/libproxy#58).
+ Fix "Invalid read after free" (gh#libproxy/libproxy#59).
+ Fix intermittent unit test failures.
- Replace pkgconfig(mozjs185) buildRequires with
pkgconfig(mozjs-38), following upstream.
2017-02-06 - dimstar@opensuse.org
- Have libproxy1-config-kde require libqt5-qtpaths instead of
libqt5-qttools on openSUSE > 13.2 / openSUSE > Leap 42.x
(boo#988808).
2017-01-09 - dimstar@opensuse.org
- Update to version 0.4.14:
+ Parallel build support for python2 and python3.
- DWITH_PYTHON has been replaced with -DWITH_PYTHON2 and
- DWITH_PYTHON3 to have full control over this. Default is
ON for both (gh#libproxy/libproxy#22).
+ Minor fixes to the PAC retriever code
(gh#libproxy/libproxy#40).
+ Fallback to mcs instead of gmcs for the mono bindings
(gh#libproxy/libproxy#37).
+ Fix build using cmake 3.7.
+ Fix deprecation warnings of pxgsettings with glib 2.46.
+ Improve the get-pac test suite (gh#libproxy/libproxy#47).
- Drop update-from-svn.sh: The script has not been usable for
years, since libproxy is no longer hosted in this svn repo.
- Drop upstream merged patches:
+ libproxy-cmake-3.7.patch
+ libproxy-FindMono-4.6.patch
+ libproxy-gnome-waitpid.patch
+ libproxy-python3-support.patch
- Re-enable the test suite: with the upstream changes this should
now be more reliable.
2016-11-22 - dimstar@opensuse.org
- Add libproxy-cmake-3.7.patch: Fix build with cmake 3.7.
2016-09-29 - dimstar@opensuse.org
- Add libproxy-FindMono-4.6.patch: Fall back to mcs if gmcs cannot
be found. Fixes issues with mono 4.6, which no longer ships the
wrapper by default.

See Also

Package Description
libproxy1-config-kde-32bit-0.4.15-178.27.x86_64.rpm Libproxy module for KDE configuration
libproxy1-networkmanager-0.4.15-178.23.x86_64.rpm Libproxy module for NetworkManager configuration
libproxy1-networkmanager-0.4.15-178.27.i586.rpm Libproxy module for NetworkManager configuration
libproxy1-networkmanager-32bit-0.4.15-178.27.x86_64.rpm Libproxy module for NetworkManager configuration
libproxy1-pacrunner-webkit-0.4.15-178.23.x86_64.rpm Libproxy module to support WPAD/PAC parsing via the WebKit JavaScript Engine
libproxy1-pacrunner-webkit-0.4.15-178.27.i586.rpm Libproxy module to support WPAD/PAC parsing via the WebKit JavaScript Engine
libproxy1-pacrunner-webkit-32bit-0.4.15-178.27.x86_64.rpm Libproxy module to support WPAD/PAC parsing via the WebKit JavaScript Engine
libpsiconv6-0.9.9-496.26.x86_64.rpm EPOC32 PSION 5(MX) file format data conversion library
libpsiconv6-0.9.9-496.30.i586.rpm EPOC32 PSION 5(MX) file format data conversion library
libpst-0.6.71-73.36.x86_64.rpm Library and utilities for reading Personal Storage Table files
libpst-0.6.71-73.40.i586.rpm Library and utilities for reading Personal Storage Table files
libpst-devel-0.6.71-73.36.x86_64.rpm Development files for libpst, a .pst file reader
libpst-devel-0.6.71-73.40.i586.rpm Development files for libpst, a .pst file reader
libpst4-0.6.71-73.36.x86_64.rpm A library for reading Personal Storage Table files
libpst4-0.6.71-73.40.i586.rpm A library for reading Personal Storage Table files
Advertisement
Advertisement