libpango-1_0-0-1.44.7+11-209.2.x86_64.rpm


Advertisement

Description

libpango-1_0-0 - Library for Layout and Rendering of Text

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libpango-1_0-0-1.44.7+11-209.2.x86_64.rpm
Package name libpango-1_0-0
Package version 1.44.7+11
Package release 209.2
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://pango.gnome.org/
License LGPL-2.1-or-later
Maintainer -
Download size 217.27 KB
Installed size 640.75 KB
Pango is a library for layout and rendering of text, with an emphasis
on internationalization. It can be used anywhere that text layout
is needed.
Pango forms the core of text and font handling for GTK+.

Alternatives

Package Version Architecture Repository
libpango-1_0-0-1.44.7+11-314.9.i586.rpm 1.44.7+11 i586 GNOME Next
libpango-1_0-0-1.44.7+11-314.9.x86_64.rpm 1.44.7+11 x86_64 GNOME Next
libpango-1_0-0-1.44.7+11-209.9.i586.rpm 1.44.7+11 i586 GNOME Factory
libpango-1_0-0-1.44.7+11-1.1.i586.rpm 1.44.7+11 i586 openSUSE Oss
libpango-1_0-0-1.44.7+11-1.1.x86_64.rpm 1.44.7+11 x86_64 openSUSE Oss
libpango-1_0-0 - - -

Requires

Name Value
/sbin/ldconfig -
libX11.so.6()(64bit) -
libXft.so.2()(64bit) -
libXrender.so.1()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libcairo.so.2()(64bit) -
libfontconfig.so.1()(64bit) -
libfreetype.so.6()(64bit) -
libfribidi.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libharfbuzz.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libthai.so.0()(64bit) -
libthai.so.0(LIBTHAI_0.1)(64bit) -
libthai.so.0(LIBTHAI_0.1.25)(64bit) -

Provides

Name Value
libpango-1.0.so.0()(64bit) -
libpango-1_0-0 = 1.44.7+11-209.2
libpango-1_0-0(x86-64) = 1.44.7+11-209.2
libpangocairo-1.0.so.0()(64bit) -
libpangoft2-1.0.so.0()(64bit) -
libpangoxft-1.0.so.0()(64bit) -
pango = 1.44.7+11
pango-modules = 1.44.7+11

Obsoletes

Name Value
pango < 1.44.7+11
pango-modules < 1.44.7+11

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libpango-1_0-0-1.44.7+11-209.2.x86_64.rpm
Source Package pango-1.44.7+11-209.2.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libpango-1_0-0 rpm package:
    # zypper install libpango-1_0-0

Files

Path
/usr/lib64/libpango-1.0.so.0
/usr/lib64/libpango-1.0.so.0.4400.7
/usr/lib64/libpangocairo-1.0.so.0
/usr/lib64/libpangocairo-1.0.so.0.4400.7
/usr/lib64/libpangoft2-1.0.so.0
/usr/lib64/libpangoft2-1.0.so.0.4400.7
/usr/lib64/libpangoxft-1.0.so.0
/usr/lib64/libpangoxft-1.0.so.0.4400.7
/usr/share/doc/packages/libpango-1_0-0/NEWS
/usr/share/doc/packages/libpango-1_0-0/README.md
/usr/share/licenses/libpango-1_0-0/COPYING

Changelog

2019-11-27 - dimstar@opensuse.org
- Update to version 1.44.7+11:
* Add a test for ellipsis shaping
* Use shape flags for ellipsis
* test-shape: Cosmetics
2019-11-02 - bjorn.lie@gmail.com
- Update to version 1.44.7+8:
+ Undo fontset deprecations.
+ Adjust expected test outputs.
+ Fix ItemProperties handling.
+ Don't treat rise as a no-shape attribute.
+ Drop an unused ItemProperties use.
+ Go back to ignoring underlines for itemization.
+ fc: remove another assertion that might trigger.
- Switch to using pango 1.44 stable git branch.
2019-10-25 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 1.44.7:
+ Fix tests without libthai.
+ Small speedup to Emoji iteration.
+ Bring back PangoFontsetSimple (pygtk bind it).
2019-10-11 - bjorn.lie@gmail.com
- Switch to git-checkout via source service, explicit tag. Upstream
tarball is borked.
2019-09-14 - Bjørn Lie <bjorn.lie@gmail.com>
- Modernize spec, prepare for possible spliting of package.
2019-09-03 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 1.44.6:
+ docs: Fix symbol indices.
+ Fix Thai line breaking.
+ Re-add symbols needed by some bindings.
+ Don't insert hyphens for some languages.
+ Fix a crash with hyphenation.
2019-08-14 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 1.44.5:
+ Revert a broken change (causing crashes on OS X).
2019-08-13 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 1.44.4:
+ Add an insert-hyphens attribute.
+ Reinstate the return type of pango_fc_font_lock_face.
+ Fix a problem with ellipses getting the wrong font.
+ fc: Improve filtering by font format.
+ Re-add PangoFcFont to public headers.
+ Install PangoFc and PangoOT introspection files.
+ Fix ink rectangles to have positive height.
+ Fix mark positioning.
+ Switch to using harfbuzz for metrics.
2019-08-04 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 1.44.3:
+ Install pango-ot headers.
+ Make subpixel positioning optional.
+ fc: Ignore fonts with unsupported formats.
2019-08-03 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 1.44.2:
+ Disable ligatures when letterspacing.
+ Set design coords on hb_font_t.
+ Expose more font options in pango-view.
+ OS X: Make 'system-ui' font work.
+ Keep deprecated pango-fc apis in headers.
+ Make hex boxes work, always.
+ introspection:
- Various build fixes.
- Add PangoPT, PangoFT2 namespaces.
+ layout: Make the new line-spacing opt-in.

See Also

Package Description
libpango-1_0-0-32bit-1.44.7+11-209.9.x86_64.rpm Library for Layout and Rendering of Text
libpangomm-1_4-1-2.42.0-8.17.x86_64.rpm C++ interface for pango
libpangomm-1_4-1-2.42.0-8.22.i586.rpm C++ interface for pango
libpangomm-1_4-1-32bit-2.42.0-8.22.x86_64.rpm C++ interface for pango
libpangomm-2_44-1-2.43.1-80.4.x86_64.rpm C++ interface for Pango
libpangomm-2_44-1-2.43.1-80.9.i586.rpm C++ interface for Pango
libpangomm-2_44-1-32bit-2.43.1-80.9.x86_64.rpm C++ interface for Pango
libpangox-1_0-0-0.0.2-14.55.x86_64.rpm PangoX compatibility library - deprecated
libpeas-1_0-0-1.24.1-87.4.x86_64.rpm GObject-based Plugin Engine
libpeas-1_0-0-1.24.1-94.1.i586.rpm GObject-based Plugin Engine
libpeas-demo-1.24.1-87.4.x86_64.rpm Demo applications from the libpeas package
libpeas-demo-1.24.1-94.1.i586.rpm Demo applications from the libpeas package
libpeas-devel-1.24.1-87.4.x86_64.rpm Development files for libpeas, a GObject-based plugin engine
libpeas-devel-1.24.1-94.1.i586.rpm Development files for libpeas, a GObject-based plugin engine
libpeas-gtk-1_0-0-1.24.1-87.4.x86_64.rpm GObject-based Plugin Engine
Advertisement
Advertisement