libgvncpulse-1_0-0-1.0.0-85.8.x86_64.rpm


Advertisement

Description

libgvncpulse-1_0-0 - Pulse audio bridge for VNC client connections

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libgvncpulse-1_0-0-1.0.0-85.8.x86_64.rpm
Package name libgvncpulse-1_0-0
Package version 1.0.0
Package release 85.8
Package architecture x86_64
Package type rpm
Category Development/Libraries/X11
Homepage https://wiki.gnome.org/Projects/gtk-vnc
License LGPL-2.1-only AND LGPL-2.1-or-later
Maintainer -
Download size 24.41 KB
Installed size 39.99 KB
gtk-vnc is a VNC viewer widget for GTK+. It is built using coroutines
allowing it to be completely asynchronous while remaining single
threaded.
This package contains the Pulse audio bridge for VNC client connections.

Alternatives

Package Version Architecture Repository
libgvncpulse-1_0-0-1.0.0-110.1.i586.rpm 1.0.0 i586 GNOME Next
libgvncpulse-1_0-0-1.0.0-110.1.x86_64.rpm 1.0.0 x86_64 GNOME Next
libgvncpulse-1_0-0-1.0.0-88.1.i586.rpm 1.0.0 i586 GNOME Factory
libgvncpulse-1_0-0-1.0.0-1.1.i586.rpm 1.0.0 i586 openSUSE Oss
libgvncpulse-1_0-0-1.0.0-1.1.x86_64.rpm 1.0.0 x86_64 openSUSE Oss
libgvncpulse-1_0-0 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgvnc-1.0.so.0()(64bit) -
libpulse-simple.so.0()(64bit) -
libpulse-simple.so.0(PULSE_0)(64bit) -
libpulse.so.0()(64bit) -
libpulse.so.0(PULSE_0)(64bit) -

Provides

Name Value
libgvncpulse-1.0.so.0()(64bit) -
libgvncpulse-1_0-0 = 1.0.0-85.8
libgvncpulse-1_0-0(x86-64) = 1.0.0-85.8

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgvncpulse-1_0-0-1.0.0-85.8.x86_64.rpm
Source Package gtk-vnc-1.0.0-85.8.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libgvncpulse-1_0-0 rpm package:
    # zypper install libgvncpulse-1_0-0

Files

Path
/usr/lib64/libgvncpulse-1.0.so.0
/usr/lib64/libgvncpulse-1.0.so.0.0.1
/usr/share/licenses/libgvncpulse-1_0-0/COPYING.LIB

Changelog

2019-08-09 - Luigi Baldoni <aloisio@gmx.com>
- Update to version 1.0.0:
+ Autotools build system replaced with meson.
+ Support for GTK-2 is dropped. GTK-3 is mandatory.
+ Support for libview is dropped in example program.
+ Improvements to example demos.
+ Use MAP_ANON if MAP_ANONYMOUS doesn't exist to help certain
macOS versions.
+ Fix crash when connection attempt fails early.
+ Initialize gcrypt early in auth process.
+ Emit vnc-auth-failure signal when SASL auth fails.
+ Emit vnc-error signal when authentication fails.
+ Fix double free when failing to read certificates.
+ Run unit tests in RPM build.
+ Modernize RPM spec.
+ Fix race condition in unit tests.
+ Fix install of missing header for cairo framebuffer.
+ Fix typo in gir package name.
+ Add missing VncPixelFormat file to git data.
- Add meson BuildRequires and macros.
- Drop libtool BuildRequires: No longer needed.
- Drop translation-update-upstream BuildRequires and macro, SUSE no
longer provides extra translations for gtk-vnc.
- Replace gtk3-devel with pkgconfig(gtk+-3.0) BuildRequires: Align
with what meson checks for.
- Add pkgconfig(gvnc-1.0) BuildRequires: New dependency.
- Use sed hack to enable install of gncviewer.
2018-09-27 - luc14n0@linuxmail.org
- Add gio-2.0, gio-unix-2.0 and gobject-2.0 pkgconfig modules
BuildRequires to main pakage to avoid implicit dependencies.
2018-08-18 - bjorn.lie@gmail.com
- Update to version 0.9.0:
+ Use libgcrypt for DES routines
+ Add missing cipher close calls in ARD auth
+ Check for errors after reading mslogon params
+ Support newer UltraVNC mslogon auth type code
+ Avoid divide by zero in mslogin auth from bogus params
+ Re-allow python2 accidentally blocked when removing python
binding.
2018-08-03 - bjorn.lie@gmail.com
- Update to version 0.8.0:
+ Deleted the python2 binding in favour of GObject introspection.
+ Pull in latest keycodemapdb content.
+ Disable/fix -Wcast-function-type warnings.
- Drop gtk-vnc2 linked package and all it's subpackages and
conditionals, no longer supported upstream.
2018-03-25 - luc14n0@linuxmail.org
- Update to version 0.7.2:
+ Deprecated the manual python2 binding in favour of GObject
introspection. It will be deleted in the next release.
+ Emit led state notification on connect.
+ Fix incorrect copyright notices.
+ Simplify shifted-tab key handling.
+ Don't short circuit TLS credential request.
+ Improve check for keymap under XWayland.
- Update:
+ URL tag to https://wiki.gnome.org/Projects/gtk-vnc: currently
the gtk-vnc's web page.
+ '+' in LGPL License tags to '-or-later' to comply with SPDX
3.0.
2017-05-20 - zaitor@opensuse.org
- Update to version 0.7.1:
+ Explicitly link to GIO instead of relying on implicit linkage.
+ Switch to use new keycodemap database module.
+ Fix size of reserved data in class struct.
+ Fix inverted framebuffer args in test case.
+ Avoid sign extension in integer arithmetic.
+ Avoid crash when opening a GSocketAddress.
+ Fix crash if server connection times out.
+ Fix incompatibility with libvncserver.
- Drop obsolete FIXME about browser plugin, dropped upstream back
in 2013.
2017-02-18 - zaitor@opensuse.org
- Update License to include LGPL-2.1.

See Also

Package Description
libgweather-3-16-3.34.0-190.5.x86_64.rpm Library to get online weather information
libgweather-3-16-3.34.0-193.3.i586.rpm Library to get online weather information
libgweather-3-16-32bit-3.34.0-193.3.x86_64.rpm Library to get online weather information
libgweather-devel-3.34.0-190.5.x86_64.rpm Development files for libgweather, a weather info retrieval library
libgweather-devel-3.34.0-193.3.i586.rpm Development files for libgweather, a weather info retrieval library
libgweather-lang-3.34.0-190.5.noarch.rpm Translations for package libgweather
libgweather-lang-3.34.0-193.3.noarch.rpm Translations for package libgweather
libhandy-0_0-0-0.0.11-19.5.x86_64.rpm A GTK+ library to develop UI for mobile devices
libhandy-0_0-0-0.0.13-21.1.i586.rpm A GTK+ library to develop UI for mobile devices
libhandy-devel-0.0.11-19.5.x86_64.rpm Source and header files for libhandy
libhandy-devel-0.0.13-21.1.i586.rpm Source and header files for libhandy
libharfbuzz-gobject0-2.6.4-178.1.x86_64.rpm GObject wrapper around the HarfBuzz OpenType text shaping engine
libharfbuzz-gobject0-2.6.4-178.7.i586.rpm GObject wrapper around the HarfBuzz OpenType text shaping engine
libharfbuzz-gobject0-32bit-2.6.4-178.7.x86_64.rpm GObject wrapper around the HarfBuzz OpenType text shaping engine
libharfbuzz-icu0-2.6.4-178.1.x86_64.rpm ICU integration into the HarfBuzz OpenType text shaping engine
Advertisement
Advertisement