libgnome-autoar-gtk-0-0-0.2.4-13.4.i586.rpm


Advertisement

Description

libgnome-autoar-gtk-0-0 - Automatic archives creating and extracting library

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libgnome-autoar-gtk-0-0-0.2.4-13.4.i586.rpm
Package name libgnome-autoar-gtk-0-0
Package version 0.2.4
Package release 13.4
Package architecture i586
Package type rpm
Category System/Libraries
Homepage https://gitlab.gnome.org/GNOME/gnome-autoar
License LGPL-2.0-or-later
Maintainer -
Download size 14.82 KB
Installed size 21.64 KB
gnome-autoar provides functions, widgets, and gschemas for GNOME applications which want
to use archives as a method to transfer directories over the Internet.

Alternatives

Package Version Architecture Repository
libgnome-autoar-gtk-0-0-0.2.4-31.4.i586.rpm 0.2.4 i586 GNOME Next
libgnome-autoar-gtk-0-0-0.2.4-31.4.x86_64.rpm 0.2.4 x86_64 GNOME Next
libgnome-autoar-gtk-0-0-0.2.4-1.1.i586.rpm 0.2.4 i586 openSUSE Oss
libgnome-autoar-gtk-0-0-0.2.4-1.1.x86_64.rpm 0.2.4 x86_64 openSUSE Oss
libgnome-autoar-gtk-0-0-0.2.3-11.30.x86_64.rpm 0.2.3 x86_64 GNOME Factory
libgnome-autoar-gtk-0-0 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -
libglib-2.0.so.0 -
libgnome-autoar-0.so.0 -
libgobject-2.0.so.0 -
libgtk-3.so.0 -

Provides

Name Value
libgnome-autoar-gtk-0-0 = 0.2.4-13.4
libgnome-autoar-gtk-0-0(x86-32) = 0.2.4-13.4
libgnome-autoar-gtk-0.so.0 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgnome-autoar-gtk-0-0-0.2.4-13.4.i586.rpm
Source Package gnome-autoar-0.2.4-13.4.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libgnome-autoar-gtk-0-0 rpm package:
    # zypper install libgnome-autoar-gtk-0-0

Files

Path
/usr/lib/libgnome-autoar-gtk-0.so.0
/usr/lib/libgnome-autoar-gtk-0.so.0.0.0

Changelog

2019-12-13 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 0.2.4:
+ Use autoreconf instead of deprecated gnome-common.
2018-02-26 - bjorn.lie@gmail.com
- Update to version 0.2.3:
+ Use proper extracted name for xz archives.
+ Fix decompressing files with legacy encoding file names.
- Run spec-cleaner, modernize spec, use autosetup and make_build
macros.
2017-03-21 - dimstar@opensuse.org
- Update to version 0.2.2:
+ Fix docx files and other format subtypes of zip to be
uncompressed.
2017-03-03 - zaitor@opensuse.org
- Update to version 0.2.1:
+ Drop rar support since rar5 is not yet supported by libarchive.
2017-02-23 - zaitor@opensuse.org
- Update to version 0.2.0:
+ Generate vala bindings.
+ Check encrypted entry after header is read.
+ Fix extraction name case, e.j.'sample.odt' in 'sample.odt.zip'.
+ Remove GSettings schema files.
- Add pkgconfig(vapigen) BuildRequires: New dependency for vala
bindings.
- Pass --enable-gtk to configure, ensure we build gtk3 widgets.
- Drop gnome-autoar-schema subpackage and add gnome-autoar-schema
Obsoletes replacing previous Requires, following upstream
changes.
2016-09-02 - zaitor@opensuse.org
- Updated to version 0.1.1:
+ Fix library link issues for Evolution.
+ Make decide destination signal synchronous for Evolution.
+ Fix licence to LGPLv2.1+.
2016-09-01 - zaitor@opensuse.org
- Update to version 0.1.0:
+ Bump required libarchive version.
+ AutoarExtractor: signal error on encrypted archives.
+ Add COPYING file.
+ tests: Add missing linker flags.
- Stop using sourceservice, tarball release now available.
- Following the above: gnome-common BuildRequires and autogen.sh
call: We no longer need to bootstrap.
2016-08-31 - dimstar@opensuse.org
- Initial package, version 0+20160825.0fec26d (no tagged release
yet available in git).

See Also

Package Description
libgnome-bluetooth13-3.34.0-185.5.x86_64.rpm GNOME Bluetooth's Shared Libraries
libgnome-bluetooth13-3.34.0-188.1.i586.rpm GNOME Bluetooth's Shared Libraries
libgnome-desktop-2-17-2.32.1-51.25.x86_64.rpm The GNOME Desktop API Library
libgnome-desktop-2-devel-2.32.1-51.25.x86_64.rpm The GNOME Desktop API Library -- Development Files
libgnome-desktop-3-18-3.34.2-283.2.x86_64.rpm The GNOME Desktop API Library
libgnome-desktop-3-18-3.34.3-286.5.i586.rpm The GNOME Desktop API Library
libgnome-desktop-3-18-32bit-3.34.3-286.5.x86_64.rpm The GNOME Desktop API Library
libgnome-desktop-3-devel-3.34.2-283.2.x86_64.rpm Development files for the GNOME Desktop API library
libgnome-desktop-3-devel-3.34.3-286.5.i586.rpm Development files for the GNOME Desktop API library
libgnome-desktop-3_0-common-3.34.2-283.2.x86_64.rpm Common data files for the GNOME Desktop API library
libgnome-desktop-3_0-common-3.34.3-286.5.i586.rpm Common data files for the GNOME Desktop API library
libgnome-devel-2.32.2+20180228.6a7dbfb9-64.5.x86_64.rpm Development files for libgnome
libgnome-games-support-1-3-1.4.4-20.5.x86_64.rpm Internal support library for GNOME games
libgnome-games-support-1-3-1.4.4-23.1.i586.rpm Internal support library for GNOME games
libgnome-games-support-devel-1.4.4-20.5.x86_64.rpm Development files for the GNOME Internal games library
Advertisement
Advertisement