libglib-2_0-0-32bit-2.62.4-426.4.x86_64.rpm


Advertisement

Description

libglib-2_0-0-32bit - General-Purpose Utility Library

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libglib-2_0-0-32bit-2.62.4-426.4.x86_64.rpm
Package name libglib-2_0-0-32bit
Package version 2.62.4
Package release 426.4
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://wiki.gnome.org/Projects/GLib
License LGPL-2.1-or-later
Maintainer -
Download size 617.80 KB
Installed size 1.25 MB
GLib is a general-purpose utility library, which provides many useful
data types, macros, type conversions, string utilities, file utilities,
a main loop abstraction, and so on.

Alternatives

Package Version Architecture Repository
libglib-2_0-0-32bit-2.62.4-698.4.x86_64.rpm 2.62.4 x86_64 GNOME Next
libglib-2_0-0-32bit-2.62.4-1.1.x86_64.rpm 2.62.4 x86_64 openSUSE Oss
libglib-2_0-0-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.28) -
libpcre.so.1 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.12) -
libpthread.so.0(GLIBC_2.2) -

Provides

Name Value
glib2-32bit = 2.62.4
libglib-2.0.so.0 -
libglib-2_0-0-32bit = 2.62.4-426.4
libglib-2_0-0-32bit(x86-32) = 2.62.4-426.4

Obsoletes

Name Value
glib2-32bit <= 2.62.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libglib-2_0-0-32bit-2.62.4-426.4.x86_64.rpm
Source Package glib2-2.62.4-426.4.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libglib-2_0-0-32bit rpm package:
    # zypper install libglib-2_0-0-32bit

Files

Path
/usr/lib/libglib-2.0.so.0
/usr/lib/libglib-2.0.so.0.6200.4

Changelog

2020-01-25 - Dominique Leuenberger <dimstar@opensuse.org>
- No longer recommend -lang: supplements are in use
2020-01-11 - Dominique Leuenberger <dimstar@opensuse.org>
- Drop gtk-doc BuildRequires: eliminate a build cycle. In a 2nd
step we will try to provide a glib2-devel-doc package as part of
a _multibuild. Also drop -Dgtk_doc=true meson parameter.
2019-12-19 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.62.4:
+ Apply recursion depth limits to variants in D-Bus messages.
+ Bugs fixed: glgo#GNOME/GLib#1938, glgo#GNOME/GLib!1240,
glgo#GNOME/GLib!1257, glgo#GNOME/GLib!1266,
glgo#GNOME/GLib!1276, glgo#GNOME/GLib!1290.
2019-11-19 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.62.3:
+ Use `poll()` in `g_spawn_sync()` rather than `select()`, which
is subject to FD limits.
+ Fix undefined behaviour with `g_utf8_find_prev_char()`.
+ Bugs fixed: glgo#GNOME/GLib#954, glgo#GNOME/GLib#1318,
glgo#GNOME/GLib#1897, glgo#GNOME/GLib#1903,
glgo#GNOME/GLib#1916, glgo#GNOME/GLib#1917,
glgo#GNOME/GLib!1174, glgo#GNOME/GLib!1184,
glgo#GNOME/GLib!1194, glgo#GNOME/GLib!1203,
glgo#GNOME/GLib!1207, glgo#GNOME/GLib!1215,
glgo#GNOME/GLib!1219, glgo#GNOME/GLib!1222,
glgo#GNOME/GLib!1228.
2019-11-05 - Michael Gorse <mgorse@suse.com>
- Re-enable systemtap, and require systemtap-headers and
systemtap-dtrace, rather than systemtap-sdt-devel, to avoid build
cycle (boo#1145438).
- Own /usr/share/systemtap{|tapset} directories, since we no
longer have systemtap-sdt-devel in BuildRequires.
- Disable lto if systemtap is enabled: build fails otherwise.
2019-10-21 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.62.2:
+ Bugs fixed:
- glgo#GNOME/GLib#1896: Use after free when calling
g_dbus_connection_flush_sync() in a dedicated thread.
- glgo#GNOME/GLib!1154: Backport glgo#GNOME/GLib!1152
?gwinhttpvfs: Handle g_get_prgname() returning NULL? to
glib-2-62.
- glgo#GNOME/GLib!1156: Backport glgo#GNOME/GLib!1146 Solaris
fixes to glib-2-62.
2019-10-04 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.62.1:
+ Fix regression in g_file_copy() when passing
`G_FILE_COPY_TARGET_DEFAULT_PERMS` flag; the destination
permissions would be private rather than following the process?
umask.
+ Several `GDateTime` parsing fixes.
+ Always build the tests if installed-tests are enabled, so that
the tests can actually be installed.
+ Bugs fixed: glgo#GNOME/GLib#174, glgo#GNOME/GLib#1865,
glgo#GNOME/GLib#1875, glgo#GNOME/GLib#1887,
glgo#GNOME/GLib#1888, glgo#GNOME/GLib!1021,
glgo#GNOME/GLib!1094, glgo#GNOME/GLib!1101,
glgo#GNOME/GLib!1102, glgo#GNOME/GLib!1103,
glgo#GNOME/GLib!1127, glgo#GNOME/GLib!1128,
glgo#GNOME/GLib!1140, glgo#GNOME/GLib!1141,
glgo#GNOME/GLib!1142.
+ Updated translations.
2019-09-05 - luke@ljones.dev
- Update to version 2.62.0:
+ Fix new `GFileInfo` APIs to work when
`G_FILE_ATTRIBUTE_TIME_MODIFIED_USEC` was not queried.
+ Bugs fixed: glgo#GNOME/GLib#487, glgo#GNOME/GLib!1084,
glgo#GNOME/GLib!1086,glgo#GNOME/GLib!1087.

See Also

Package Description
libglibmm-2_4-1-2.62.0-25.10.i586.rpm C++ Interface for Glib
libglibmm-2_4-1-2.62.0-25.4.x86_64.rpm C++ Interface for Glib
libglibmm-2_4-1-32bit-2.62.0-25.10.x86_64.rpm C++ Interface for Glib
libglibmm-2_62-1-2.61.1-187.10.i586.rpm C++ Interface for Glib
libglibmm-2_62-1-2.61.1-187.4.x86_64.rpm C++ Interface for Glib
libglibmm-2_62-1-32bit-2.61.1-187.10.x86_64.rpm C++ Interface for Glib
libgmime-2_6-0-2.6.23-9.35.x86_64.rpm MIME Parser and Utility Library
libgmime-2_6-0-2.6.23-9.43.i586.rpm MIME Parser and Utility Library
libgmime-2_6-0-32bit-2.6.23-9.43.x86_64.rpm MIME Parser and Utility Library
libgmime-3_0-0-3.2.5-92.1.x86_64.rpm MIME Parser and Utility Library
libgmime-3_0-0-3.2.5-92.8.i586.rpm MIME Parser and Utility Library
libgmime-3_0-0-32bit-3.2.5-92.8.x86_64.rpm MIME Parser and Utility Library
libgmodule-2_0-0-2.62.3-420.3.x86_64.rpm General-Purpose Utility Library -- Library for Modules
libgmodule-2_0-0-2.62.4-426.4.i586.rpm General-Purpose Utility Library -- Library for Modules
libgmodule-2_0-0-32bit-2.62.4-426.4.x86_64.rpm General-Purpose Utility Library -- Library for Modules
Advertisement
Advertisement