libgeocode-glib0-3.26.1-71.19.i586.rpm


Advertisement

Description

libgeocode-glib0 - Convenience library for the Yahoo! Place Finder APIs

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libgeocode-glib0-3.26.1-71.19.i586.rpm
Package name libgeocode-glib0
Package version 3.26.1
Package release 71.19
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.gnome.org/
License LGPL-2.0-or-later
Maintainer -
Download size 60.01 KB
Installed size 144.67 KB
The geocode-glib library is a convenience library for the Yahoo! Place
Finder APIs, as described at http://developer.yahoo.com/geo/placefinder/
The Place Finder web service allows to do geocoding (finding longitude
and latitude from an address), and reverse geocoding (finding an address
from coordinates).

Alternatives

Package Version Architecture Repository
libgeocode-glib0-3.26.1-121.23.i586.rpm 3.26.1 i586 GNOME Next
libgeocode-glib0-3.26.1-121.23.x86_64.rpm 3.26.1 x86_64 GNOME Next
libgeocode-glib0-3.26.1-71.13.x86_64.rpm 3.26.1 x86_64 GNOME Factory
libgeocode-glib0-3.26.1-1.4.i586.rpm 3.26.1 i586 openSUSE Oss
libgeocode-glib0-3.26.1-1.4.x86_64.rpm 3.26.1 x86_64 openSUSE Oss
libgeocode-glib0 - - -

Requires

Name Value
/sbin/ldconfig -
geocode-glib >= 3.26.1
libc.so.6(GLIBC_2.4) -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libjson-glib-1.0.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libsoup-2.4.so.1 -

Provides

Name Value
libgeocode-glib.so.0 -
libgeocode-glib0 = 3.26.1-71.19
libgeocode-glib0(x86-32) = 3.26.1-71.19

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgeocode-glib0-3.26.1-71.19.i586.rpm
Source Package geocode-glib-3.26.1-71.19.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libgeocode-glib0 rpm package:
    # zypper install libgeocode-glib0

Files

Path
/usr/lib/libgeocode-glib.so.0
/usr/lib/libgeocode-glib.so.0.0.0
/usr/share/doc/packages/libgeocode-glib0/AUTHORS
/usr/share/doc/packages/libgeocode-glib0/NEWS
/usr/share/doc/packages/libgeocode-glib0/README
/usr/share/licenses/libgeocode-glib0/COPYING.LIB

Changelog

2019-03-14 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 3.26.1:
+ Fix crashes caused by Nominatim server changes.
+ Fix warnings when building the API documentation.
2018-06-06 - bjorn.lie@gmail.com
- Update to version 3.26.0:
+ Remove full build path from public headers so as to make the
build more easily reproduceable.
- Drop geocode-glib-make-reproducible.patch: Fixed upstream.
- Drop hicolor-icon-theme BuildRequires: No longer needed.
2018-03-17 - bjorn.lie@gmail.com
- Add geocode-glib-make-reproducible.patch: lib: Remove full build
path from public headers. So as to make the build more easily
reproducible.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2017-09-08 - jengelh@inai.de
- Update descriptions and RPM groups.
2017-08-09 - zaitor@opensuse.org
- Update to version 3.25.4.1:
+ Brown paperbag release to add news entry for 3.25.4.
- Changes from version 3.25.4:
+ Port to meson build system.
+ Drop autotools.
+ Provide a configure script for backwards compatibility.
+ Fix a warning from gcc 7.1.1.
- Add meson BuildRequires and switch autotools macros configure,
make and makeinstall to meson, meson_build and meson_install
following upstream switch to Meson build system.
- Replace gnome-doc-utils-devel with gtk-doc BuildRequires and pass
enable-gtk-doc=true to meson.
- Pass enable-installed-tests=false to meson, unsure if we should
package these or not, default upstream is yes.
2017-08-09 - zaitor@opensuse.org
- Update to version 3.24.0:
+ Stable bump only.
2017-02-07 - dimstar@opensuse.org
- Update to version 3.23.90:
+ Add g_autoptr cleanup functions.
+ Make code base const-correct.
+ Add backend abstraction.
+ Make unit-test base on offline mock backend.
+ Add support for multiple reverse results.
+ Add a user-agent property to override default user-agent.
+ Add equality functions to bbox/location/place.
+ Updated translations.
2016-04-15 - mgorse@suse.com
- Update to GNOME 3.20  Fate#318572
2016-04-12 - zaitor@opensuse.org
- Update to version 3.20.1:
+ Fix build for uClibc.

See Also

Package Description
libgeocode-glib0-32bit-3.26.1-71.19.x86_64.rpm Convenience library for the Yahoo! Place Finder APIs
libgepub-0_6-0-0.6.0-14.28.x86_64.rpm EPUB document reader library
libgepub-0_6-0-0.6.0-14.29.i586.rpm EPUB document reader library
libgepub-devel-0.6.0-14.28.x86_64.rpm Development files for libgepub
libgepub-devel-0.6.0-14.29.i586.rpm Development files for libgepub
libgfbgraph-0_2-0-0.2.3-16.24.x86_64.rpm Facebook Graph API access library
libgfbgraph-0_2-0-0.2.3-16.25.i586.rpm Facebook Graph API access library
libgio-2_0-0-2.62.3-420.3.x86_64.rpm A virtual file system library API
libgio-2_0-0-2.62.4-426.4.i586.rpm A virtual file system library API
libgio-2_0-0-32bit-2.62.4-426.4.x86_64.rpm A virtual file system library API
libgio-fam-2.62.3-420.3.x86_64.rpm GIO module to use FAM
libgio-fam-2.62.4-426.4.i586.rpm GIO module to use FAM
libgio-fam-32bit-2.62.4-426.4.x86_64.rpm GIO module to use FAM
libgiomm-2_4-1-2.62.0-25.10.i586.rpm C++ Interface for Gio
libgiomm-2_4-1-2.62.0-25.4.x86_64.rpm C++ Interface for Gio
Advertisement
Advertisement