libgcr-3-1-32bit-3.28.1-79.9.x86_64.rpm


Advertisement

Description

libgcr-3-1-32bit - Library for Crypto UI related tasks

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory all
Package filename libgcr-3-1-32bit-3.28.1-79.9.x86_64.rpm
Package name libgcr-3-1-32bit
Package version 3.28.1
Package release 79.9
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.gnome.org
License LGPL-2.1-or-later
Maintainer -
Download size 306.29 KB
Installed size 1.12 MB
GCR is a library for displaying certificates, and crypto UI, accessing
key stores.

Alternatives

Package Version Architecture Repository
libgcr-3-1-32bit-3.28.1-131.8.x86_64.rpm 3.28.1 x86_64 GNOME Next
libgcr-3-1-32bit-3.28.1-1.3.x86_64.rpm 3.28.1 x86_64 openSUSE Oss
libgcr-3-1-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.28) -
libcairo.so.2 -
libgck-1.so.0 -
libgcrypt.so.20 -
libgcrypt.so.20(GCRYPT_1.6) -
libgdk-3.so.0 -
libgdk_pixbuf-2.0.so.0 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgtk-3.so.0 -
libp11-kit.so.0 -
libpango-1.0.so.0 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -

Provides

Name Value
libgcr-3-1-32bit = 3.28.1-79.9
libgcr-3-1-32bit(x86-32) = 3.28.1-79.9
libgcr-base-3.so.1 -
libgcr-ui-3.so.1 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgcr-3-1-32bit-3.28.1-79.9.x86_64.rpm
Source Package gcr-3.28.1-79.9.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libgcr-3-1-32bit rpm package:
    # zypper install libgcr-3-1-32bit

Files

Path
/usr/lib/libgcr-3.so.1
/usr/lib/libgcr-3.so.1.0.0
/usr/lib/libgcr-base-3.so.1
/usr/lib/libgcr-base-3.so.1.0.0
/usr/lib/libgcr-ui-3.so.1
/usr/lib/libgcr-ui-3.so.1.0.0

Changelog

2019-01-18 - bjorn.lie@gmail.com
- Update to version 3.28.1:
+ system-prompter: Fix use of g_hash_table_lookup_extended.
+ Updated translations.
2018-03-12 - dimstar@opensuse.org
- Update to version 3.28.0:
+ Fix year 2038 workaround in ASN.1 decoder (bgo#787963).
+ Fix test errors when ssh-keygen is not found.
+ Updated translations.
2018-03-11 - dimstar@opensuse.org
- Supplement the new gcr-ssh-askpass for gpg2 and gnome-shell:
GNOME users want to have this available to enter the ssh key
passwords.
2018-03-09 - jengelh@inai.de
- Fix SRPM group. Update package summaries.
2018-03-05 - dimstar@opensuse.org
- Update to version 3.27.92:
+ Provide API for reliably calling ssh programs (bgo#735873).
+ Updated translations.
- Split new subpackage gcr-ssh-askpass, recommended by the main
library.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2018-02-27 - luc14n0@linuxmail.org
- Update to version 3.27.4:
+ Fixes:
- Encoding of EC parameters (bgo#785234).
- Hang in certificate export dialog (bgo#789804).
- Failure case in gcr_secure_memory_try_realloc() (bgo#775685).
+ Switch to using GLib resources.
+ Build fixes: bgo#771052, bgo#775685, bgo#775966, bgo#774312,
bgo#774311, bgo#764562, bgo#764569.
+ Updated translations.
- Drop %desktop_database_*, %mime_database_*, %icon_theme_cache_*
and %glib2_gsettings_schema_* post/postun scriptlets and
%glib2_gsettings_schema_requires macro: they're no longer needed
since RPM File Triggers cover their functionality now.
- Drop shared-mime-info BuildRequires: it's no longer needed now
that its macros are not used anymore.
- Drop pkgconfig(libtasn1) BuildRequires: it's no longer needed nor
used anymore.
- Adopt the use of %make_build macro rather than raw make command,
following the best practices.
- Add gtk-doc BuildRequires and pass enable-gtk-doc to configure as
the API's documentation is desired.
- Add pkgconfig(gtk+-x11-3.0) BuildRequires: it was being pulled
by gtk+-3.0 pkgconfig module and used already, since both of them
lives in gtk3-devel package.
- Rebase gcr-bsc932232-use-libgcrypt-allocators.patch.
2018-02-27 - dimstar@opensuse.org
- Use SPDX3.0 license tags and package COPYING as %license.
2018-02-26 - crrodriguez@opensuse.org
- Add explicit pkgconfig(pango) and pkgconfig(cairo) BuildRequires:
closer alignment with what configure checks for.
2016-08-31 - fezhang@suse.com
- Add openSUSE conditional macro and description tag for existing
patches in specfile.

See Also

Package Description
libgcr-devel-3.28.1-79.9.i586.rpm Development files for gcr, a library for crypto UI related tasks
libgcr-devel-3.28.1-79.9.x86_64.rpm Development files for gcr, a library for crypto UI related tasks
libgcr-devel-32bit-3.28.1-79.9.x86_64.rpm Development files for gcr, a library for crypto UI related tasks
libgda-5_0-4-5.2.8-167.2.i586.rpm GNU Data Access (GDA) Library
libgda-5_0-4-5.2.8-167.2.x86_64.rpm GNU Data Access (GDA) Library
libgda-5_0-4-lang-5.2.8-167.2.noarch.rpm Translations for package libgda
libgda-5_0-bdb-5.2.8-167.2.i586.rpm Berkeley DB Provider for GNU Data Access (GDA)
libgda-5_0-bdb-5.2.8-167.2.x86_64.rpm Berkeley DB Provider for GNU Data Access (GDA)
libgda-5_0-devel-5.2.8-167.2.i586.rpm GNU Data Access (GDA) Library -- Development Files
libgda-5_0-devel-5.2.8-167.2.x86_64.rpm GNU Data Access (GDA) Library -- Development Files
libgda-5_0-doc-5.2.8-167.2.i586.rpm GNU Data Access (GDA) Library -- Developer Documentation
libgda-5_0-doc-5.2.8-167.2.x86_64.rpm GNU Data Access (GDA) Library -- Developer Documentation
libgda-5_0-firebird-5.2.8-167.2.i586.rpm Firebird DB Provider for GNU Data Access (GDA)
libgda-5_0-firebird-5.2.8-167.2.x86_64.rpm Firebird DB Provider for GNU Data Access (GDA)
libgda-5_0-jdbc-5.2.8-167.2.i586.rpm JDBC Provider for GNU Data Access (GDA)
Advertisement
Advertisement