libevdocument3-4-3.34.2-266.9.i586.rpm


Advertisement

Description

libevdocument3-4 - GNOME Document Viewer System Library

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libevdocument3-4-3.34.2-266.9.i586.rpm
Package name libevdocument3-4
Package version 3.34.2
Package release 266.9
Package architecture i586
Package type rpm
Category System/Libraries
Homepage https://wiki.gnome.org/Apps/Evince
License GPL-2.0-or-later
Maintainer -
Download size 167.02 KB
Installed size 198.93 KB
Evince is a document viewer capable of displaying single-page and multi-page
document formats like PDF and PostScript.

Alternatives

Package Version Architecture Repository
libevdocument3-4-3.34.2-360.10.i586.rpm 3.34.2 i586 GNOME Next
libevdocument3-4-3.34.2-360.10.x86_64.rpm 3.34.2 x86_64 GNOME Next
libevdocument3-4-3.34.2-266.4.x86_64.rpm 3.34.2 x86_64 GNOME Factory
libevdocument3-4-3.34.2-1.1.i586.rpm 3.34.2 i586 openSUSE Oss
libevdocument3-4-3.34.2-1.1.x86_64.rpm 3.34.2 x86_64 openSUSE Oss
libevdocument3-4 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.28) -
libcairo.so.2 -
libgdk-3.so.0 -
libgdk_pixbuf-2.0.so.0 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgmodule-2.0.so.0 -
libgobject-2.0.so.0 -
libgtk-3.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libsynctex.so.2 -

Provides

Name Value
libevdocument3-4 = 3.34.2-266.9
libevdocument3-4(x86-32) = 3.34.2-266.9
libevdocument3.so.4 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libevdocument3-4-3.34.2-266.9.i586.rpm
Source Package evince-3.34.2-266.9.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libevdocument3-4 rpm package:
    # zypper install libevdocument3-4

Files

Path
/usr/lib/libevdocument3.so.4
/usr/lib/libevdocument3.so.4.0.0

Changelog

2019-11-23 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 3.34.2:
+ libview:
- Fix crash on DnD.
- Don't enable popup actions on page change.
+ Updated translations.
2019-11-05 - Antonio Larrosa <alarrosa@suse.com>
- Add patches to reverse the upstream requirement of at least
synctex 1.19 since that requires texlive 2019 and we have 2017 in
SLE 15. The patches are only applied when building evince with
synctex < 1.19:
* 0001-reversed-synctex-Move-_GNU_SOURCE-to-the-top-of-the-source-code.patch
* 0002-reversed-synctex-Remove-unused-labels.patch
* 0003-reversed-synctex-Silence-error-when-no-synctex-file-is-present.patch
* 0004-reversed-synctex-Annotate-functions-that-wrap-vfprintf.patch
* 0005-reversed-synctex-Fix-compilation.patch
* 0006-reversed-synctex-Update-from-version-1.18-to-1.21.patch
2019-10-07 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 3.34.1:
+ accessibility:
- Fix erroneous cast.
- Initialize private fields.
+ build: Distribute meson build files when using autotools.
+ flatpak: Update dependency versions.
+ i18n: Fix typo in Ukrainian translation for Download.
+ icon:
- Create a nightly app icon.
- Fix logo in README and add flatpak button.
+ shell:
- Ignore higher mouse buttons on links.
- Fix slow scrolling on last pages of big pdf's.
+ Updated translations.
2019-09-30 - bjorn.lie@gmail.com
- Update to version 3.34.0:
+ AppData: Add release information to AppData.
- Switch to using explicit tag in _service.
2019-09-30 - bjorn.lie@gmail.com
- Update to version 3.32.1+0:
+ AppData: Add 3.30 major release date.
+ Add release information to AppData.
2019-09-09 - bjorn.lie@gmail.com
- Update to version 3.32.0+28:
+ sidebar links: fix popup.
+ require Poppler 0.76.0 for ignoreDiacritics feature.
+ shell: remember unmaximized window size.
+ EvPresentationView: don't start render job until realized.
+ ev-page-action-widget: disconnect notify::document signal in
finalize.
+ backend: fix swapped y-coordinates when adding annotations.
+ ev_window: prevent NULL metadata being passed.
+ Updated translations.
- Switch to source services, use checkout from gnome-3.32 stable
branch.
- Switch to meson buildsystem. Add meson BuildRequires and macros,
as well as dropping libtool BuildRequires, no longer needed.
- Replace gcc-c++ with generic c++_compiler BuildRequires.
- Drop CVE-2019-11459.patch: Fixed upstream.
2019-06-03 - mgorse@suse.com
- Add CVE-2019-11459.patch: fix display of uninitialized memory if
TiffReadRGBAImageOriented fails (boo#1133037 CVE-2019-11459
glgo#GNOME/evince#1129).
2019-05-17 - mgorse@suse.com
- Remove Supplements from psdocument package, so that it isn't
pulled in by default (boo#1122794).
2019-03-14 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 3.32.0:
+ Updated translations.
2019-02-20 - bjorn.lie@gmail.com
- Update to version 3.31.91:
+ Updated translations.
- Changes from version 3.31.90:
+ Fix typo's spotted for max-scale and min-scale.
+ Remove '.flat' style from PDF forms GtkEntry's.
+ Set MIN_SCALE back to previous low value.
+ Revert removal of browser-plugin support.
+ Update app icon.
+ help:
- No more View menu.
- Replace title bar with header bar.
+ pdf backend: Ignore diacritics when searching text.
+ unarr: Update LZMA SDK.
+ Updated translations.

See Also

Package Description
libevview3-3-3.34.2-266.4.x86_64.rpm GNOME Document Viewer System Library
libevview3-3-3.34.2-266.9.i586.rpm GNOME Document Viewer System Library
libfarstream-0_2-5-0.2.8-43.20.x86_64.rpm GStreamer modules and libraries for videoconferencing
libfarstream-0_2-5-0.2.8-43.26.i586.rpm GStreamer modules and libraries for videoconferencing
libfarstream-0_2-5-32bit-0.2.8-43.26.x86_64.rpm GStreamer modules and libraries for videoconferencing
libflatpak0-1.4.3-89.1.x86_64.rpm OSTree based application bundle management library
libflatpak0-1.6.1-98.3.i586.rpm OSTree based application bundle management library
libfolks-data-0.13.1-104.6.x86_64.rpm Data files for libfolks, a library to create metacontacts from many sources
libfolks-data-0.13.1-107.2.i586.rpm Data files for libfolks, a library to create metacontacts from many sources
libfolks-eds25-0.13.1-104.6.x86_64.rpm Evolution Data Server backend for libfolks
libfolks-eds25-0.13.1-107.2.i586.rpm Evolution Data Server backend for libfolks
libfolks-telepathy25-0.13.1-104.6.x86_64.rpm Telepathy backend for libfolks
libfolks-telepathy25-0.13.1-107.2.i586.rpm Telepathy backend for libfolks
libfolks-tracker25-0.13.1-104.6.x86_64.rpm Tracker backend for libfolks
libfolks-tracker25-0.13.1-107.2.i586.rpm Tracker backend for libfolks
Advertisement
Advertisement