libenchant-2-2-32bit-2.2.5-70.9.x86_64.rpm


Advertisement

Description

libenchant-2-2-32bit - Generic Spell Checking Library

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libenchant-2-2-32bit-2.2.5-70.9.x86_64.rpm
Package name libenchant-2-2-32bit
Package version 2.2.5
Package release 70.9
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://abiword.github.io/enchant/
License LGPL-2.1-or-later
Maintainer -
Download size 31.35 KB
Installed size 49.71 KB
A library providing an efficient extensible abstraction for dealing
with different spell checking libraries.

Alternatives

Package Version Architecture Repository
libenchant-2-2-32bit-2.2.5-86.9.x86_64.rpm 2.2.5 x86_64 GNOME Next
libenchant-2-2-32bit-2.2.5-2.1.x86_64.rpm 2.2.5 x86_64 openSUSE Oss
libenchant-2-2-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libglib-2.0.so.0 -
libgmodule-2.0.so.0 -

Provides

Name Value
libenchant-2-2-32bit = 2.2.5-70.9
libenchant-2-2-32bit(x86-32) = 2.2.5-70.9
libenchant-2.so.2 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libenchant-2-2-32bit-2.2.5-70.9.x86_64.rpm
Source Package enchant-2.2.5-70.9.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libenchant-2-2-32bit rpm package:
    # zypper install libenchant-2-2-32bit

Files

Path
/usr/lib/libenchant-2.so.2
/usr/lib/libenchant-2.so.2.2.5

Changelog

2019-10-21 - Yifan Jiang <yfjiang@suse.com>
- Disable aspell support on SLE.
2019-10-18 - Yifan Jiang <yfjiang@suse.com>
- Redownload the 2.2.5 tarball to reflect the consistent upstream
release provided in Source.
2019-07-19 - Antonio Larrosa <alarrosa@suse.com>
- Update to version 2.2.5:
+ Fix a memory leak in the hunspell provider.
- Changes from version 2.2.4:
+ Fix a bug in the enchant program, where words ending in non-ASCII
characters were truncated during tokenization.
2019-04-03 - Micha? Rostecki <mrostecki@opensuse.org>
- Add enchant-2-backend-aspell package which provides the aspell
backend for enchant.
2018-06-03 - dleuenberger@suse.com
- Revert parts of last change: Still using supplementes instead of
boolean rich deps: zypper dup from < CODE15 is impossible
otherwise.
2018-05-29 - badshah400@gmail.com
- Fix installation of backends (bgo#1089433):
+ Drop Supplements entirely.
+ For the shared lib package, add conditional Requires on
either/both the hunspell or voikko backends depending on
whether the system has libhunspell and/or libvoikko installed.
+ Add a Suggests on -backend-hunspell for the case where neither
libvoikko not libhunspell are installed.
2018-03-10 - jengelh@inai.de
- Update descriptions.
2018-02-28 - dimstar@opensuse.org
- Update to version 2.2.3:
+ Brown paper bag: fix 2.2.2 as intended.
- Changes from version 2.2.2:
+ Fix a bug in the build system where the test harness would try
to delete files under root, typically the system libraries.
- Changes from version 2.2.1:
+ Fix a crash on invalid input with the hspell backend.
+ Remove some bashisms from the build system.
+ updates the Free Software Foundation?s street address.
+ Stop running some tests that fail on recent macOS.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner.
2017-12-13 - dimstar@opensuse.org
- Update to version 2.2.0:
+ Improves support for parallel installation with other major
versions of Enchant (specifically for man pages).
+ Fix relocation support.
+ Minor documentation improvements
+ Fix a potential crash in the hspell back-end.
- Update URL to https://abiword.github.io/enchant/.
- Adjust packaging, following the shared library packaging policy
and allowing for coexistance of enchant-1 and enchant-2 (as
foreseen by upstream):
+ Split enchant-1-data package (providing enchant-data, generic
name) from libenchant1.
+ Split enchant-1-backends from libenchant1: the main backends.
+ Add conflict to libenchant1 < 1.6.1 to the split packages (and
appropriate split provides).
+ Rename enchant-{voikko,zemberek} to
enchant-2-backend-{voikko,zemberek}.
- Drop enchant-hunspell-1.4.0.patch: no longer needed.

See Also

Package Description
libenchant1-1.6.1-18.1.x86_64.rpm Generic Spell Checking Library
libenchant1-1.6.1-18.7.i586.rpm Generic Spell Checking Library
libenchant1-32bit-1.6.1-18.7.x86_64.rpm Generic Spell Checking Library
libevdocument3-4-3.34.2-266.4.x86_64.rpm GNOME Document Viewer System Library
libevdocument3-4-3.34.2-266.9.i586.rpm GNOME Document Viewer System Library
libevview3-3-3.34.2-266.4.x86_64.rpm GNOME Document Viewer System Library
libevview3-3-3.34.2-266.9.i586.rpm GNOME Document Viewer System Library
libfarstream-0_2-5-0.2.8-43.20.x86_64.rpm GStreamer modules and libraries for videoconferencing
libfarstream-0_2-5-0.2.8-43.26.i586.rpm GStreamer modules and libraries for videoconferencing
libfarstream-0_2-5-32bit-0.2.8-43.26.x86_64.rpm GStreamer modules and libraries for videoconferencing
libflatpak0-1.4.3-89.1.x86_64.rpm OSTree based application bundle management library
libflatpak0-1.6.1-98.3.i586.rpm OSTree based application bundle management library
libfolks-data-0.13.1-104.6.x86_64.rpm Data files for libfolks, a library to create metacontacts from many sources
libfolks-data-0.13.1-107.2.i586.rpm Data files for libfolks, a library to create metacontacts from many sources
libfolks-eds25-0.13.1-104.6.x86_64.rpm Evolution Data Server backend for libfolks
Advertisement
Advertisement