libchamplain-0_12-0-0.12.20-100.8.i586.rpm


Advertisement

Description

libchamplain-0_12-0 - Library to display maps

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libchamplain-0_12-0-0.12.20-100.8.i586.rpm
Package name libchamplain-0_12-0
Package version 0.12.20
Package release 100.8
Package architecture i586
Package type rpm
Category Development/Libraries/GNOME
Homepage https://wiki.gnome.org/Projects/libchamplain
License LGPL-2.1-or-later
Maintainer -
Download size 141.60 KB
Installed size 404.56 KB
Libchamplain is a C library providing a ClutterActor to display maps. It
also provides a Gtk+ widget to display maps in Gtk+ applications.
It supports numerous free map sources such as OpenStreetMap,
OpenAerialMap and Maps for free.

Alternatives

Package Version Architecture Repository
libchamplain-0_12-0-0.12.20-131.8.i586.rpm 0.12.20 i586 GNOME Next
libchamplain-0_12-0-0.12.20-131.8.x86_64.rpm 0.12.20 x86_64 GNOME Next
libchamplain-0_12-0-0.12.20-100.4.x86_64.rpm 0.12.20 x86_64 GNOME Factory
libchamplain-0_12-0-0.12.20-1.1.i586.rpm 0.12.20 i586 openSUSE Oss
libchamplain-0_12-0-0.12.20-1.1.x86_64.rpm 0.12.20 x86_64 openSUSE Oss
libchamplain-0_12-0 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -
libcairo-gobject.so.2 -
libcairo.so.2 -
libclutter-1.0.so.0 -
libclutter-gtk-1.0.so.0 -
libcogl-path.so.20 -
libcogl.so.20 -
libgdk-3.so.0 -
libgdk_pixbuf-2.0.so.0 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgtk-3.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.27) -
libm.so.6(GLIBC_2.29) -
libpango-1.0.so.0 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libsoup-2.4.so.1 -
libsqlite3.so.0 -

Provides

Name Value
libchamplain-0.12.so.0 -
libchamplain-0_12-0 = 0.12.20-100.8
libchamplain-0_12-0(x86-32) = 0.12.20-100.8
libchamplain-gtk-0.12.so.0 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libchamplain-0_12-0-0.12.20-100.8.i586.rpm
Source Package libchamplain-0.12.20-100.8.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libchamplain-0_12-0 rpm package:
    # zypper install libchamplain-0_12-0

Files

Path
/usr/lib/libchamplain-0.12.so.0
/usr/lib/libchamplain-0.12.so.0.11.10
/usr/lib/libchamplain-gtk-0.12.so.0
/usr/lib/libchamplain-gtk-0.12.so.0.11.10
/usr/share/doc/packages/libchamplain-0_12-0/AUTHORS
/usr/share/doc/packages/libchamplain-0_12-0/NEWS
/usr/share/doc/packages/libchamplain-0_12-0/README.md
/usr/share/licenses/libchamplain-0_12-0/COPYING

Changelog

2019-10-29 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 0.12.20:
+ Remove autotools-based build and all the related files.
+ Fix gtk-doc module name.
+ Add missing gdk required dependency.
+ Make the build reproducible.
2019-03-03 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 0.12.19:
+ Fix incorrect Requires in pc files when using meson.
+ Various meson-related fixes and cleanups.
2019-02-21 - bjorn.lie@gmail.com
- Update to version 0.12.18:
+ Fix incorrect so version when using meson.
+ Avoid exporting marshaler functions by dropping the use of
glib-genmarshal and using the generic marshaler instead.
+ Don't use glib-mkenums for champlain-gtk where it's not needed.
- Changes from version 0.12.17:
+ Use of meson build system, CI tests and automatized generation
of documentation.
+ Various map wrapping fixes.
+ Pass data as uint8 pointer in champlain_renderer_set_data() and
make this function introspectable.
+ Bump versions of some dependencies - clutter (1.24), glib
(2.38) - and fix depreciation warnings.
+ Use https for all map sources that support it.
+ Don't version-control generated vapi files.
+ Combine champlain and champlain-gtk documentations into one.
+ More helpful README.md with links to pages related to
libchamplain.
+ Various housekeeping and cleanups.
- Drop patch fixed upstream:
libchamplain-Fix-wrapping-champlain_view_x_to_longitude.patch.
- Switch to meson build system, add meson BuildRequires and macros.
2019-01-03 - bjorn.lie@gmail.com
- No longer build mephis support: Drop memphis-devel BuildRequires,
memphis upstream is dead and gone from the web for several years.
libchamplain upstream have disabled mephis support in git 5 years
ago, so we should not build it either. Pass --disable-memphis to
configure to be ensure we do not.
- Pkgconfigify spec, align with what configure checks for:
+ Drop clutter-devel, clutter-gtk-devel, gtk3-devel,
libsoup-devel, sqlite3-devel and vala BuildRequires.
+ Add pkgconfig, pkgconfig(cairo), pkgconfig(clutter-1.0),
pkgconfig(clutter-gtk-1.0), pkgconfig(gdk-3.0),
pkgconfig(gio-2.0), pkgconfig(glib-2.0),
pkgconfig(gobject-2.0), pkgconfig(gtk+-3.0),
pkgconfig(libsoup-2.4), pkgconfig(sqlite3) and
pkgconfig(vapigen) BuildRequires.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2018-01-28 - bjorn.lie@gmail.com
- Add
libchamplain-Fix-wrapping-champlain_view_x_to_longitude.patch:
Fix wrapping in champlain_view_x_to_longitude. Previous
implementation assumed that after using x_to_wrap_x further
wrapping would be needed only if x + priv->viewport_x >= width.
- Do minor spec cleanup, use autosetup, make_build and make_install
macros, drop obsolete and unused BUILD_FROM_VCS conditional
gnome-common and gtk-doc BuildRequires and autogen.sh call.
2017-09-06 - dimstar@opensuse.org
- Update to version 0.12.16:
+ Add possibility to set User-Agent for requests.
+ Fix touch gesture zoom.
+ Python demo fixes and cleanups.
2017-03-08 - zaitor@opensuse.org
- Update to version 0.12.15:
+ Fix path layer surface exporting when no clone is visible.
+ Fix printing in gnome-maps.
+ Fix build on RHEL 7.3.
+ Minor example updates.
2016-09-07 - zaitor@opensuse.org
- Update to version 0.12.14:
+ Add support for horizontal map wrapping.
+ Make the number of parallel connections of network tile source
configurable.
+ Remove Mapquest map source as the tile server is not accessible
any more.
+ Remove Maemo-related code.
+ Fix small memory leaks.
+ Bump libsoup dependency requirement to 2.42 and drop deprecated
function calls.
+ Various minor improvements, fixes, depreciaton warning removals
and cleanups.
2016-04-15 - mgorse@suse.com
- Update to GNOME 3.20  Fate#318572

See Also

Package Description
libchamplain-devel-0.12.20-100.4.x86_64.rpm Library to dusplay maps - Development Files
libchamplain-devel-0.12.20-100.8.i586.rpm Library to dusplay maps - Development Files
libcheck0-0.12.0-57.44.x86_64.rpm Unit Test Framework for C
libcheck0-0.12.0-57.50.i586.rpm Unit Test Framework for C
libcheck0-32bit-0.12.0-57.50.x86_64.rpm Unit Test Framework for C
libcheese-common-3.34.0-239.8.x86_64.rpm Common data files for the Cheese webcam booth
libcheese-common-3.34.0-242.2.i586.rpm Common data files for the Cheese webcam booth
libcheese-gtk25-3.34.0-239.8.x86_64.rpm UI library for the Cheese a webcam booth
libcheese-gtk25-3.34.0-242.2.i586.rpm UI library for the Cheese a webcam booth
libcheese8-3.34.0-239.8.x86_64.rpm Library implementing a webcam booth for GNOME
libcheese8-3.34.0-242.2.i586.rpm Library implementing a webcam booth for GNOME
libcloudproviders-devel-0.3.0-10.11.i586.rpm Development files for libcloudproviders
libcloudproviders-devel-0.3.0-10.7.x86_64.rpm Development files for libcloudproviders
libcloudproviders0-0.3.0-10.11.i586.rpm Library to integrate cloud storage providers
libcloudproviders0-0.3.0-10.7.x86_64.rpm Library to integrate cloud storage providers
Advertisement
Advertisement