libcanberra-gtk3-0-0.30-87.17.i586.rpm


Advertisement

Description

libcanberra-gtk3-0 - Portable sound event library -- GTK+ 3 Library

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory all
Package filename libcanberra-gtk3-0-0.30-87.17.i586.rpm
Package name libcanberra-gtk3-0
Package version 0.30
Package release 87.17
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://0pointer.de/lennart/projects/libcanberra
License LGPL-2.0-or-later
Maintainer -
Download size 15.86 KB
Installed size 21.59 KB
libcanberra is an implementation of the XDG Sound Theme and Name
Specifications, for generating event sounds on free desktops, such
as GNOME. It comes with several backends (ALSA, PulseAudio, null)
and is designed to be portable.
This package contains a library to make it easier to use
libcanberra from GTK+ 3 applications.

Alternatives

Package Version Architecture Repository
libcanberra-gtk3-0-0.30-100.19.i586.rpm 0.30 i586 GNOME Next
libcanberra-gtk3-0-0.30-100.19.x86_64.rpm 0.30 x86_64 GNOME Next
libcanberra-gtk3-0-0.30-87.17.x86_64.rpm 0.30 x86_64 GNOME Factory
libcanberra-gtk3-0-0.30-15.3.i586.rpm 0.30 i586 openSUSE Oss
libcanberra-gtk3-0-0.30-15.3.x86_64.rpm 0.30 x86_64 openSUSE Oss
libcanberra-gtk3-0 - - -

Requires

Name Value
/sbin/ldconfig -
libX11.so.6 -
libc.so.6(GLIBC_2.4) -
libcanberra.so.0 -
libgdk-3.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgtk-3.so.0 -
libpthread.so.0 -

Provides

Name Value
libcanberra-gtk3-0 = 0.30-87.17
libcanberra-gtk3-0(x86-32) = 0.30-87.17
libcanberra-gtk3.so.0 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libcanberra-gtk3-0-0.30-87.17.i586.rpm
Source Package libcanberra-0.30-87.17.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libcanberra-gtk3-0 rpm package:
    # zypper install libcanberra-gtk3-0

Files

Path
/usr/lib/libcanberra-gtk3.so.0
/usr/lib/libcanberra-gtk3.so.0.1.9

Changelog

2018-03-05 - jengelh@inai.de
- Fix SRPM group. Update summaries.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2016-12-19 - sor.alexei@meowr.ru
- Remove the lynx build dependency: of questionable need.
- Build for Gtk3 unconditionally.
- Spec cleanup.
2016-05-25 - sreeves@suse.com
- Update to GNOME 3.20.2 Fate#318572
2016-01-14 - dimstar@opensuse.org
- Do not require sound-theme-freedesktop by libcanberra0: if this
is wanted on a default install, it is up to the DE pattern to
recommend/require this - it is not needed for the libraries
proper functioning.
2015-12-28 - zaitor@opensuse.org
- Split out libcanberra-gtk-devel and libcanberra-gtk3-devel
sub-packages, this will make it possible for us to build
dependant packages without having to pull in both gtk2 and gtk3.
2015-11-06 - zaitor@opensuse.org
- Split out a new sub-package canberra-gtk-play-gnome: Currently
there are no desktop-login, desktop-logout or session-ready
sounds in the freedesktop sound theme, so installing this will
require a different sound-theme for it to be operational. Having
this in a own sub-package will avoid logspam about missing files.
Fixes boo#953862.
2013-02-06 - dimstar@opensuse.org
- Drop pkgconfig(gstreamer-1.0) BuildRequires: no longer build the
gstreamer backend. The default is PulseAudio, with a fallback to
alsa, which is sufficient. Helps against issues like bnc#800963.
2012-11-09 - michael.meeks@suse.com
- Add libcanberra-broadway-fix.patch: Fix crash with
libcanberra-gtk-module's and non-X11 displays (bnc#789066).
2012-09-25 - dimstar@opensuse.org
- Update to version 0.30:
+ Minor bug fixes
+ Explicitly require x11 for GTK linking
+ Port to GStreamer 1.0.
- Add pkgconfig(glib-2.0) BuildRequires so it can be versioned.
- Add pkgconfig(x11) BuildRequires: new explicit dependency.
- Drop libcanberra-gst10.patch: fixed upstream.
- Drop libtool BuildRequires and call to ./autogen.sh: no patch
requires bootstrapping.

See Also

Package Description
libcanberra-gtk3-0-32bit-0.30-87.17.x86_64.rpm Portable sound event library -- GTK+ 3 Library
libcanberra-gtk3-devel-0.30-87.17.i586.rpm GTK+ 3 development files for libcanberra
libcanberra-gtk3-devel-0.30-87.17.x86_64.rpm GTK+ 3 development files for libcanberra
libcanberra-gtk3-module-0.30-87.17.i586.rpm Portable sound event library -- GTK+ 3 Module
libcanberra-gtk3-module-0.30-87.17.x86_64.rpm Portable sound event library -- GTK+ 3 Module
libcanberra-gtk3-module-32bit-0.30-87.17.x86_64.rpm Portable sound event library -- GTK+ 3 Module
libcanberra0-0.30-87.17.i586.rpm Portable sound event library
libcanberra0-0.30-87.17.x86_64.rpm Portable sound event library
libcanberra0-32bit-0.30-87.17.x86_64.rpm Portable sound event library
libcaribou0-0.4.21-77.22.i586.rpm On-screen Keyboard for GNOME -- Library
libcaribou0-0.4.21-77.22.x86_64.rpm On-screen Keyboard for GNOME -- Library
libchamplain-0_12-0-0.12.19-98.5.i586.rpm Library to display maps
libchamplain-0_12-0-0.12.19-98.5.x86_64.rpm Library to display maps
libchamplain-devel-0.12.19-98.5.i586.rpm Library to dusplay maps - Development Files
libchamplain-devel-0.12.19-98.5.x86_64.rpm Library to dusplay maps - Development Files
Advertisement
Advertisement