libatspi0-2.34.0-190.11.i586.rpm


Advertisement

Description

libatspi0 - Assistive Technology Service Provider Interface

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libatspi0-2.34.0-190.11.i586.rpm
Package name libatspi0
Package version 2.34.0
Package release 190.11
Package architecture i586
Package type rpm
Category System/Libraries
Homepage https://www.gnome.org/
License LGPL-2.1-or-later
Maintainer -
Download size 111.58 KB
Installed size 222.84 KB
AT-SPI is a general interface for applications to make use of the
accessibility toolkit. This version is based on dbus.

Alternatives

Package Version Architecture Repository
libatspi0-2.34.0-325.11.i586.rpm 2.34.0 i586 GNOME Next
libatspi0-2.34.0-325.11.x86_64.rpm 2.34.0 x86_64 GNOME Next
libatspi0-2.34.0-190.4.x86_64.rpm 2.34.0 x86_64 GNOME Factory
libatspi0-2.34.0-1.1.i586.rpm 2.34.0 i586 openSUSE Oss
libatspi0-2.34.0-1.1.x86_64.rpm 2.34.0 x86_64 openSUSE Oss
libatspi0 - - -

Requires

Name Value
/sbin/ldconfig -
libX11.so.6 -
libc.so.6(GLIBC_2.7) -
libdbus-1.so.3 -
libdbus-1.so.3(LIBDBUS_1_3) -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -

Provides

Name Value
libatspi.so.0 -
libatspi0 = 2.34.0-190.11
libatspi0(x86-32) = 2.34.0-190.11

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libatspi0-2.34.0-190.11.i586.rpm
Source Package at-spi2-core-2.34.0-190.11.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libatspi0 rpm package:
    # zypper install libatspi0

Files

Path
/usr/lib/libatspi.so.0
/usr/lib/libatspi.so.0.0.1

Changelog

2019-09-09 - mgorse@suse.com
- Update to version 2.34.0:
+ Fix a use after free when freeing an event.
+ Clean up handling of the X11 property specifying the bus
address.
+ Update doap.
2019-09-02 - mgorse@suse.com
- Update to version 2.33.92:
+ Now requires meson 0.50.0.
+ License is now LGPL-2.1+.
+ Meson: only link to libdl when it is necessary.
+ Update installation instructions.
+ Clarify atspi_editable_text_insert_text documentation.
+ Do not warn on no reply from pending get_items call.
+ Eliminate some superfluous runtime warnings.
- Require meson >= 0.50.0.
- Set license to LGPL-2.1-or-later.
2019-08-30 - mgorse@suse.com
- Update to version 2.33.90:
+ Refactor the API for the screen reader to notify listeners
of its status.
+ Add a sender to the AtspiEvent struct.
+ Add missing atspi_application_get_type prototype.
+ Support mutter remote desktop interface for synthesizing
keyboard/mouse events (likely still needs work).
2019-06-25 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.33.2:
+ Check WAYLAND_DISPLAY, rather than XDG_SESSION_TYPE, to avoid X
connections. Fixes breakage if X is started with startx and
XDG_SESSION_TYPE is unset.
+ X11: also try mod4 and mod5 to generate keysyms.
+ Add ATSPI_ROLE_CONTENT_DELETION and
ATSPI_ROLE_CONTENT_INSERTION.
+ Check for dbus-daemon in /usr/lib (for Solaris).
2019-04-10 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.32.1:
+ Fix meson build for meson 0.50.0 and newer.
- Drop at-spi2-core-meson-build-fix.patch: Fixed upstream.
2019-03-12 - mgorse@suse.com
- Add at-spi2-core-meson-build-fix.patch: fix build for meson
0.50.0 (glgo#GNOME/at-spi2-core!9).
2019-03-12 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.32.0:
+ Stable release version bump.
2019-03-04 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.31.92:
+ Fix atspi_table_cell_get_(row_column)_headers.
+ Update documentation to indicate that extents are only
meaningful when an object has both STATE_VISIBLE and
STATE_SHOWING.
+ Use a consistent style for the meson options.
+ Fix a compiler warning on BSD.
+ Add ScrollSubstringTo and ScrollSubstringToPoint text
interfaces.
- Enable gtk-docs BuildRequires and update options passed to meson.
- Drop unneeded and unused intltool BuildRequires.
2019-03-04 - bjorn.lie@gmail.com
- Update to version 2.31.2:
+ Add ScrollSubstringTo and ScrollSubstringToPoint text
interfaces.
2019-03-04 - bjorn.lie@gmail.com
- Update to version 2.31.1:
+ Bus launcher: fix an issue where the error wasn't cleared on
failure.
+ Add support for locking/unlocking modifiers.
+ Update error log text for consistency.
+ Documentation clean-ups.
- Drop upstream fixed patches:
+ at-spi2-core-bus-launch-use__linux__.patch.
+ at-spi2-core-generate-pc.patch.

See Also

Package Description
libatspi0-32bit-2.34.0-190.11.x86_64.rpm Assistive Technology Service Provider Interface
libavahi-client3-0.7-198.6.x86_64.rpm D-Bus Service for Zeroconf and Bonjour
libavahi-client3-0.7-208.2.i586.rpm D-Bus Service for Zeroconf and Bonjour
libavahi-client3-32bit-0.7-208.2.x86_64.rpm D-Bus Service for Zeroconf and Bonjour
libavahi-common3-0.7-198.6.x86_64.rpm D-Bus Service for Zeroconf and Bonjour
libavahi-common3-0.7-208.2.i586.rpm D-Bus Service for Zeroconf and Bonjour
libavahi-common3-32bit-0.7-208.2.x86_64.rpm D-Bus Service for Zeroconf and Bonjour
libavahi-core7-0.7-198.6.x86_64.rpm D-Bus Service for Zeroconf and Bonjour
libavahi-core7-0.7-208.2.i586.rpm D-Bus Service for Zeroconf and Bonjour
libavahi-devel-0.7-198.6.x86_64.rpm Header files for the Zeroconf/Bonjour D-Bus service
libavahi-devel-0.7-208.2.i586.rpm Header files for the Zeroconf/Bonjour D-Bus service
libavahi-glib-devel-0.7-199.8.x86_64.rpm Header files for Avahi's Glib bindings
libavahi-glib-devel-0.7-209.2.i586.rpm Header files for Avahi's Glib bindings
libavahi-glib1-0.7-199.8.x86_64.rpm Glib Bindings for avahi, the D-Bus Service for Zeroconf and Bonjour
libavahi-glib1-0.7-209.2.i586.rpm Glib Bindings for avahi, the D-Bus Service for Zeroconf and Bonjour
Advertisement
Advertisement