libanjuta-3-0-3.34.0-216.7.x86_64.rpm


Advertisement

Description

libanjuta-3-0 - Library for developing Anjuta plugins

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename libanjuta-3-0-3.34.0-216.7.x86_64.rpm
Package name libanjuta-3-0
Package version 3.34.0
Package release 216.7
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://wiki.gnome.org/Apps/Anjuta
License GPL-2.0-or-later
Maintainer -
Download size 202.71 KB
Installed size 733.25 KB
Anjuta is a versatile Integrated Development Environment (IDE) for the
GNOME desktop.

Alternatives

Package Version Architecture Repository
libanjuta-3-0-3.34.0-303.1.i586.rpm 3.34.0 i586 GNOME Next
libanjuta-3-0-3.34.0-303.1.x86_64.rpm 3.34.0 x86_64 GNOME Next
libanjuta-3-0-3.34.0-219.1.i586.rpm 3.34.0 i586 GNOME Factory
libanjuta-3-0-3.34.0-1.1.i586.rpm 3.34.0 i586 openSUSE Oss
libanjuta-3-0-3.34.0-1.1.x86_64.rpm 3.34.0 x86_64 openSUSE Oss
libanjuta-3-0 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -
libcairo.so.2()(64bit) -
libgdk-3.so.0()(64bit) -
libgdk_pixbuf-2.0.so.0()(64bit) -
libgdl-3.so.5()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgmodule-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-3.so.0()(64bit) -
libpango-1.0.so.0()(64bit) -
libpangocairo-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libutil.so.1()(64bit) -
libutil.so.1(GLIBC_2.2.5)(64bit) -
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -

Provides

Name Value
libanjuta-3-0 = 3.34.0-216.7
libanjuta-3-0(x86-64) = 3.34.0-216.7
libanjuta-3.so.0()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libanjuta-3-0-3.34.0-216.7.x86_64.rpm
Source Package anjuta-3.34.0-216.7.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install libanjuta-3-0 rpm package:
    # zypper install libanjuta-3-0

Files

Path
/usr/lib64/libanjuta-3.so.0
/usr/lib64/libanjuta-3.so.0.0.0

Changelog

2019-09-08 - mgorse@suse.com
- Update to version 3.34.0:
+ Replace Bugzilla by Gitlab URL in DOAP file.
+ Add new vala version.
+ anjuta-tags: fix tag for vala language.
+ Convert README to markdown.
+ Add build rule so that README is not flagged as missing.
+ build: Allow building with vala 0.44.
+ Fix error in distcheck.
+ build: Don't require exact match in the bison check.
+ Updated translations.
2018-03-20 - dimstar@opensuse.org
- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).
2018-03-15 - dimstar@opensuse.org
- Replace pkgconfig(libvala-0.38) BuildRequires with libvala-devel.
2018-03-11 - luc14n0@linuxmail.org
- Update to version 3.28.0:
+ help: Fix build-tutorial.
+ Fix a random crash when vim modelines are used.
+ Updated translations.
- Drop:
- update-desktop-files BuildRequires and its macro: they are no
longer required anymore.
- shared-mime-info BuildRequires, and glib2_gsettings_schema_*,
desktop_database_*, icon_theme_cache_* and mime_database_*
post/postun scriptlets and glib2_gsettings_schema_requires
macro: their functionality has been moved to RPM file triggers
(RPM 4.13, suse_vesion 1330).
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2017-09-10 - zaitor@opensuse.org
- Update to version 3.26.0:
+ Remove some untracked files from git status (bgo#787473).
+ Language-support-vala fails to build with vala 0.38
(bgo#786973).
+ Updated translations.
- Stop passing --disable-vala to configure, bug fixed upstream.
2017-09-08 - jengelh@inai.de
- Trim descriptions in secondary packages, and update summaries.
Do not run fdupes across hardlink boundaries.
2017-08-30 - dimstar@opensuse.org
- Pass --disable-vala to configure until bgo#786973 is resolved.
2017-08-20 - zaitor@opensuse.org
- Update to version 3.25.91:
+ bgo#782633: Scintilla editor occupies 100% of a core after
switching tabs.
+ bgo#782452: Using #!/usr/bin/perl in scripts is not portable.
+ Avoid errors with recent version of gcc.
+ gdb: bgo#783380: Unable to debug executable compiled with -pie
option.
+ bgo#770822: "Search for example code" points to discontinued
webpage
+ bgo#763115: Anjuta builds are not reproducible.
+ Fix some compiler warnings.
+ Fix warning misleading-indentation.
+ Remove obsolete CSS properties.
+ Remove deprecated flags.
+ Fix some run time critical warnings.
+ Avoid an endless loop when updating a project.
+ Fix another crash when updating project files.
+ bgo#786309: segfault when shm support is missing.
+ gtksourceview: Ignore changes that happen during a save.
+ symbol-db: add support for libgda-6.0.
+ Support reproducible builds.
+ manuals: Remove extra - symbols before =.
+ Allow building with vala 0.36 and 0.38.
+ bgo#771625: needs support for vala 0.34.
+ Fix callback generation when user_data is set on glade.
+ Fix translator comments.
+ Updated translations.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
- Drop anjuta-vala-0.34.patch and anjuta-fix-gcc7-build.patch:
Fixed upstream, following this, drop gnome-common BuildRequires:
and autogen.sh call, no longer needed.
2017-07-20 - zaitor@opensuse.org
- Build with vala 0.38:
+ Replace pkgconfig(libvala-0.36) BuildRequires with
pkgconfig(libvala-0.38).
+ Extend anjuta-vala-0.34.patch: add support for vala 0.38.

See Also

Package Description
libappstream-glib8-0.7.15-152.7.x86_64.rpm AppStream Abstraction Library
libappstream-glib8-0.7.16-154.5.i586.rpm AppStream Abstraction Library
libart_lgpl-devel-2.3.21-43.12.x86_64.rpm Header files for the libart 2D graphics library
libart_lgpl-devel-2.3.21-43.15.i586.rpm Header files for the libart 2D graphics library
libart_lgpl-devel-32bit-2.3.21-43.15.x86_64.rpm Header files for the libart 2D graphics library
libart_lgpl_2-2-2.3.21-43.12.x86_64.rpm Libart Components Licensed under the LGPL
libart_lgpl_2-2-2.3.21-43.15.i586.rpm Libart Components Licensed under the LGPL
libart_lgpl_2-2-32bit-2.3.21-43.15.x86_64.rpm Libart Components Licensed under the LGPL
libatk-1_0-0-2.34.1-126.10.i586.rpm An Accessibility Toolkit
libatk-1_0-0-2.34.1-126.4.x86_64.rpm An Accessibility Toolkit
libatk-1_0-0-32bit-2.34.1-126.10.x86_64.rpm An Accessibility Toolkit
libatk-bridge-2_0-0-2.34.1-166.4.x86_64.rpm ATK/D-Bus bridging library
libatk-bridge-2_0-0-2.34.1-166.9.i586.rpm ATK/D-Bus bridging library
libatk-bridge-2_0-0-32bit-2.34.1-166.9.x86_64.rpm ATK/D-Bus bridging library
libatkmm-1_6-1-2.28.0-8.14.x86_64.rpm C++ Binding for the ATK library
Advertisement
Advertisement