json-glib-devel-1.4.4-80.23.x86_64.rpm


Advertisement

Description

json-glib-devel - Development files for libjson-glib

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename json-glib-devel-1.4.4-80.23.x86_64.rpm
Package name json-glib-devel
Package version 1.4.4
Package release 80.23
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://live.gnome.org/JsonGlib
License LGPL-2.1-or-later
Maintainer -
Download size 107.87 KB
Installed size 772.45 KB
JSON-GLib provides a parser and a generator GObject classes and various
wrappers for the complex data types employed by JSON, such as arrays
and objects.
This package contains development files needed to develop with the
json-glib library.

Alternatives

Package Version Architecture Repository
json-glib-devel-1.4.4-115.3.i586.rpm 1.4.4 i586 GNOME Next
json-glib-devel-1.4.4-115.3.x86_64.rpm 1.4.4 x86_64 GNOME Next
json-glib-devel-1.4.4-83.3.i586.rpm 1.4.4 i586 GNOME Factory
json-glib-devel-1.4.4-1.5.i586.rpm 1.4.4 i586 openSUSE Oss
json-glib-devel-1.4.4-1.5.x86_64.rpm 1.4.4 x86_64 openSUSE Oss
json-glib-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libc.so.6(GLIBC_2.4)(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libjson-glib-1.0.so.0()(64bit) -
libjson-glib-1_0-0 = 1.4.4
pkgconfig(gio-2.0) >= 2.44.0
pkgconfig(gobject-2.0) >= 2.44.0
typelib-1_0-Json-1_0 = 1.4.4

Provides

Name Value
json-glib-devel = 1.4.4-80.23
json-glib-devel(x86-64) = 1.4.4-80.23
pkgconfig(json-glib-1.0) = 1.4.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package json-glib-devel-1.4.4-80.23.x86_64.rpm
Source Package json-glib-1.4.4-80.23.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install json-glib-devel rpm package:
    # zypper install json-glib-devel

Files

Path
/usr/bin/json-glib-format
/usr/bin/json-glib-validate
/usr/include/json-glib-1.0/
/usr/include/json-glib-1.0/json-glib/json-builder.h
/usr/include/json-glib-1.0/json-glib/json-enum-types.h
/usr/include/json-glib-1.0/json-glib/json-generator.h
/usr/include/json-glib-1.0/json-glib/json-glib.h
/usr/include/json-glib-1.0/json-glib/json-gobject.h
/usr/include/json-glib-1.0/json-glib/json-gvariant.h
/usr/include/json-glib-1.0/json-glib/json-parser.h
/usr/include/json-glib-1.0/json-glib/json-path.h
/usr/include/json-glib-1.0/json-glib/json-reader.h
/usr/include/json-glib-1.0/json-glib/json-types.h
/usr/include/json-glib-1.0/json-glib/json-utils.h
/usr/include/json-glib-1.0/json-glib/json-version-macros.h
/usr/include/json-glib-1.0/json-glib/json-version.h
/usr/lib/installed-tests/
/usr/lib/installed-tests/json-glib-1.0/array
/usr/lib/installed-tests/json-glib-1.0/boxed
/usr/lib/installed-tests/json-glib-1.0/builder
/usr/lib/installed-tests/json-glib-1.0/generator
/usr/lib/installed-tests/json-glib-1.0/gvariant
/usr/lib/installed-tests/json-glib-1.0/invalid
/usr/lib/installed-tests/json-glib-1.0/node
/usr/lib/installed-tests/json-glib-1.0/object
/usr/lib/installed-tests/json-glib-1.0/parser
/usr/lib/installed-tests/json-glib-1.0/path
/usr/lib/installed-tests/json-glib-1.0/reader
/usr/lib/installed-tests/json-glib-1.0/serialize-complex
/usr/lib/installed-tests/json-glib-1.0/serialize-full
/usr/lib/installed-tests/json-glib-1.0/serialize-simple
/usr/lib/installed-tests/json-glib-1.0/stream-load.json
/usr/lib64/libjson-glib-1.0.so
/usr/lib64/pkgconfig/json-glib-1.0.pc
/usr/share/doc/packages/json-glib-devel/NEWS
/usr/share/doc/packages/json-glib-devel/README.md
/usr/share/gir-1.0/Json-1.0.gir
/usr/share/installed-tests/
/usr/share/installed-tests/json-glib-1.0/array.test
/usr/share/installed-tests/json-glib-1.0/boxed.test
/usr/share/installed-tests/json-glib-1.0/builder.test
/usr/share/installed-tests/json-glib-1.0/generator.test
/usr/share/installed-tests/json-glib-1.0/gvariant.test
/usr/share/installed-tests/json-glib-1.0/invalid.test
/usr/share/installed-tests/json-glib-1.0/node.test
/usr/share/installed-tests/json-glib-1.0/object.test
/usr/share/installed-tests/json-glib-1.0/parser.test
/usr/share/installed-tests/json-glib-1.0/path.test
/usr/share/installed-tests/json-glib-1.0/reader.test
/usr/share/installed-tests/json-glib-1.0/serialize-complex.test
/usr/share/installed-tests/json-glib-1.0/serialize-full.test
/usr/share/installed-tests/json-glib-1.0/serialize-simple.test

Changelog

2018-09-26 - bjorn.lie@gmail.com
- Update to version 1.4.4:
+ Fix memory leaks.
+ Fix behaviour of JsonParser with immutable nodes for empty
documents.
+ Clarify documentation.
+ Update autoptr macro for JsonNode to use json_node_unref().
+ Update the enumeration types template.
+ Perform fuzzy comparisons for floating point values in the test
suite.
+ Updated translations.
2018-04-26 - sbrabec@suse.com
- Set gettext domain explicitly in translation-update-upstream,
as it does not support complex meson.build expressions
(bsc#1087076#c21).
2018-03-20 - dimstar@opensuse.org
- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2017-09-12 - dimstar@opensuse.org
- Update to version 1.4.2:
+ Literally no change, just a re-released tarball. The tarball
generated for 1.4.0 and pushed to download.gnome.org comes from
a different commit.
2017-09-12 - dimstar@opensuse.org
- Update to version 1.4.0:
+ Update the linker flags on macOS (bgo#785053).
+ Change the build configuration options to better fit with
Meson.
+ Updated translations.
2017-09-11 - jengelh@inai.de
- Trim descriptions a little. Update summaries.
2017-07-18 - zaitor@opensuse.org
- Update to version 1.3.2:
+ Use Meson as the only build system.
+ Bugs fixed: bgo#773504, bgo##780550, bgo#769206, bgo#766281,
bgo#758580, bgo#768788, bgo#774688.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
- Add meson BuildRequires and switch autotools macros configure,
make and makeinstall to meson, meson_build and meson_install
following upstream switch to Meson build system.
2017-03-19 - zaitor@opensuse.org
- Update to version 1.2.8:
+ Add missing header in the Meson file listing.
+ Ensure that introspection scans all the headers.
+ build:
- Reduce the internal dependencies.
- Add missing argument to the introspection scanner.
- Ignore 'config.h' when building the API reference.
- Generate the config.h file under json-glib.
- Fix soversion for Meson builds.
- Require the same modules for Meson and Autotools.
- Sync the interface age with the version.
+ Fix the generated pkg-config file with Meson.
+ docs:
- Add links to online resources.
- Reference the JSON-GLib header.
- Override version macros.
- Use 'plain' language for JSON snippets.
- Update the README.
+ Move the reference build down one level.
+ Use the appropriate values to initialize Autotools.
2017-03-13 - dimstar@opensuse.org
- Update to version 1.2.6:
+ Brown paper bag release to re-generate the dist tarball
(bgo#779980).
- Modernize .spec file a bit: use make %{?_smp_mflags} and 'find'
to remove the libtool archives (*.la).

See Also

Package Description
json-glib-lang-1.4.4-80.23.noarch.rpm Translations for package json-glib
json-glib-lang-1.4.4-83.3.noarch.rpm Translations for package json-glib
jsonrpc-glib-devel-3.34.0-22.5.x86_64.rpm Development environment for jsonrpc-glib
jsonrpc-glib-devel-3.34.0-22.9.i586.rpm Development environment for jsonrpc-glib
lasem-0.4.4-24.12.x86_64.rpm MathML and SVG rendering library
lasem-0.4.4-27.1.i586.rpm MathML and SVG rendering library
lasem-devel-0.4.4-24.12.x86_64.rpm Development files for lasem, a MathML and SVG rendering library
lasem-devel-0.4.4-27.1.i586.rpm Development files for lasem, a MathML and SVG rendering library
libIDL-2-0-0.8.14-46.41.x86_64.rpm IDL Parsing Library
libIDL-2-0-0.8.14-46.49.i586.rpm IDL Parsing Library
libIDL-2-0-32bit-0.8.14-46.49.x86_64.rpm IDL Parsing Library
libWPEBackend-fdo-1_0-1-1.4.0-10.4.x86_64.rpm Shared library for wpebackend-fdo
libWPEBackend-fdo-1_0-1-1.4.0-10.9.i586.rpm Shared library for wpebackend-fdo
libWPEBackend-fdo-1_0-1-32bit-1.4.0-10.9.x86_64.rpm Shared library for wpebackend-fdo
libaccountsservice0-0.6.55-154.1.x86_64.rpm Client library for the user account information manipulation D-Bus service
Advertisement
Advertisement