enchant-1-backend-voikko-32bit-1.6.1-18.7.x86_64.rpm


Advertisement

Description

enchant-1-backend-voikko-32bit - Generic Spell Checking Library - Voikko Plugin

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename enchant-1-backend-voikko-32bit-1.6.1-18.7.x86_64.rpm
Package name enchant-1-backend-voikko-32bit
Package version 1.6.1
Package release 18.7
Package architecture x86_64
Package type rpm
Category Productivity/Text/Spell
Homepage https://abiword.github.io/enchant/
License LGPL-2.1-or-later
Maintainer -
Download size 16.49 KB
Installed size 13.38 KB
Voikko plugin (Finnish) for enchant, a library providing an efficient
extensible abstraction for dealing with different spell checking
libraries.

Alternatives

Package Version Architecture Repository
enchant-1-backend-voikko-32bit-1.6.1-26.7.x86_64.rpm 1.6.1 x86_64 GNOME Next
enchant-1-backend-voikko-32bit-1.6.1-5.1.x86_64.rpm 1.6.1 x86_64 openSUSE Oss
enchant-1-backend-voikko-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libenchant.so.1 -
libglib-2.0.so.0 -
libvoikko.so.1 -

Provides

Name Value
enchant-1-backend-voikko-32bit = 1.6.1-18.7
enchant-1-backend-voikko-32bit(x86-32) = 1.6.1-18.7
enchant-backend-voikko-32bit = 1.6.1
enchant-voikko-32bit = 1.6.1
libenchant_voikko.so -

Obsoletes

Name Value
enchant-backend-voikko-32bit < 1.6.1
enchant-voikko-32bit < 1.6.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package enchant-1-backend-voikko-32bit-1.6.1-18.7.x86_64.rpm
Source Package enchant-1-1.6.1-18.7.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install enchant-1-backend-voikko-32bit rpm package:
    # zypper install enchant-1-backend-voikko-32bit

Files

Path
/usr/lib/enchant/libenchant_voikko.so

Changelog

2019-11-19 - Frederic Crozat <fcrozat@suse.com>
- Fix obsoletes/provides in baselibs.conf.
2019-11-05 - Frederic Crozat <fcrozat@suse.com>
- Ensure 32bit enchant-1-backends have proper obsoletes/provides
to upgrade enchant-backends in baselibs.conf.
2019-09-24 - Stefan Dirsch <sndirsch@suse.com>
- Make enchant-1-backend-voikko require enchant-1-backends
(boo#1141993).
2019-07-19 - Antonio Larrosa <alarrosa@suse.com>
- Make libenchant1 recommend enchant-1-backends instead of requiring
any package providing enchant-1-backend. By default, the resolver
pulls in enchant-1-backend-voikko, which is only valid for the fi
locale, so by recommending enchant-1-backends, the resolver now
knows we have a preferred provider for the capability (boo#1141993).
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2017-12-13 - dimstar@opensuse.org
- Update to verssion 1.6.1:
+ This release, the first for several years, is ABI and API
compatible with 1.6.0, but contains a much-upgraded
enchant-ispell front-end, which is now a working ispell
replacement.
+ The code has been cleaned up and some bugs fixed, and the unit
test suite, originally written 10 years ago for Windows, has
been made to run on all platforms.
- Update URL to https://abiword.github.io/enchant/.
- Rename to enchant-1: introduce compatibility package, since
enchant moves to version / API 2.x.
- Adjust packaging to the reworked enchant, following the shared
library packaging policy and allowing for coexistance of
enchant-1 and enchant-2 (as foreseen by upstream):
+ Split enchant-1-data package (providing enchant-data, generic
name) from libenchant1.
+ Split enchant-1-backends from libenchant1: the main backends.
+ Add conflict to libenchant1 < 1.6.1 to the split packages (and
appropriate split provides).
+ Rename enchant-{voikko,zemberek} to
enchant-1-backend-{voikko,zemberek}.
2017-08-11 - pgajdos@suse.com
- aspell to be removed from factory (bsc#1052949, FATE#323578).
2016-05-02 - dimstar@opensuse.org
- Add enchant-hunspell-1.4.0.patch: Fix build against
hunspell 1.4.0, where MAXWORDLEN is no longer exported.
2013-03-26 - mmeister@suse.com
- Added url as source.
Please see http://en.opensuse.org/SourceUrls
2013-03-01 - dimstar@opensuse.org
- Spec-cleanup using format_spec_file service.

See Also

Package Description
enchant-1-backend-zemberek-1.6.1-18.1.x86_64.rpm Generic Spell Checking Library - Zemberek Plugin
enchant-1-backend-zemberek-1.6.1-18.7.i586.rpm Generic Spell Checking Library - Zemberek Plugin
enchant-1-backend-zemberek-32bit-1.6.1-18.7.x86_64.rpm Generic Spell Checking Library - Zemberek Plugin
enchant-1-backends-1.6.1-18.1.x86_64.rpm ISpell/Myspell backends for libenchant
enchant-1-backends-1.6.1-18.7.i586.rpm ISpell/Myspell backends for libenchant
enchant-1-data-1.6.1-18.1.x86_64.rpm Data files for libenchant
enchant-1-data-1.6.1-18.7.i586.rpm Data files for libenchant
enchant-1-devel-1.6.1-18.1.x86_64.rpm Include Files and Libraries mandatory for Development
enchant-1-devel-1.6.1-18.7.i586.rpm Include Files and Libraries mandatory for Development
enchant-1-tools-1.6.1-18.1.x86_64.rpm Generic Spell Checking Library - Command Line Tools
enchant-1-tools-1.6.1-18.7.i586.rpm Generic Spell Checking Library - Command Line Tools
enchant-2-backend-aspell-2.2.5-70.3.x86_64.rpm Aspell backend for the Enchant spell checking library
enchant-2-backend-aspell-2.2.5-70.9.i586.rpm Aspell backend for the Enchant spell checking library
enchant-2-backend-hunspell-2.2.5-70.3.x86_64.rpm Hunspell backend for the Enchant spell checking library
enchant-2-backend-hunspell-2.2.5-70.9.i586.rpm Hunspell backend for the Enchant spell checking library
Advertisement
Advertisement