at-spi2-core-2.34.0-190.11.i586.rpm


Advertisement

Description

at-spi2-core - Assistive Technology Service Provider Interface - D-Bus based implementation

Property Value
Distribution openSUSE Tumbleweed
Repository GNOME Factory x86_64 + i586
Package filename at-spi2-core-2.34.0-190.11.i586.rpm
Package name at-spi2-core
Package version 2.34.0
Package release 190.11
Package architecture i586
Package type rpm
Category System/GUI/GNOME
Homepage https://www.gnome.org/
License LGPL-2.1-or-later
Maintainer -
Download size 56.64 KB
Installed size 132.01 KB
AT-SPI is a general interface for applications to make use of the
accessibility toolkit. This version is based on dbus.
This package contains the AT-SPI registry daemon. It provides a
mechanism for all assistive technologies to discover and interact
with applications running on the desktop.

Alternatives

Package Version Architecture Repository
at-spi2-core-2.34.0-325.11.i586.rpm 2.34.0 i586 GNOME Next
at-spi2-core-2.34.0-325.11.x86_64.rpm 2.34.0 x86_64 GNOME Next
at-spi2-core-2.34.0-190.4.x86_64.rpm 2.34.0 x86_64 GNOME Factory
at-spi2-core-2.34.0-1.1.i586.rpm 2.34.0 i586 openSUSE Oss
at-spi2-core-2.34.0-1.1.x86_64.rpm 2.34.0 x86_64 openSUSE Oss
at-spi2-core - - -

Requires

Name Value
dbus-1 -
libX11.so.6 -
libXtst.so.6 -
libatspi.so.0 -
libc.so.6(GLIBC_2.7) -
libdbus-1.so.3 -
libdbus-1.so.3(LIBDBUS_1_3) -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -

Provides

Name Value
at-spi2-core = 2.34.0-190.11
at-spi2-core(x86-32) = 2.34.0-190.11

Download

Type URL
Mirror widehat.opensuse.org
Binary Package at-spi2-core-2.34.0-190.11.i586.rpm
Source Package at-spi2-core-2.34.0-190.11.src.rpm

Install Howto

  1. Add the GNOME Factory repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/ gnome-factory
  2. Install at-spi2-core rpm package:
    # zypper install at-spi2-core

Files

Path
/etc/xdg/autostart/at-spi-dbus-bus.desktop
/usr/lib/at-spi2/at-spi-bus-launcher
/usr/lib/at-spi2/at-spi2-registryd
/usr/lib/systemd/user/at-spi-dbus-bus.service
/usr/share/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
/usr/share/dbus-1/services/org.a11y.Bus.service
/usr/share/defaults/
/usr/share/defaults/at-spi2/accessibility.conf
/usr/share/licenses/at-spi2-core/COPYING

Changelog

2019-09-09 - mgorse@suse.com
- Update to version 2.34.0:
+ Fix a use after free when freeing an event.
+ Clean up handling of the X11 property specifying the bus
address.
+ Update doap.
2019-09-02 - mgorse@suse.com
- Update to version 2.33.92:
+ Now requires meson 0.50.0.
+ License is now LGPL-2.1+.
+ Meson: only link to libdl when it is necessary.
+ Update installation instructions.
+ Clarify atspi_editable_text_insert_text documentation.
+ Do not warn on no reply from pending get_items call.
+ Eliminate some superfluous runtime warnings.
- Require meson >= 0.50.0.
- Set license to LGPL-2.1-or-later.
2019-08-30 - mgorse@suse.com
- Update to version 2.33.90:
+ Refactor the API for the screen reader to notify listeners
of its status.
+ Add a sender to the AtspiEvent struct.
+ Add missing atspi_application_get_type prototype.
+ Support mutter remote desktop interface for synthesizing
keyboard/mouse events (likely still needs work).
2019-06-25 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.33.2:
+ Check WAYLAND_DISPLAY, rather than XDG_SESSION_TYPE, to avoid X
connections. Fixes breakage if X is started with startx and
XDG_SESSION_TYPE is unset.
+ X11: also try mod4 and mod5 to generate keysyms.
+ Add ATSPI_ROLE_CONTENT_DELETION and
ATSPI_ROLE_CONTENT_INSERTION.
+ Check for dbus-daemon in /usr/lib (for Solaris).
2019-04-10 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.32.1:
+ Fix meson build for meson 0.50.0 and newer.
- Drop at-spi2-core-meson-build-fix.patch: Fixed upstream.
2019-03-12 - mgorse@suse.com
- Add at-spi2-core-meson-build-fix.patch: fix build for meson
0.50.0 (glgo#GNOME/at-spi2-core!9).
2019-03-12 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.32.0:
+ Stable release version bump.
2019-03-04 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 2.31.92:
+ Fix atspi_table_cell_get_(row_column)_headers.
+ Update documentation to indicate that extents are only
meaningful when an object has both STATE_VISIBLE and
STATE_SHOWING.
+ Use a consistent style for the meson options.
+ Fix a compiler warning on BSD.
+ Add ScrollSubstringTo and ScrollSubstringToPoint text
interfaces.
- Enable gtk-docs BuildRequires and update options passed to meson.
- Drop unneeded and unused intltool BuildRequires.
2019-03-04 - bjorn.lie@gmail.com
- Update to version 2.31.2:
+ Add ScrollSubstringTo and ScrollSubstringToPoint text
interfaces.
2019-03-04 - bjorn.lie@gmail.com
- Update to version 2.31.1:
+ Bus launcher: fix an issue where the error wasn't cleared on
failure.
+ Add support for locking/unlocking modifiers.
+ Update error log text for consistency.
+ Documentation clean-ups.
- Drop upstream fixed patches:
+ at-spi2-core-bus-launch-use__linux__.patch.
+ at-spi2-core-generate-pc.patch.

See Also

Package Description
at-spi2-core-devel-2.34.0-190.11.i586.rpm Development files for the Assistive Technology Service Provider Interface
at-spi2-core-devel-2.34.0-190.4.x86_64.rpm Development files for the Assistive Technology Service Provider Interface
at-spi2-core-devel-32bit-2.34.0-190.11.x86_64.rpm Development files for the Assistive Technology Service Provider Interface
at-spi2-core-lang-2.34.0-190.11.noarch.rpm Translations for package at-spi2-core
at-spi2-core-lang-2.34.0-190.4.noarch.rpm Translations for package at-spi2-core
atk-devel-2.34.1-126.10.i586.rpm Development files for the ATK accessibility toolkit
atk-devel-2.34.1-126.4.x86_64.rpm Development files for the ATK accessibility toolkit
atk-devel-32bit-2.34.1-126.10.x86_64.rpm Development files for the ATK accessibility toolkit
atk-doc-2.34.1-126.10.noarch.rpm Additional Package Documentation for atk
atk-doc-2.34.1-126.4.noarch.rpm Additional Package Documentation for atk
atk-lang-2.34.1-126.10.noarch.rpm Translations for package atk
atk-lang-2.34.1-126.4.noarch.rpm Translations for package atk
atkmm-devel-2.29.1-53.4.x86_64.rpm C++ Binding for the ATK library -- Development Files
atkmm-devel-2.29.1-53.9.i586.rpm C++ Binding for the ATK library -- Development Files
atkmm-devel-32bit-2.29.1-53.9.x86_64.rpm C++ Binding for the ATK library -- Development Files
Advertisement
Advertisement