libsfml1_6-1.6-14.9.x86_64.rpm


Advertisement

Description

libsfml1_6 - SFML library

Property Value
Distribution openSUSE Tumbleweed
Repository Games all
Package filename libsfml1_6-1.6-14.9.x86_64.rpm
Package name libsfml1_6
Package version 1.6
Package release 14.9
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.sfml-dev.org/
License Zlib
Maintainer -
Download size 337.27 KB
Installed size 967.59 KB
SFML is a portable and easy to use multimedia API written in C++. You can
see it as a modern, object-oriented alternative to SDL.  SFML is composed of
several packages to perfectly suit your needs.  You can use SFML as a
minimal windowing system to interface with OpenGL, or as a fully-featured
multimedia library for building games or interactive programs.

Alternatives

Package Version Architecture Repository
libsfml1_6-1.6-14.9.i586.rpm 1.6 i586 Games
libsfml1_6 - - -

Requires

Name Value
/sbin/ldconfig -
libGL.so.1()(64bit) -
libGLEW.so.2.1()(64bit) -
libSOIL.so.1()(64bit) -
libX11.so.6()(64bit) -
libXrandr.so.2()(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libfreetype.so.6()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libjpeg.so.8()(64bit) -
libjpeg.so.8(LIBJPEG_8.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libopenal.so.1()(64bit) -
libpng16.so.16()(64bit) -
libpng16.so.16(PNG16_0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libsndfile.so.1()(64bit) -
libsndfile.so.1(libsndfile.so.1.0)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Provides

Name Value
libsfml-audio.so.1.6()(64bit) -
libsfml-graphics.so.1.6()(64bit) -
libsfml-network.so.1.6()(64bit) -
libsfml-system.so.1.6()(64bit) -
libsfml-window.so.1.6()(64bit) -
libsfml1_6 = 1.6-14.9
libsfml1_6(x86-64) = 1.6-14.9

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libsfml1_6-1.6-14.9.x86_64.rpm
Source Package sfml-1.6-14.9.src.rpm

Install Howto

  1. Add the Games repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/games/openSUSE_Tumbleweed/ games
  2. Install libsfml1_6 rpm package:
    # zypper install libsfml1_6

Files

Path
/usr/lib64/libsfml-audio.so.1.6
/usr/lib64/libsfml-graphics.so.1.6
/usr/lib64/libsfml-network.so.1.6
/usr/lib64/libsfml-system.so.1.6
/usr/lib64/libsfml-window.so.1.6

Changelog

2015-10-06 - rpm@fthiessen.de
- Fixed changelog to accomplish openSUSE Factory requirements to
name added patches explicit:
* Added name of patches to changelog comment where possible.
* Created cangelog comment where missing from osc log
2013-04-15 - joop.boonen@opensuse.org
- Added a gcc47 memcpy patch:
* sfml-1.6-gcc47.patch
2012-12-26 - joop.boonen@opensuse.org
- openal-devel is now called openal-soft-devel
2012-12-19 - joop.boonen@opensuse.org
- Cleaned the spec file a bit more up
2012-12-19 - joop.boonen@opensuse.org
- Added BuildRequires: glu-devel as it's not a BuildRequirement
for Mesa-devel anymore for openSUSE > 12.2
- Added libnpng > 14 patch:
* sfml-1.6-png.patch
- Some corrections in the spec file Url license etc
2012-04-19 - reddwarf@opensuse.org
- Add underlinking patch:
* sfml-1.6-underlinking.patch
2012-04-18 - reddwarf@opensuse.org
- Added patch to make it use the system libs:
* sfml-1.6-system_libs.patch
- Added gcc patches:
* sfml-1.6-cflags.patch
* sfml-1.6-gcc.patch
2010-07-12 - uli@suse.de
- initial package, version 1.6.
* sfml-1.6-nochm.patch

See Also

Package Description
libsfml2-2_5-2.5.1-23.8.i586.rpm Free multimedia C++ API
libsfml2-2_5-2.5.1-23.8.x86_64.rpm Free multimedia C++ API
libsfml2-2_5-32bit-2.5.1-23.8.x86_64.rpm Free multimedia C++ API
libshadowdive0_0_0-suse-0.6.5+git.20190205-6.4.i586.rpm A library for reading and writing One Must Fall 2097 datafiles
libshadowdive0_0_0-suse-0.6.5+git.20190205-6.4.x86_64.rpm A library for reading and writing One Must Fall 2097 datafiles
libskstream-0_3-7-0.3.9-1.38.i586.rpm An iostream socket library headers and static libs
libskstream-0_3-7-0.3.9-1.38.x86_64.rpm An iostream socket library headers and static libs
libsolarus1-1.6.0-10.8.i586.rpm Zelda-like game engine
libsolarus1-1.6.0-10.8.x86_64.rpm Zelda-like game engine
libspatialindex4-1.8.5-6.46.i586.rpm A library for spatial indexing
libspatialindex4-1.8.5-6.46.x86_64.rpm A library for spatial indexing
libsquish1-1.10-1.69.i586.rpm Texture compression for NVIDIA cards
libsquish1-1.10-1.69.x86_64.rpm Texture compression for NVIDIA cards
libstorm9-9.22-1.4.i586.rpm StormLib library
libstorm9-9.22-1.4.x86_64.rpm StormLib library
Advertisement
Advertisement