libOpenThreads20-3.4.1-17.2.x86_64.rpm


Advertisement

Description

libOpenThreads20 - Shared libraries for OpenSceneGraph

Property Value
Distribution openSUSE Tumbleweed
Repository Games x86_64 + i586
Package filename libOpenThreads20-3.4.1-17.2.x86_64.rpm
Package name libOpenThreads20
Package version 3.4.1
Package release 17.2
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://openscenegraph.org/projects/osg
License LGPL-2.1-only WITH WxWindows-exception-3.1
Maintainer -
Download size 23.20 KB
Installed size 46.14 KB
The OpenSceneGraph is a graphics toolkit for the development of
graphic applications such as flight simulators, games, virtual
reality and scientific visualization. Based around the concept of a
scene graph, it provides an object-oriented framework on top of
OpenGL.
This package contains the shared libraries for OpenSceneGraph.

Alternatives

Package Version Architecture Repository
libOpenThreads20-3.4.1-17.2.i586.rpm 3.4.1 i586 Games
libOpenThreads20-3.4.1-4.1.i586.rpm 3.4.1 i586 openSUSE Oss
libOpenThreads20-3.4.1-4.1.x86_64.rpm 3.4.1 x86_64 openSUSE Oss
libOpenThreads20 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_3.3.1)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Provides

Name Value
libOpenThreads.so.20()(64bit) -
libOpenThreads20 = 3.4.1-17.2
libOpenThreads20(x86-64) = 3.4.1-17.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libOpenThreads20-3.4.1-17.2.x86_64.rpm
Source Package OpenSceneGraph34-3.4.1-17.2.src.rpm

Install Howto

  1. Add the Games repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/games/openSUSE_Tumbleweed/ games
  2. Install libOpenThreads20 rpm package:
    # zypper install libOpenThreads20

Files

Path
/usr/lib64/libOpenThreads.so.20
/usr/lib64/libOpenThreads.so.3.3.0

Changelog

2020-02-03 - Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Replace wrong Requires: SDL-devel in devel package with
pkgconfig(sdl2).
- Replace PowerPC specific _constraints with ones for all
architectures, there are no differences in real life, avoids
failures for other architectures.
2019-12-10 - Michael Vetter <mvetter@suse.com>
- bsc#1158895: Remove dependency on jasper (due to planned removal)
Removes JPEG2000 support.
2019-09-30 - Michel Normand <normand@linux.vnet.ibm.com>
- Add _constraints for PowerPC to avoid linker failure
2019-07-02 - Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Fix failing builds with CMake 3.14 and later
Add fix_deprecated_FIND_PACKAGE_wxWidgets_usage.patch
2018-07-22 - stefan.bruens@rwth-aachen.de
- Rename devel packages to include the library version, otherwise
these are not visible by the OBS resolver but shadowed by the
highest version.
- Add Conflicts: OpenSceneGraph-examples to examples subpackage
- Add Provides: OpenSceneGraph-plugins to plugins subpackage, to
provide a generic resolvable
- Drop Requires: libOpenThreads-devel in OSG devel subpackage, it
is autoreq'ed via the pkgconfig file.
2018-07-09 - stefan.bruens@rwth-aachen.de
- Add Conflicts: OpenSceneGraph, multiple versions are only
installable for the library subpackages
2018-07-01 - stefan.bruens@rwth-aachen.de
- Create OpenSceneGraph34 package from OpenSceneGraph packge. OSG
changes API and ABI between minor versions. While this is already
covered for the built libraries, the devel package has been
available only for the latest version.
2018-02-14 - mimi.vx@gmail.com
- update to 3.4.1
* Improves to GLES support across platforms
* Full support for osgText and on screen stats across all platfroms
* Build fixes to allow compilation against recent
3rd party depdendency changes
* Range of runtime fixes
2017-12-15 - crrodriguez@opensuse.org
- Switch to QT5, as QT4 is dead.
- Remove manual requires on -devel package.
2017-08-19 - stefan.bruens@rwth-aachen.de
- Add 8e26ebd23ef9_Fixed_coverity_detected_defect_OOB_read.patch
Fix out-of-bound-read, also required for the next patch to apply
- Add 01c712e85195_Explicit_signed_char_declarations.patch
Fix compilation on architectures where char is unsigned

See Also

Package Description
libOpenThreads20-devel-3.4.1-17.2.i586.rpm OpenSceneGraph development files
libOpenThreads20-devel-3.4.1-17.2.x86_64.rpm OpenSceneGraph development files
libOpenThreads21-3.6.3-48.2.i586.rpm Shared libraries for OpenSceneGraph
libOpenThreads21-3.6.3-48.2.x86_64.rpm Shared libraries for OpenSceneGraph
libPocoCppParser63-1.9.3-8.2.i586.rpm C++ Framework for Network-based Applications
libPocoCppParser63-1.9.3-8.2.x86_64.rpm C++ Framework for Network-based Applications
libPocoCrypto63-1.9.3-8.2.i586.rpm C++ Framework for Network-based Applications
libPocoCrypto63-1.9.3-8.2.x86_64.rpm C++ Framework for Network-based Applications
libPocoData63-1.9.3-8.2.i586.rpm C++ Framework for Network-based Applications
libPocoData63-1.9.3-8.2.x86_64.rpm C++ Framework for Network-based Applications
libPocoDataMySQL63-1.9.3-8.2.i586.rpm C++ Framework for Network-based Applications
libPocoDataMySQL63-1.9.3-8.2.x86_64.rpm C++ Framework for Network-based Applications
libPocoDataODBC63-1.9.3-8.2.i586.rpm C++ Framework for Network-based Applications
libPocoDataODBC63-1.9.3-8.2.x86_64.rpm C++ Framework for Network-based Applications
libPocoDataSQLite63-1.9.3-8.2.i586.rpm C++ Framework for Network-based Applications
Advertisement
Advertisement