pspp-devel-1.2.0-4.5.x86_64.rpm


Advertisement

Description

pspp-devel - Development files for pspp, a statistical analysis program

Property Value
Distribution openSUSE Tumbleweed
Repository Education all
Package filename pspp-devel-1.2.0-4.5.x86_64.rpm
Package name pspp-devel
Package version 1.2.0
Package release 4.5
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.gnu.org/software/pspp/
License LGPL-2.1+
Maintainer -
Download size 15.13 KB
Installed size 1.95 KB
PSPP is a program for statistical analysis of sampled data. It
is a free replacement for the proprietary program SPSS.
This subpackage contains libraries and header files for developing
applications that want to build pspp plugins.

Alternatives

Package Version Architecture Repository
pspp-devel-1.2.0-4.5.i586.rpm 1.2.0 i586 Education
pspp-devel-1.2.0-3.1.x86_64.rpm 1.2.0 x86_64 openSUSE Oss
pspp-devel-1.2.0-3.1.i586.rpm 1.2.0 i586 openSUSE Oss
pspp-devel - - -

Requires

Name Value
glibc-devel -
gsl-devel -
libxml2-devel -
postgresql-devel -
zlib-devel -

Provides

Name Value
libtool(/usr/lib64/pspp/libpspp-core.la) -
libtool(/usr/lib64/pspp/libpspp.la) -
pspp-devel = 1.2.0-4.5
pspp-devel(x86-64) = 1.2.0-4.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package pspp-devel-1.2.0-4.5.x86_64.rpm
Source Package pspp-1.2.0-4.5.src.rpm

Install Howto

  1. Add the Education repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/Education/openSUSE_Tumbleweed/ education
  2. Install pspp-devel rpm package:
    # zypper install pspp-devel

Files

Path
/usr/lib64/pspp/libpspp-core.la
/usr/lib64/pspp/libpspp.la

Changelog

2019-02-28 - opensuse.lietuviu.kalba@gmail.com
- Add upstream patch CVE-2019-9211.patch to fix CVE-2019-9211
(boo#1127343).
2019-02-06 - Jan Engelhardt <jengelh@inai.de>
- Remove excessive -n argument to %build, and excessive %defattr
lines.
2019-01-04 - Jan Engelhardt <jengelh@inai.de>
- Drop useless AutoReqProv: on.
2019-01-03 - opensuse.lietuviu.kalba@gmail.com
- Add upstream patch CVE-2018-20230.patch to fix CVE-2018-20230
(bnc#1120061).
- Add upstream patch avoid_old_Texinfo_4.13.patch to avoid
compiling with old Texinfo 4.13.
2018-11-10 - astieger@suse.com
- pspp 1.2.0:
* New experimental command SAVE DATA COLLECTION to save MDD files
* MTIME and YMDHMS variable formats now supported.
* Spread sheet rendering now done via spread-sheet-widget
2018-11-10 - astieger@suse.com
- add upstream signing key and verify source signature
2017-09-11 - jengelh@inai.de
- Update boilerplate descriptions. Replace $RPM_ shell variables
by macros. Unify mix of different CFLAGS.
2017-09-05 - opensuse.lietuviu.kalba@gmail.com
- Removing ncurses dependency, because since 0.11.0 version,
the ncurses library is no longer required or used.
2017-08-29 - opensuse.lietuviu.kalba@gmail.com
- Update to 1.0.1 version:
* Bug fixes, including fixes for CVE-2017-12958 (bnc#1054585),
CVE-2017-12959 (bnc#1054588), CVE-2017-12960 (bnc#1054587), and
CVE-2017-12961 (bnc#1054586).
* Translation updates.
2017-08-13 - opensuse.lietuviu.kalba@gmail.com
- Update to 0.11.0 version:
* The REGRESSION command now has a /ORIGIN subcommand to perform
regression through the origin.
* The FACTOR command can now analyse matrix files prepared with MATRIX DATA.
* The FACTOR command can now print the anti-image matrices.
* The MATRIX DATA command has been added.
* Some inappropriate properties in selection dialogs have been corrected.
* A bug which could cause the HTML driver to go into a tight loop
has been fixed.
* An error in the FREQUENCIES procedure, where the word "Mean" was
printed when "Variance" was appropriate has been fixed.
* The ncurses library is no longer required or used.
* A bug where the Mann-Whitney test would give misleading results
if run on multiple variables and MISSING=ANALAYSIS was specified
has been fixed.
* Gtk+3.14.5 or later must now be used when building.
* Graphical user interface changes:
* There is a new menu: Edit|Options
* The Non Parametric Statistics Menu has a new item: "K Independent Samples".
* Dialog boxes can now be canceled using the <Escape> key.
* The AUTORECODE command now accepts an optional / before INTO.
* The short form of the VECTOR command can now create string variables.
* Bug fixes, including fixes for CVE-2017-10791 and CVE-2017-10792.
- Drop pspp-0001-sys-file-reader-Avoid-null-dereference-skipping-bad-.patch:
Fix for CVE-2017-10792 included in PSPP 0.11.0 version upstream.
- Drop pspp-0002-sys-file-reader-Fix-integer-overflows-in-parse_long_.patch:
Fix for CVE-2017-10791 included in PSPP 0.11.0 version upstream.

See Also

Package Description
pysycache-3.1.01-19.135.i586.rpm Educational point-and-click software for young children
pysycache-3.1.01-19.135.x86_64.rpm Educational point-and-click software for young children
pysycache-cartoons-3.0-2.26.noarch.rpm Add on for the "Drag and drop" activity
pysycache-lang-3.0-2.95.noarch.rpm Language packages for PySyCache
pysycache-lang-da-3.0-2.95.noarch.rpm Danish language pack for PySyCache
pysycache-lang-de-3.0-2.95.noarch.rpm German language pack for PySyCache
pysycache-lang-en-3.0-2.95.noarch.rpm English language pack for PySyCache
pysycache-lang-es-3.0-2.95.noarch.rpm Estonian language pack for PySyCache
pysycache-lang-fi-3.0-2.95.noarch.rpm Finish language pack for PySyCache
pysycache-lang-fr-3.0-2.95.noarch.rpm French language pack for PySyCache
pysycache-lang-it-3.0-2.95.noarch.rpm Italian language pack for PySyCache
pysycache-lang-nl-3.0-2.95.noarch.rpm Netherlands language pack for PySyCache
pysycache-lang-pt-3.0-2.95.noarch.rpm Portugese language pack for PySyCache
pysycache-photographies-3.0-1.26.noarch.rpm Add on for the "Drag and drop" activity
pysycache-themes-click-3.0-1.16.noarch.rpm Additional themes for the Click activity
Advertisement
Advertisement