libmaa4-1.4.4-8.1.x86_64.rpm


Advertisement

Description

libmaa4 - Library providing many low-level data structures

Property Value
Distribution openSUSE Tumbleweed
Repository Education all
Package filename libmaa4-1.4.4-8.1.x86_64.rpm
Package name libmaa4
Package version 1.4.4
Package release 8.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.dict.org
License MIT
Maintainer -
Download size 40.61 KB
Installed size 98.68 KB
The libmaa library provides many low-level data structures which can
be used for writing compilers, hash tables, sets, lists,
debugging support, and memory management. libmaa was originally
implemented as a foundation for the "kheperalong" package.

Alternatives

Package Version Architecture Repository
libmaa4-1.4.4-8.1.i586.rpm 1.4.4 i586 Education
libmaa4-1.4.4-1.1.x86_64.rpm 1.4.4 x86_64 openSUSE Oss
libmaa4-1.4.4-1.1.i586.rpm 1.4.4 i586 openSUSE Oss
libmaa4 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.15)(64bit) -

Provides

Name Value
libmaa.so.4()(64bit) -
libmaa4 = 1.4.4-8.1
libmaa4(x86-64) = 1.4.4-8.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libmaa4-1.4.4-8.1.x86_64.rpm
Source Package libmaa-1.4.4-8.1.src.rpm

Install Howto

  1. Add the Education repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/Education/openSUSE_Tumbleweed/ education
  2. Install libmaa4 rpm package:
    # zypper install libmaa4

Files

Path
/usr/lib64/libmaa.so.4
/usr/lib64/libmaa.so.4.0
/usr/share/doc/packages/libmaa4/NEWS
/usr/share/doc/packages/libmaa4/README
/usr/share/licenses/libmaa4/LICENSE

Changelog

2019-04-23 - vle@gmx.net
- Update to libmaa-1.4.4:
* Fix compilation failure using gcc-8
- Simplify build process using capabilities of mk-configure
- Remove patches already applied in upstream, specifically
- 02-Spelling-typos.patch
- 03-Fix-gcc-8-ftbfs.patch
- Fix License in rpm spec
- Remove unnecessary dependencies from rpm spec
2019-03-08 - Matej Cepl <mcepl@suse.com>
- Update to 1.4.3:
- Fix parallel build
- Explicitely enable WARNERR and remove gcc-ism from CFLAGS
2019-01-28 - Jan Engelhardt <jengelh@inai.de>
- Trim filler wording from descriptions. Set proper RPM groups,
and noarch status for doc subpackage.
- Drop silly glibc PreReq.
2019-01-26 - mcepl@suse.com
- Upgrade to libmaa-1.4.2:
* Fix build failure on SunOS-5.11 (alloca)
* License has been changed from LGPL to MIT, permitted by Rik
Faith, original author of this library.
* Build system changed from autotools to mk-configure.
* Library version/soname was bumped from 3 to 4. I cannot
guarantee that mk-configure and libtool build shared library
the same way.
* Tests were added for stk_*, mem_* and prm_* functions.
* stk_isempty function was added.
* stk_* and other was reimplemented without obstack functions
(glibc extension).
2018-10-09 - mcepl@suse.com
- Add 02-Spelling-typos.patch and 03-Fix-gcc-8-ftbfs.patch from Debian
package.
2011-11-27 - brunciter@localhost.lan
- initial package

See Also

Package Description
libmarsyas0-0.4.8-1.233.i586.rpm Library for marsyas
libmarsyas0-0.4.8-1.233.x86_64.rpm Library for marsyas
libmongoose-doc-5.4.0-52.1.i586.rpm Documentation for libmongoose
libmongoose-doc-5.4.0-52.1.x86_64.rpm Documentation for libmongoose
libmongoose2-2.0.3-52.1.i586.rpm Graph partitioning library
libmongoose2-2.0.3-52.1.x86_64.rpm Graph partitioning library
libmopac7-1-1.15-19.1.i586.rpm Dynamic libraries from mopac7
libmopac7-1-1.15-19.1.x86_64.rpm Dynamic libraries from mopac7
libmopac7-1-devel-1.15-19.1.i586.rpm Header files and static libraries from mopac7
libmopac7-1-devel-1.15-19.1.x86_64.rpm Header files and static libraries from mopac7
libmuparser2_2_6-2.2.6.1-28.7.i586.rpm Library to evaluate strings as mathematical functions
libmuparser2_2_6-2.2.6.1-28.7.x86_64.rpm Library to evaluate strings as mathematical functions
libmuparser2_2_6-32bit-2.2.6.1-28.7.x86_64.rpm Library to evaluate strings as mathematical functions
libmyFitter0-0.2-2.57.i586.rpm A C++ class library for maximum likelihood fits
libmyFitter0-0.2-2.57.x86_64.rpm A C++ class library for maximum likelihood fits
Advertisement
Advertisement