libcaca0-0.99.16-5.14.x86_64.rpm


Advertisement

Description

libcaca0 - Text mode graphics library

Property Value
Distribution openSUSE Tumbleweed
Repository Education all
Package name libcaca0
Package version 0.99.16
Package release 5.14
Package architecture x86_64
Package type rpm
Installed size 1023.82 KB
Download size 242.72 KB
Official Mirror widehat.opensuse.org
libcaca is a graphics library that outputs text instead of pixels, so that it
can work on older video cards or text terminals. It is not unlike the famous
AAlib library, with the following improvements:
* Unicode support
* 2048 available colours (some devices can only handle 16)
* dithering of colour images
* advanced text canvas operations (blitting, rotations)
Authors:
--------
Sam Hocevar
Jean-Yves Lamoureux

Alternatives

Package Version Architecture Repository
libcaca0-0.99.16-5.14.i586.rpm 0.99.16 i586 Education
libcaca0-0.99.beta19.git20171003-63.12.x86_64.rpm 0.99.beta19.git20171003 x86_64 Multimedia Libs
libcaca0-0.99.beta19.git20171003-63.12.i586.rpm 0.99.beta19.git20171003 i586 Multimedia Libs
libcaca0-0.99.beta19.git20171003-1.1.x86_64.rpm 0.99.beta19.git20171003 x86_64 openSUSE Oss
libcaca0-0.99.beta19.git20171003-1.1.i586.rpm 0.99.beta19.git20171003 i586 openSUSE Oss
libcaca0 - - -

Requires

Name Value
/sbin/ldconfig -
libX11.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libncursesw.so.5()(64bit) -
libslang.so.2()(64bit) -
libslang.so.2(SLANG2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libz.so.1()(64bit) -
xorg-x11-libs -

Provides

Name Value
libcaca++.so.0()(64bit) -
libcaca.so.0()(64bit) -
libcaca0 = 0.99.16-5.14
libcaca0(x86-64) = 0.99.16-5.14

Download

Type URL
Binary Package libcaca0-0.99.16-5.14.x86_64.rpm
Source Package libcaca0-0.99.16-5.14.src.rpm

Install Howto

  1. Add the Education repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/Education/openSUSE_Tumbleweed/ education
  2. Install libcaca0 rpm package:
    # zypper install libcaca0

Files

Path
/usr/lib64/libcaca++.so.0
/usr/lib64/libcaca++.so.0.99.16
/usr/lib64/libcaca.so.0
/usr/lib64/libcaca.so.0.99.16
/usr/lib64/libcucul++.so.0
/usr/lib64/libcucul++.so.0.99.16
/usr/lib64/libcucul.so.0
/usr/lib64/libcucul.so.0.99.16

Changelog

2008-12-30 - lars@linux-schulserver.de
- build for openSUSE-Education (flexdoc -> scilab dependeny)
- own %{_datadir}/libcaca
2008-10-18 - Manfred.Tremmel <Manfred.Tremmel@iiv.de>
- update to 0.99beta16
2008-10-02 - Manfred.Tremmel <Manfred.Tremmel@iiv.de>
- downgrade to 0.99beta14, to much problems with beta15
2008-09-30 - Manfred.Tremmel <Manfred.Tremmel@iiv.de>
- sorry, another fix provides/links
2008-09-29 - Manfred.Tremmel <Manfred.Tremmel@iiv.de>
- included some provides entries for compatibility reasons
2008-09-28 - Manfred.Tremmel <Manfred.Tremmel@iiv.de>
- update to 0.99beta15
2008-07-06 - Manfred.Tremmel <Manfred.Tremmel@iiv.de>
- update to 0.99beta14
2007-11-29 - Manfred.Tremmel <Manfred.Tremmel@iiv.de>
- update to 0.99beta13
2007-10-01 - Manfred.Tremmel <Manfred.Tremmel@iiv.de>
- update to 0.99beta12
2006-11-20 - Manfred.Tremmel <Manfred.Tremmel@iiv.de>
- update to 0.99beta11

See Also

Package Description
libcaca0-ruby-0.99.16-5.14.i586.rpm Ruby bindings package for libcaca
libcaca0-ruby-0.99.16-5.14.x86_64.rpm Ruby bindings package for libcaca
libcamd2-2.4.6-45.1.i586.rpm Symmetric Approximate Minimum Degree
libcamd2-2.4.6-45.1.x86_64.rpm Symmetric Approximate Minimum Degree
libccolamd2-2.9.6-45.1.i586.rpm Constrained Column Approximate Minimum Degree
libccolamd2-2.9.6-45.1.x86_64.rpm Constrained Column Approximate Minimum Degree
libcholmod3-3.0.12-45.1.i586.rpm Supernodal Sparse Cholesky Factorization and Update/Downdate
libcholmod3-3.0.12-45.1.x86_64.rpm Supernodal Sparse Cholesky Factorization and Update/Downdate
libclips2-6.30.0-3.22.i586.rpm Run-time C libraries for CLIPS applications
libclips2-6.30.0-3.22.x86_64.rpm Run-time C libraries for CLIPS applications
libcnc-1.0.100-23.44.i586.rpm Libraries for Intel Concurrent Collections for C++
libcnc-1.0.100-23.44.x86_64.rpm Libraries for Intel Concurrent Collections for C++
libcolamd2-2.9.6-45.1.i586.rpm Column Approximate Minimum Degree
libcolamd2-2.9.6-45.1.x86_64.rpm Column Approximate Minimum Degree
libcpuid-devel-0.3.0-1.42.i586.rpm Development files for libcpuid
Advertisement
Advertisement