php5-geoip-1.1.0-3.1.x86_64.rpm


Advertisement

Description

php5-geoip - PHP module for MaxMind GeoIP libraries

Property Value
Distribution openSUSE Leap 42.3
Repository PHP Extensions all
Package name php5-geoip
Package version 1.1.0
Package release 3.1
Package architecture x86_64
Package type rpm
Installed size 32.25 KB
Download size 13.16 KB
Official Mirror widehat.opensuse.org
This PHP extension allows you to find the location of an IP address - City, State,
Country, Longitude, Latitude, and other information as all, such as ISP and connection type.
For more info, please visit Maxmind's website.

Alternatives

Package Version Architecture Repository
php5-geoip - - -

Requires

Name Value
libGeoIP.so.1()(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
php(api) = 20121113
php(zend-abi) = 20121212

Provides

Name Value
config(php5-geoip) = 1.1.0-3.1
geoip.so()(64bit) -
php-geoip = 1.1.0
php5-geoip = 1.1.0-3.1
php5-geoip(x86-64) = 1.1.0-3.1

Obsoletes

Name Value
php-geoip < 1.1.0

Download

Type URL
Binary Package php5-geoip-1.1.0-3.1.x86_64.rpm
Source Package php5-geoip-1.1.0-3.1.src.rpm

Install Howto

  1. Add the PHP Extensions repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/server:/php:/extensions/openSUSE_Leap_42.3/ php-extensions
  2. Install php5-geoip rpm package:
    # zypper install php5-geoip

Files

Path
/etc/php5/conf.d/geoip.ini
/usr/lib64/php5/extensions/geoip.so
/usr/share/doc/packages/php5-geoip/ChangeLog
/usr/share/doc/packages/php5-geoip/README

Changelog

2016-01-29 - pgajdos@suse.com
- provides php-geoip symbol
2016-01-12 - pgajdos@suse.com
- call spec-cleaner
2015-05-28 - crrodriguez@opensuse.org
- Update to version 1.0.1
2011-10-29 - crrodriguez@opensuse.org
- Update to version 1.0.8
2011-06-05 - crrodriguez@opensuse.org
- Add missing module deps
2010-04-04 - crrodriguez@opensuse.org
- updat to version 1.0.7
2009-08-16 - crrodriguez@suse.de
- use API versioning macros
2009-01-20 - crrodriguez@suse.de
- version 1.0.6
2008-12-22 - crrodriguez@suse.de
- update to version 1.0.5
* * Small bug in phpinfo() when printing version number could crash PHP.
2008-06-13 - crrodriguez@suse.de
- update to version 1.0.3
* Change license from PHP 3.0 to PHP 3.01 for Debian?
* Added geoip_continent_code_by_name() to get continent instead of country
* Fixing a small casting issue (compiler warning)
* Fixing missing entries in geoip_record_by_name(), bug #14131

See Also

Package Description
php5-gnupg-1.3.6-2.1.x86_64.rpm PHP wrapper around the gpgme library
php5-gtk-2.0.1-2.1.x86_64.rpm PHP bindings for GTK2
php5-gtk-devel-2.0.1-2.1.x86_64.rpm PHP bindings for GTK2
php5-haru-1.0.4-2.1.x86_64.rpm Create PDF Documents Using the Haru Free PDF Library
php5-igbinary-1.2.1-2.1.x86_64.rpm Replacement for the Standard PHP Serializer
php5-imagick-3.4.1-1.1.x86_64.rpm Wrapper to the ImageMagick/GraphicsMagick library
php5-imagick-devel-3.4.1-1.1.x86_64.rpm Header files for imagick development
php5-inotify-0.1.6-3.1.x86_64.rpm The inotify extension allows to use inotify functions in a PHP script.
php5-lzf-1.6.3-2.1.x86_64.rpm PHP LZF de/compression extension
php5-mailparse-2.1.6-4.1.x86_64.rpm Email Message Manipulation
php5-memcache-3.0.8-13.1.x86_64.rpm PHP Memcache client Extension
php5-memcached-2.2.0-5.1.x86_64.rpm PHP MemcacheD client Extension
php5-mogilefs-0.9.2-2.1.x86_64.rpm PHP client library to communicate with the MogileFS storage
php5-oauth-1.2.3-4.1.x86_64.rpm oauth Consumer Extension
php5-pam-1.0.3-2.1.x86_64.rpm PHP PAM integration
Advertisement
Advertisement