stockfish17-1.7.1-3.2.x86_64.rpm


Advertisement

Description

stockfish17 - A very strong, UCI compatible Chess engine

Property Value
Distribution openSUSE Leap 42.3
Repository Packman all
Package name stockfish17
Package version 1.7.1
Package release 3.2
Package architecture x86_64
Package type rpm
Installed size 6.88 MB
Download size 3.25 MB
Official Mirror packman.inode.at
Stockfish is a free UCI chess engine derived from Glaurung 2.1. It is
not a complete chess program, but requires some UCI compatible GUI
(like XBoard with PolyGlot, eboard, José, Arena, Sigma Chess, Shredder,
Chess Partner, or Fritz) in order to be used comfortably.  Read the
documentation for your GUI of choice for information about how to use
Stockfish with your GUI.
This version of Stockfish supports up to 8 CPUs, but has not been
tested thoroughly with more than 2.  The program tries to detect the
number of CPUs on your computer and set the number of search threads
accordingly, but please be aware that the detection is not always
correct.  It is therefore recommended to inspect the value of the
"Threads" UCI parameter, and to make sure it equals the number of CPU
cores on your computer. If you are using more than four threads, it
is recommended to raise the value of "Minimum Split Depth" UCI parameter
to 6.
Authors:
--------
Marco Costalba mcostalba@gmail.com
Salvo Spitaleri (opening book "Book.bin")

Alternatives

Package Version Architecture Repository
stockfish17 - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Provides

Name Value
stockfish17 = 1.7.1-3.2
stockfish17(x86-64) = 1.7.1-3.2

Download

Type URL
Binary Package stockfish17-1.7.1-3.2.x86_64.rpm
Source Package stockfish17-1.7.1-3.2.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_42.3/ packman
  2. Install stockfish17 rpm package:
    # zypper install stockfish17

Files

Path
/usr/bin/stockfish17
/usr/bin/stockfish17-polyglot
/usr/bin/stockfish17.bin
/usr/bin/xstockfish17
/usr/share/doc/packages/stockfish17/COPYING
/usr/share/doc/packages/stockfish17/Readme.txt
/usr/share/stockfish17/Book.bin
/usr/share/stockfish17/stockfish17.ini
/usr/share/stockfish17/stockfish_100x50.gif
/usr/share/stockfish17/stockfish_130x65.gif

Changelog

2010-04-11 - packman@links2linux.de - 1.7.1
- updated to 1.7.1 (bugfix release)
* removed new and broken Hyper Threading detection code
and fall back to well known 1.6.3 behaviour
* worked around issue in zugzwang positions where 1.7.0 failed to
detect zugzwang. To avoid  breaking compatibility with 1.7.0
issue was NOT fixed by default, but an UCI parameter called
"Zugzwang detection" that is OFF by default was added
- added "Zugzwang detection = true" to polyglot ini-file
2010-04-08 - packman@links2linux.de - 1.7.0
- initial build, version 1.7.0

See Also

Package Description
stockfish18-1.8.0-3.2.x86_64.rpm A very strong, UCI compatible Chess engine
stockfish19-1.9.1-3.2.x86_64.rpm A very strong, UCI compatible Chess engine
stockfish20-2.0.1-3.2.x86_64.rpm A very strong, UCI compatible Chess engine
streamripper-1.64.6-2.2.aarch64.rpm Record shoutcast compatible streams
streamripper-1.64.6-2.2.armv7hl.rpm Record shoutcast compatible streams
streamripper-1.64.6-2.2.x86_64.rpm Record shoutcast compatible streams
streamtuner2-2.2.0-7.3.noarch.rpm GUI Interface for Internet Radio Directories
streamtuner2-2.2.0-7.4.noarch.rpm GUI Interface for Internet Radio Directories
subtitleripper-0.3.4-4.2.aarch64.rpm Tools to extract DVD-subtitles
subtitleripper-0.3.4-4.2.armv7hl.rpm Tools to extract DVD-subtitles
subtitleripper-0.3.4-4.2.x86_64.rpm Tools to extract DVD-subtitles
sview-17.04-2.3.x86_64.rpm Stereoscopic media player
sweep-0.9.3-5.5.x86_64.rpm Sound wave editor
sweep-0.9.3-5.7.aarch64.rpm Sound wave editor
sweep-0.9.3-5.7.armv7hl.rpm Sound wave editor
Advertisement
Advertisement