js-1.8.5-19.4.6.aarch64.rpm


Advertisement

Description

js - JavaScript interpreter

Property Value
Distribution openSUSE Leap 42.3
Repository Packman all
Package name js
Package version 1.8.5
Package release 19.4.6
Package architecture aarch64
Package type rpm
Installed size 1.86 MB
Download size 574.31 KB
Official Mirror packman.inode.at
JavaScript is the Netscape-developed object scripting language used in millions
of web pages and server applications worldwide. Netscape's JavaScript is a
superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
with only mild differences from the published standard.

Alternatives

Package Version Architecture Repository
js-1.8.5-19.4.9.x86_64.rpm 1.8.5 x86_64 Packman
js-1.8.5-19.4.6.armv7hl.rpm 1.8.5 armv7hl Packman
js - - -

Requires

Name Value
ld-linux-aarch64.so.1()(64bit) -
ld-linux-aarch64.so.1(GLIBC_2.17)(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libdl.so.2()(64bit) -
libgcc_s.so.1()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.17)(64bit) -
libnspr4.so()(64bit) -
libplc4.so()(64bit) -
libplds4.so()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.17)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
js = 1.8.5-19.4.6
js(aarch-64) = 1.8.5-19.4.6

Download

Type URL
Binary Package js-1.8.5-19.4.6.aarch64.rpm
Source Package js-1.8.5-19.4.6.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_42.3/ packman
  2. Install js rpm package:
    # zypper install js

Files

Path
/usr/bin/js
/usr/share/doc/packages/js/README.html

Changelog

2013-12-15 - uweigand@de.ibm.com
- ppc64le-support.patch: Add support for powerpc64le.
- js-filter.patch: don't try to use the JIT on powerpc64le
2013-08-12 - schwab@suse.de
- js-filter.patch: don't try to use the JIT on aarch64
2013-03-21 - dmueller@suse.com
- fix build on SLE11 (work around SLE's configure macro)
- add missing dependency to devel package
2012-06-28 - adrian@suse.de
- do not enforce wrong build flags on arm (fixes build)
2011-11-10 - dvaleev@suse.com
- fix ppc64 build
2011-06-17 - wr@rosenauer.org
- create package by using "make install"
- use upstream pkg-config file (libjs -> mozjs185)
- avoid __DATE__ and __TIME__ in binaries
2011-06-17 - vuntz@opensuse.org
- Pass --enable-threadsafe to configure, as gjs relies on this.
2011-04-19 - wr@rosenauer.org
- initial openSUSE package

See Also

Package Description
js-devel-1.8.5-19.4.6.aarch64.rpm Header files, libraries and development documentation for js
js-devel-1.8.5-19.4.6.armv7hl.rpm Header files, libraries and development documentation for js
js-devel-1.8.5-19.4.9.x86_64.rpm Header files, libraries and development documentation for js
k3b-18.08.1-10.1.aarch64.rpm CD/DVD/Blu-ray Burning Application for KDE
k3b-18.08.1-10.1.armv7hl.rpm CD/DVD/Blu-ray Burning Application for KDE
k3b-18.08.1-10.1.x86_64.rpm CD/DVD/Blu-ray Burning Application for KDE
k3b-devel-18.08.1-10.1.aarch64.rpm Development files for k3b
k3b-devel-18.08.1-10.1.armv7hl.rpm Development files for k3b
k3b-devel-18.08.1-10.1.x86_64.rpm Development files for k3b
k3b-lang-18.08.1-10.1.noarch.rpm Languages for package k3b
k9copy-3.0.3-11.2.aarch64.rpm DVD backup utility
k9copy-3.0.3-11.2.armv7hl.rpm DVD backup utility
k9copy-3.0.3-11.4.x86_64.rpm DVD backup utility
k9copy-lang-3.0.3-11.2.noarch.rpm Languages for package k9copy
k9copy-lang-3.0.3-11.4.noarch.rpm Languages for package k9copy
Advertisement
Advertisement