glaurung121-1.2.1-2.2.x86_64.rpm


Advertisement

Description

glaurung121 - A very strong, UCI compatible Chess engine

Property Value
Distribution openSUSE Leap 42.3
Repository Packman all
Package name glaurung121
Package version 1.2.1
Package release 2.2
Package architecture x86_64
Package type rpm
Installed size 7.47 MB
Download size 2.96 MB
Official Mirror packman.inode.at
This is the previous stable version of glaurung and also a very strong chess engine.
Glaurung 1.2.1 is probably slightly weaker than glaurung 2, but has a much more entertaining style of play.
It uses the UCI (universal chess interface), for chess engines as communication protocol.
This means to play against it, you have to use an UCI capable interface,
like knights or an xboard adapter like polyglot.
glaurung can be found at:
http://www.glaurungchess.com/
Authors:
--------
Tord Romstad <tord@glaurungchess.com>

Alternatives

Package Version Architecture Repository
glaurung121 - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -

Provides

Name Value
glaurung121 = 1.2.1-2.2
glaurung121(x86-64) = 1.2.1-2.2

Download

Type URL
Binary Package glaurung121-1.2.1-2.2.x86_64.rpm
Source Package glaurung121-1.2.1-2.2.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_42.3/ packman
  2. Install glaurung121 rpm package:
    # zypper install glaurung121

Files

Path
/usr/bin/glaurung121
/usr/bin/glaurung121-polyglot
/usr/bin/glaurung121.bin
/usr/bin/xglaurung121
/usr/share/doc/packages/glaurung121/Copying.txt
/usr/share/doc/packages/glaurung121/Readme.txt
/usr/share/glaurung121/book.bin
/usr/share/glaurung121/glaurung121.ini
/usr/share/glaurung121/kpk.bin

Changelog

2009-08-31 - AxelKoellhofer@web.de
- added a polyglot startup script (i.e. for use with xboard)
simply typing "xboard -fcp glaurung121-polyglot" (engine = white) 
or "xboard -scp glaurung121-polyglot" (engine = black) will work
2009-08-27 - AxelKoellhofer@web.de
- modified startup
The two scripts /usr/bin/glaurung121 and /usr/bin/xglaurung121
both check if there is a $HOME/.glaurung121 directory
containing an opening book and a polyglot ini-file;
if not, the files are copied from /usr/share/glaurung121.
In this way every user can run a "personalized" configuration
as all of the configuration stuff is handled within $HOME.
2009-08-26 - AxelKoellhofer@web.de
- fixed wrong error message in xboard-script if polyglot is not installed
2009-08-24 - AxelKoellhofer@web.de
- first build for openSUSE, version 1.2.1

See Also

Package Description
glaurung22-2.2-4.2.x86_64.rpm A very strong, UCI compatible Chess engine
gmerlin-1.2.0rsvn4256-3.6.aarch64.rpm Multimedia architecture for Linux
gmerlin-1.2.0rsvn4256-3.6.armv7hl.rpm Multimedia architecture for Linux
gmerlin-1.2.0rsvn4256-3.7.x86_64.rpm Multimedia architecture for Linux
gmerlin-alsamixer-1.2.0rsvn4256-3.6.aarch64.rpm Alsa mixer
gmerlin-alsamixer-1.2.0rsvn4256-3.6.armv7hl.rpm Alsa mixer
gmerlin-alsamixer-1.2.0rsvn4256-3.7.x86_64.rpm Alsa mixer
gmerlin-avdecoder-1.2.0rsvn4256-2.10.x86_64.rpm Gmerlin A/V decoder library
gmerlin-avdecoder-1.2.0rsvn4256-2.17.aarch64.rpm Gmerlin A/V decoder library
gmerlin-avdecoder-1.2.0rsvn4256-2.17.armv7hl.rpm Gmerlin A/V decoder library
gmerlin-avdecoder-lang-1.2.0rsvn4256-2.10.noarch.rpm Languages for package gmerlin-avdecoder
gmerlin-avdecoder-lang-1.2.0rsvn4256-2.17.noarch.rpm Languages for package gmerlin-avdecoder
gmerlin-avdecoder-plugins-1.2.0rsvn4256-2.10.x86_64.rpm Plugins for gmerlin
gmerlin-avdecoder-plugins-1.2.0rsvn4256-2.17.aarch64.rpm Plugins for gmerlin
gmerlin-avdecoder-plugins-1.2.0rsvn4256-2.17.armv7hl.rpm Plugins for gmerlin
Advertisement
Advertisement