dataquay-devel-0.9.1-5.1.aarch64.rpm


Advertisement

Description

dataquay-devel - Development files for dataquay, an RDF data store library

Property Value
Distribution openSUSE Leap 42.3
Repository Packman all
Package name dataquay-devel
Package version 0.9.1
Package release 5.1
Package architecture aarch64
Package type rpm
Installed size 150.02 KB
Download size 33.07 KB
Official Mirror packman.inode.at
Dataquay is a library that provides a C++ API for an
RDF data store using Qt5 classes and containers.
This subpackage contains the header files for developing
applications that want to make use of dataquay.

Alternatives

Package Version Architecture Repository
dataquay-devel-0.9.1-5.2.x86_64.rpm 0.9.1 x86_64 Packman
dataquay-devel-0.9.1-5.1.armv7hl.rpm 0.9.1 armv7hl Packman
dataquay-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libdataquay0 = 0.9.1

Provides

Name Value
dataquay-devel = 0.9.1-5.1
dataquay-devel(aarch-64) = 0.9.1-5.1
pkgconfig(dataquay) = 0.9.1

Download

Type URL
Binary Package dataquay-devel-0.9.1-5.1.aarch64.rpm
Source Package dataquay-0.9.1-5.1.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_42.3/ packman
  2. Install dataquay-devel rpm package:
    # zypper install dataquay-devel

Files

Path
/usr/include/dataquay/BasicStore.h
/usr/include/dataquay/Connection.h
/usr/include/dataquay/Node.h
/usr/include/dataquay/PropertyObject.h
/usr/include/dataquay/RDFException.h
/usr/include/dataquay/Store.h
/usr/include/dataquay/Transaction.h
/usr/include/dataquay/TransactionalStore.h
/usr/include/dataquay/Triple.h
/usr/include/dataquay/Uri.h
/usr/include/dataquay/objectmapper/ContainerBuilder.h
/usr/include/dataquay/objectmapper/ObjectBuilder.h
/usr/include/dataquay/objectmapper/ObjectLoader.h
/usr/include/dataquay/objectmapper/ObjectMapper.h
/usr/include/dataquay/objectmapper/ObjectMapperDefs.h
/usr/include/dataquay/objectmapper/ObjectMapperExceptions.h
/usr/include/dataquay/objectmapper/ObjectMapperForwarder.h
/usr/include/dataquay/objectmapper/ObjectStorer.h
/usr/include/dataquay/objectmapper/TypeMapping.h
/usr/lib64/libdataquay.so
/usr/lib64/pkgconfig/dataquay.pc

Changelog

2018-07-17 - aloisio@gmx.com
- Added dataquay-includedir.patch
2017-09-08 - jengelh@inai.de
- Fix RPM groups. Ensure neutrality of descriptions.
- Use upstream name for -devel subpackage.
2017-08-31 - aloisio@gmx.com
- Update to 0.9.1
* Update to support Qt5 and newer C++ compilers. Now requires
C++11 (though the library only makes minimal use of the
standard).
* Incorporate a number of build fixes
- Switched to Qt5
- Refreshed dataquay-redland.patch and dataquay-lib64.patch
- Added dataquay-sharedlib.patch
- Dropped dataquay-disable_tests.patch
- Spec cleanup
2014-10-22 - avvissu@yandex.ru
- Fix to build on x86 architecture
2012-11-24 - pascal.bleser@opensuse.org
- initial version (0.9)

See Also

Package Description
dcadec-0.2.0-2.5.aarch64.rpm DTS Coherent Acoustics decoder with support for HD extensions
dcadec-0.2.0-2.5.armv7hl.rpm DTS Coherent Acoustics decoder with support for HD extensions
dcadec-0.2.0-2.5.x86_64.rpm DTS Coherent Acoustics decoder with support for HD extensions
dcaenc-2-2.5.aarch64.rpm DTS Encoder
dcaenc-2-2.5.armv7hl.rpm DTS Encoder
dcaenc-2-2.5.x86_64.rpm DTS Encoder
dcatools-0.0.6-2.1.aarch64.rpm Free DTS Coherent Acoustics decoder tools
dcatools-0.0.6-2.1.armv7hl.rpm Free DTS Coherent Acoustics decoder tools
dcatools-0.0.6-2.2.x86_64.rpm Free DTS Coherent Acoustics decoder tools
deadbeef-plugin-mpris2-1.10-3.4.aarch64.rpm MPRISv2 plugin for the DeaDBeeF music player
deadbeef-plugin-mpris2-1.10-3.6.x86_64.rpm MPRISv2 plugin for the DeaDBeeF music player
deadbeef-plugin-statusnotifier-1.3-5.132.x86_64.rpm Alternative tray icon for Plasma 5 DE
deadbeef-plugin-statusnotifier-1.3-5.15.aarch64.rpm Alternative tray icon for Plasma 5 DE
deepin-media-player-2.0git20140428-3.3.noarch.rpm Deepin Media Player
deepin-media-player-2.0git20140428-3.5.noarch.rpm Deepin Media Player
Advertisement
Advertisement