zlib-devel-32bit-1.2.8-14.3.1.x86_64.rpm


Advertisement

Description

zlib-devel-32bit - Development files for zlib, a data compression library

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name zlib-devel-32bit
Package version 1.2.8
Package release 14.3.1
Package architecture x86_64
Package type rpm
Installed size unknown
Download size 11.18 KB
Official Mirror ftp.gwdg.de
zlib is a general-purpose lossless data-compression library,
implementing an API for the DEFLATE algorithm, the latter of
which is being used by, for example, gzip and the ZIP archive
format.
This subpackage holds the development headers for the library.
The zlib data format is itself portable across platforms. Unlike the
LZW compression method used in unix compress(1) and in the GIF image
format, the compression method currently used in zlib essentially
never expands the data. (LZW can double or triple the file size in
extreme cases.) zlib's memory footprint is also independent of the
input data and can be reduced, if necessary, at some cost in
compression.

Alternatives

Package Version Architecture Repository
zlib-devel-32bit-1.2.8-13.15.x86_64.rpm 1.2.8 x86_64 openSUSE Oss
zlib-devel-32bit - - -

Requires

Name Value
zlib-devel = 1.2.8

Provides

Name Value
zlib-devel-32bit = 1.2.8-14.3.1
zlib-devel-32bit(x86-32) = 1.2.8-14.3.1

Download

Type URL
Binary Package zlib-devel-32bit-1.2.8-14.3.1.x86_64.rpm
Source Package zlib-1.2.8-14.3.1.src.rpm

Install Howto

Install zlib-devel-32bit rpm package:

# zypper install zlib-devel-32bit

Files

Path
/usr/lib/libz.so

Changelog

2018-05-15 - tchvatal@suse.com
- Add patch to safeguard against negative values in uInt bsc#1071321:
* 0001-Do-not-try-to-store-negative-values-in-unsigned-int.patch
2016-12-04 - tchvatal@suse.com
- Include fixes for bnc#1003580 bnc#1003579 bnc#1003577 bnc#1013882:
* zlib-bnc1003577.patch
* zlib-bnc1003579-part2.patch
* zlib-bnc1003579.patch
* zlib-bnc1003580.patch refreshed
* zlib-bnc1013882.patch CVE-2016-9843
2015-09-24 - jengelh@inai.de
- Trim descriptions to fit target audience. Update RPM group
classification.
2015-07-13 - tchvatal@suse.com
- Require zlib-devel in zlib-devel-static to fix previous change
2015-06-30 - tchvatal@suse.com
- Bring back zlib-devel-static. Needed by binutils
2015-06-24 - tchvatal@suse.com
- Remove zlib-devel-static, nothing should use libz.a anyway.
- Package minizip library, everything using it should now pull
minizip-devel and unbundle it bnc#935864
2014-09-25 - tchvatal@suse.com
- Install examples to cover another angle from bnc#890228
- Cleanup with spec-cleaner
2013-07-29 - mvyskocil@suse.com
- zlib-format.patch, backport missing sle11 feature back to openSUSE
bnc#831880
2013-05-11 - idonmez@suse.com
- Update to version 1.2.8
* Add new inflateGetDictionary() function
* Fix bug where gzopen() immediately followed by gzclose()
would write an empty file instead of an empty gzip stream.
* Fix bug in gzclose() when gzwrite() runs out of memory
2013-03-05 - mvyskocil@suse.com
- libz1-32bit obsoletes zlib-32bit <= 1.2.7 (fixes bnc#806310)

See Also

Package Description
zlib-devel-static-1.2.8-14.3.1.x86_64.rpm Static library for zlib
zlib-devel-static-32bit-1.2.8-14.3.1.x86_64.rpm Static library for zlib
znc-1.7.1-20.3.1.x86_64.rpm Advanced IRC Bouncer
znc-devel-1.7.1-20.3.1.x86_64.rpm Development files to build modules for ZNC
znc-lang-1.7.1-20.3.1.noarch.rpm Languages for package znc
znc-perl-1.7.1-20.3.1.x86_64.rpm Perl support for ZNC
znc-python3-1.7.1-20.3.1.x86_64.rpm Python support for ZNC
znc-tcl-1.7.1-20.3.1.x86_64.rpm TCL support for ZNC
zsh-5.0.5-9.3.1.x86_64.rpm Shell with comprehensive completion
zsh-htmldoc-5.0.5-9.3.1.x86_64.rpm Zsh shell manual in html format
zstd-1.3.3-2.1.x86_64.rpm Zstandard compression tools
zutils-1.7-4.3.1.x86_64.rpm Collection of utilities for dealing with compressed files
zypp-plugin-python-0.6.3-8.3.1.noarch.rpm Helper that makes writing ZYpp plugins in python easier
zypper-1.13.32-8.1.x86_64.rpm Command line software manager using libzypp
zypper-1.13.38-11.1.x86_64.rpm Command line software manager using libzypp
Advertisement
Advertisement