qt4-qtscript-0.2.0-15.2.1.x86_64.rpm


Advertisement

Description

qt4-qtscript - Qt bindings generator for Qt Script

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name qt4-qtscript
Package version 0.2.0
Package release 15.2.1
Package architecture x86_64
Package type rpm
Installed size 21.44 MB
Download size 4.30 MB
Official Mirror widehat.opensuse.org
Qt Script Generator is a tool that generates Qt bindings for Qt Script.
With the generated bindings you get access to substantial portions of
the Qt API from within Qt Script.

Alternatives

Package Version Architecture Repository
qt4-qtscript-0.2.0-14.21.x86_64.rpm 0.2.0 x86_64 openSUSE Oss
qt4-qtscript - - -

Requires

Name Value
libQtCore.so.4()(64bit) -
libQtGui.so.4()(64bit) -
libQtNetwork.so.4()(64bit) -
libQtOpenGL.so.4()(64bit) -
libQtScript.so.4()(64bit) -
libQtSql.so.4()(64bit) -
libQtSvg.so.4()(64bit) -
libQtWebKit.so.4()(64bit) -
libQtXml.so.4()(64bit) -
libQtXmlPatterns.so.4()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libqt4 = 4.8.7
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
libqtscript_core.so.1()(64bit) -
libqtscript_gui.so.1()(64bit) -
libqtscript_network.so.1()(64bit) -
libqtscript_opengl.so.1()(64bit) -
libqtscript_sql.so.1()(64bit) -
libqtscript_svg.so.1()(64bit) -
libqtscript_uitools.so.1()(64bit) -
libqtscript_webkit.so.1()(64bit) -
libqtscript_xml.so.1()(64bit) -
libqtscript_xmlpatterns.so.1()(64bit) -
qt4-qtscript = 0.2.0-15.2.1
qt4-qtscript(x86-64) = 0.2.0-15.2.1

Download

Type URL
Binary Package qt4-qtscript-0.2.0-15.2.1.x86_64.rpm
Source Package qt4-qtscript-0.2.0-15.2.1.src.rpm

Install Howto

Install qt4-qtscript rpm package:

# zypper install qt4-qtscript

Files

Path
/usr/lib64/qt4/plugins/script/libqtscript_core.so
/usr/lib64/qt4/plugins/script/libqtscript_core.so.1
/usr/lib64/qt4/plugins/script/libqtscript_core.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_core.so.1.0.0
/usr/lib64/qt4/plugins/script/libqtscript_gui.so
/usr/lib64/qt4/plugins/script/libqtscript_gui.so.1
/usr/lib64/qt4/plugins/script/libqtscript_gui.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_gui.so.1.0.0
/usr/lib64/qt4/plugins/script/libqtscript_network.so
/usr/lib64/qt4/plugins/script/libqtscript_network.so.1
/usr/lib64/qt4/plugins/script/libqtscript_network.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_network.so.1.0.0
/usr/lib64/qt4/plugins/script/libqtscript_opengl.so
/usr/lib64/qt4/plugins/script/libqtscript_opengl.so.1
/usr/lib64/qt4/plugins/script/libqtscript_opengl.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_opengl.so.1.0.0
/usr/lib64/qt4/plugins/script/libqtscript_sql.so
/usr/lib64/qt4/plugins/script/libqtscript_sql.so.1
/usr/lib64/qt4/plugins/script/libqtscript_sql.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_sql.so.1.0.0
/usr/lib64/qt4/plugins/script/libqtscript_svg.so
/usr/lib64/qt4/plugins/script/libqtscript_svg.so.1
/usr/lib64/qt4/plugins/script/libqtscript_svg.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_svg.so.1.0.0
/usr/lib64/qt4/plugins/script/libqtscript_uitools.so
/usr/lib64/qt4/plugins/script/libqtscript_uitools.so.1
/usr/lib64/qt4/plugins/script/libqtscript_uitools.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_uitools.so.1.0.0
/usr/lib64/qt4/plugins/script/libqtscript_webkit.so
/usr/lib64/qt4/plugins/script/libqtscript_webkit.so.1
/usr/lib64/qt4/plugins/script/libqtscript_webkit.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_webkit.so.1.0.0
/usr/lib64/qt4/plugins/script/libqtscript_xml.so
/usr/lib64/qt4/plugins/script/libqtscript_xml.so.1
/usr/lib64/qt4/plugins/script/libqtscript_xml.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_xml.so.1.0.0
/usr/lib64/qt4/plugins/script/libqtscript_xmlpatterns.so
/usr/lib64/qt4/plugins/script/libqtscript_xmlpatterns.so.1
/usr/lib64/qt4/plugins/script/libqtscript_xmlpatterns.so.1.0
/usr/lib64/qt4/plugins/script/libqtscript_xmlpatterns.so.1.0.0
/usr/share/doc/packages/qt4-qtscript/LICENSE.LGPL
/usr/share/doc/packages/qt4-qtscript/README

Changelog

2012-09-09 - schwab@linux-m68k.org
- Use %{optflags} and %{?_smp_mflags}
2012-07-12 - adrian@suse.de
- fix arm build
2012-01-26 - idonmez@suse.com
- Fix license to be SUSE-LGPL-2.1-with-nokia-exception-1.1
2012-01-26 - tittiatcoke@gmail.com
- Update to version 0.2
* Compatibility fixes with Qt 4.8
2011-10-12 - cdenicolo@suse.com
- license update: GPL-2
qt4-qtscript is GPL-2 only
2011-09-27 - idonmez@suse.com
- Add qtscript-separate-webkit.patch to fix compilation with
new QtWebKit 2.2
2009-05-22 - dmueller@suse.de
- fix build with gcc 4.4
2009-03-25 - dmueller@suse.de
- Rename to qt4-qtscript to match openSUSE naming sheme.
Package is based on qtscript-qt written by Rex Dieter
and Ian Monroe.

See Also

Package Description
qt4-qtscript-doc-0.2.0-15.2.1.x86_64.rpm Qt bindings generator for Qt Script
qt4-x11-tools-4.8.7-17.3.2.x86_64.rpm C++ Program Library, Core Components
quagga-1.1.1-18.3.1.x86_64.rpm Routing Software for BGP, OSPF and RIP
quagga-devel-1.1.1-18.3.1.x86_64.rpm Development files for quagga, a routing software for BGP, OSPF, RIP
quassel-base-0.12.5-5.3.1.x86_64.rpm Modern, cross-platform, distributed IRC client
quassel-base-0.12.5-5.6.1.x86_64.rpm Base files for the Quassel IRC client
quassel-client-0.12.5-5.3.1.x86_64.rpm Modern, cross-platform, distributed IRC client
quassel-client-0.12.5-5.6.1.x86_64.rpm KDE client for the Quassel IRC client
quassel-client-qt5-0.12.5-5.3.1.x86_64.rpm Modern, cross-platform, distributed IRC client
quassel-client-qt5-0.12.5-5.6.1.x86_64.rpm Qt5 client for the Quassel IRC client
quassel-core-0.12.5-5.3.1.x86_64.rpm Modern, cross-platform, distributed IRC client
quassel-core-0.12.5-5.6.1.x86_64.rpm Core program for the Quassel IRC client
quassel-mono-0.12.5-5.3.1.x86_64.rpm Modern, cross-platform, distributed IRC client
quassel-mono-0.12.5-5.6.1.x86_64.rpm Standalone client for the Quassel IRC client
qupzilla-2.0.1-4.3.1.x86_64.rpm Cross-platform Qt web browser
Advertisement
Advertisement