polkit-0.113-14.3.1.x86_64.rpm


Advertisement

Description

polkit - PolicyKit Authorization Framework

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name polkit
Package version 0.113
Package release 14.3.1
Package architecture x86_64
Package type rpm
Installed size 252.08 KB
Download size 108.75 KB
Official Mirror widehat.opensuse.org
PolicyKit is a toolkit for defining and handling authorizations.
It is used for allowing unprivileged processes to speak to privileged
processes.

Alternatives

Package Version Architecture Repository
polkit-0.113-13.1.x86_64.rpm 0.113 x86_64 openSUSE Oss
polkit - - -

Requires

Name Value
dbus-1 -
libc.so.6(GLIBC_2.7)(64bit) -
libexpat.so.1()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libmozjs-17.0.so()(64bit) -
libmozjs-17.0.so(mozjs_17.0)(64bit) -
libpam.so.0()(64bit) -
libpam.so.0(LIBPAM_1.0)(64bit) -
libpolkit-agent-1.so.0()(64bit) -
libpolkit-gobject-1.so.0()(64bit) -
libpolkit0 = 0.113-14.3.1
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libsystemd.so.0()(64bit) -
libsystemd.so.0(LIBSYSTEMD_209)(64bit) -
libsystemd.so.0(LIBSYSTEMD_213)(64bit) -
permissions -
pwdutils -
systemd -

Provides

Name Value
config(polkit) = 0.113-14.3.1
polkit = 0.113-14.3.1
polkit(x86-64) = 0.113-14.3.1

Download

Type URL
Binary Package polkit-0.113-14.3.1.x86_64.rpm
Source Package polkit-0.113-14.3.1.src.rpm

Install Howto

Install polkit rpm package:

# zypper install polkit

Files

Path
/etc/dbus-1/
/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
/etc/pam.d/polkit-1
/etc/polkit-1/
/etc/polkit-1/rules.d/50-default.rules
/usr/bin/pkaction
/usr/bin/pkcheck
/usr/bin/pkexec
/usr/bin/pkttyagent
/usr/lib/polkit-1/polkit-agent-helper-1
/usr/lib/polkit-1/polkitd
/usr/lib/systemd/system/polkit.service
/usr/share/dbus-1/
/usr/share/dbus-1/system-services/org.freedesktop.PolicyKit1.service
/usr/share/doc/packages/polkit/COPYING
/usr/share/locale/cs/LC_MESSAGES/polkit-1.mo
/usr/share/locale/da/LC_MESSAGES/polkit-1.mo
/usr/share/man/man1/pkaction.1.gz
/usr/share/man/man1/pkcheck.1.gz
/usr/share/man/man1/pkexec.1.gz
/usr/share/man/man1/pkttyagent.1.gz
/usr/share/man/man8/polkit.8.gz
/usr/share/man/man8/polkitd.8.gz
/usr/share/polkit-1/
/usr/share/polkit-1/actions/org.freedesktop.policykit.policy
/usr/share/polkit-1/rules.d/
/var/lib/polkit/

Changelog

2018-07-04 - meissner@suse.com
- 0001-Fix-CVE-FIXME-Trusting-client-supplied-UID.patch:
Fixed trusting the client-supplied UID (CVE-2018-1116 bsc#1099031)
2017-06-13 - lnussel@suse.de
- Use gettext as fallback to get potential distro translations for
polkit actions. Similar mechnism as used for desktop file
translations. That way it's possible to use weblate to add
additional translations that are not provided by upstream
(polkit-gettext.patch).
2016-06-08 - fbui@suse.com
- Use pkgconfig() instead of requiring systemd package names directly.
2016-06-07 - fbui@suse.com
- systemd.pc is shipped by systemd main package (bsc#983167)
Strangely polkit wants systemd.pc to detect that the target system
is running systemd even if its configured to build systemd support...
2015-11-26 - meissner@suse.com
- polkit-revert-session-magic.patch: revert a session detection change
that could lead to sessions not being detected as active due to
a systemd bug. bsc#954139
2015-08-06 - antoine.belvire@laposte.net
- Update to 0.113:
* Fix CVE-2015-4625
* Fix CVE-2015-3256
* Fix CVE-2015-3255
* Fix CVE-2015-3218
* On systemd-213 and later, the ?active? state is shared across
all sessions of an user, instead of being tracked separately
* pkexec: when not given a program to execute, runs the users?
shell by default
- Remove polkit-no-kded-leak.patch (upstreamed)
2015-01-12 - tchvatal@suse.com
- Try to fix kded leaking due to powerdevil exposing this issue in
polkit: (bsc#912889)
* polkit-no-kded-leak.patch
2014-12-09 - meissner@suse.com
- Added gpg signature and keyring with David Zeuthen and Miloslav Trmac
ids.
2013-09-27 - toms@opensuse.org
- Fixed URL
2013-09-19 - hrvoje.senjan@gmail.com
- Update to 0.112
+ polkitunixprocess: Deprecate racy APIs
+ pkcheck: Support --process=pid,start-time,uid syntax too
(CVE-2013-4288)
+ Use GOnce for interface type registration
+ Add czech translation po file to distribution
+ Update the czech once more with newest pot file

See Also

Package Description
polkit-devel-0.113-14.3.1.x86_64.rpm Development files for PolicyKit
polkit-doc-0.113-14.3.1.noarch.rpm Development documentation for PolicyKit
polkit-gnome-0.105-17.4.1.x86_64.rpm PolicyKit integration for the GNOME desktop
polkit-gnome-lang-0.105-17.4.1.noarch.rpm Languages for package polkit-gnome
poppler-tools-0.43.0-5.1.x86_64.rpm PDF Rendering Library Tools
poppler-tools-0.43.0-8.1.x86_64.rpm PDF Rendering Library Tools
postgresql-init-10-16.3.1.noarch.rpm Init script and other infrastructure for PostgreSQL
postgresql10-10.5-2.1.x86_64.rpm Basic Clients and Utilities for PostgreSQL
postgresql10-10.6-5.1.x86_64.rpm Basic Clients and Utilities for PostgreSQL
postgresql10-contrib-10.5-2.1.x86_64.rpm Contributed Extensions and Additions to PostgreSQL
postgresql10-contrib-10.6-5.1.x86_64.rpm Contributed Extensions and Additions to PostgreSQL
postgresql10-devel-10.5-2.1.x86_64.rpm PostgreSQL development header files and libraries
postgresql10-devel-10.6-5.1.x86_64.rpm PostgreSQL development header files and libraries
postgresql10-docs-10.5-2.1.noarch.rpm HTML Documentation for PostgreSQL
postgresql10-docs-10.6-5.1.noarch.rpm HTML Documentation for PostgreSQL
Advertisement
Advertisement