php7-posix-7.0.7-55.1.x86_64.rpm


Advertisement

Description

php7-posix - PHP7 Extension Module

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package filename php7-posix-7.0.7-55.1.x86_64.rpm
Package name php7-posix
Package version 7.0.7
Package release 55.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/PHP
Homepage http://www.php.net
License PHP-3.01
Maintainer -
Download size 60.21 KB
Installed size 31.07 KB
This module allows to use POSIX-like functions in PHP.

Alternatives

Package Version Architecture Repository
php7-posix-7.2.13-155.1.x86_64.rpm 7.2.13 x86_64 Apache Modules
php7-posix-7.0.7-58.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-52.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-49.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-46.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-43.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-40.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-37.2.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-34.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-31.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-28.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-25.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-22.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-19.1.x86_64.rpm 7.0.7 x86_64 openSUSE Update Oss
php7-posix-7.0.7-17.2.x86_64.rpm 7.0.7 x86_64 openSUSE Oss
php7-posix - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
php7 = 7.0.7

Provides

Name Value
config(php7-posix) = 7.0.7-55.1
php-posix = 7.0.7
php7-posix = 7.0.7-55.1
php7-posix(x86-64) = 7.0.7-55.1
posix.so()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package php7-posix-7.0.7-55.1.x86_64.rpm
Source Package php7-7.0.7-55.1.src.rpm

Install Howto

Install php7-posix rpm package:

# zypper install php7-posix

Files

Path
/etc/php7/conf.d/posix.ini
/usr/lib64/php7/extensions/posix.so

Changelog

2019-01-31 - Petr Gajdos <pgajdos@suse.com>
- security update
* CVE-2019-6978 [bsc#1123522]
+ php-CVE-2019-6978.patch
* CVE-2019-6977 [bsc#1123354]
+ php-CVE-2019-6977.patch
2018-12-11 - Petr Gajdos <pgajdos@suse.com>
- security update
* CVE-2018-19935 [bsc#1118832]
+ php-CVE-2018-19935.patch
2018-11-23 - Petr Gajdos <pgajdos@suse.com>
- security update
* imap_open script injection flaw, CVE-2018-19518 [bsc#1117107]
+ php-imap_open-script-injection.patch
2018-09-19 - Petr Gajdos <pgajdos@suse.com>
- security update
* CVE-2018-17082 [bsc#1108753]
+ php-CVE-2018-17082.patch
2018-08-28 - pgajdos@suse.com
- fix segfault in pcre extension, CVE-2017-9118 [bsc#1105466]
+ php-pcre-replace-impl-CWE-680.patch
2018-08-28 - pgajdos@suse.com
- align patch names:
* php7-CVE-2017-9120.patch -> php-CVE-2017-9120.patch
* php7-CVE-2018-14851.patch -> php-CVE-2018-14851.patch
2018-08-04 - pgajdos@suse.com
- security update
* CVE-2018-14851 [bsc#1103659]
+ php-CVE-2018-14851.patch
* CVE-2017-9120 [bsc#1103661]
+ php-CVE-2017-9120.patch
2018-06-26 - pgajdos@suse.com
- security update
* CVE-2018-12882 [bsc#1099098]
+ php-CVE-2018-12882.patch
2018-05-02 - pgajdos@suse.com
- security update
* CVE-2018-10545 [bsc#1091367]
+ php-CVE-2018-10545.patch
* CVE-2018-10547 [bsc#1091362]
+ php-CVE-2018-10547.patch
* CVE-2018-10546 [bsc#1091363]
+ php-CVE-2018-10546.patch
* CVE-2018-10548 [bsc#1091355]
+ php-CVE-2018-10548.patch
2018-04-23 - pgajdos@suse.com
- SplFileObject::getCsvControl() returns escape character
[bsc#1090133]
+ php7-splfileobject-escape-character.patch

See Also

Package Description
php7-pspell-7.0.7-19.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-22.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-25.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-28.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-31.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-34.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-37.2.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-40.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-43.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-46.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-49.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-52.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-55.1.x86_64.rpm PHP7 pspell extension
php7-pspell-7.0.7-58.1.x86_64.rpm PHP7 pspell extension
php7-readline-7.0.7-19.1.x86_64.rpm PHP7 readline extension
Advertisement
Advertisement