perl-Bootloader-0.921-2.3.1.x86_64.rpm


Advertisement

Description

perl-Bootloader - Library for Configuring Boot Loaders

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name perl-Bootloader
Package version 0.921
Package release 2.3.1
Package architecture x86_64
Package type rpm
Installed size 402.35 KB
Download size 140.48 KB
Official Mirror ftp.gwdg.de
Perl modules for configuring various boot loaders.
Authors:
--------
Jiri Srain <jsrain@suse.cz>
Joachim Plack <jplack@suse.de>
Alexander Osthof <aosthof@suse.de>
Josef Reidinger <jreidinger@suse.cz>

Alternatives

Package Version Architecture Repository
perl-Bootloader-0.919-1.1.x86_64.rpm 0.919 x86_64 openSUSE Oss
perl-Bootloader - - -

Requires

Name Value
/bin/bash -
/usr/bin/perl -
coreutils -
perl-base = 5.18.2

Provides

Name Value
perl(Bootloader::Core) -
perl(Bootloader::Core::ELILO) -
perl(Bootloader::Core::GRUB) -
perl(Bootloader::Core::GRUB2) -
perl(Bootloader::Core::GRUB2EFI) -
perl(Bootloader::Core::LILO) -
perl(Bootloader::Core::NONE) -
perl(Bootloader::FileIO) -
perl(Bootloader::Library) = 0.921
perl(Bootloader::Logger) -
perl(Bootloader::MBRTools) -
perl(Bootloader::Path) -
perl(Bootloader::Tools) -
perl-Bootloader = 0.921-2.3.1
perl-Bootloader(x86-64) = 0.921-2.3.1

Conflicts

Name Value
multipath-tools < 0.4.8-40.25.1

Download

Type URL
Binary Package perl-Bootloader-0.921-2.3.1.x86_64.rpm
Source Package perl-Bootloader-0.921-2.3.1.src.rpm

Install Howto

Install perl-Bootloader rpm package:

# zypper install perl-Bootloader

Files

Path
/boot/boot.readme
/etc/logrotate.d/pbl
/sbin/pbl
/sbin/update-bootloader
/usr/lib/bootloader/bootloader_entry
/usr/lib/bootloader/bootloader_entry.old
/usr/lib/bootloader/update-bootloader.old
/usr/lib/bootloader/grub2/add-option
/usr/lib/bootloader/grub2/config
/usr/lib/bootloader/grub2/del-option
/usr/lib/bootloader/grub2/get-option
/usr/lib/bootloader/grub2/install
/usr/lib/bootloader/grub2-efi/add-option
/usr/lib/bootloader/grub2-efi/config
/usr/lib/bootloader/grub2-efi/del-option
/usr/lib/bootloader/grub2-efi/get-option
/usr/lib/bootloader/grub2-efi/install
/usr/lib/bootloader/u-boot/config
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Core.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/FileIO.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Library.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Logger.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/MBRTools.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Path.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Tools.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Core/ELILO.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Core/GRUB.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Core/GRUB2.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Core/GRUB2EFI.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Core/LILO.pm
/usr/lib/perl5/vendor_perl/5.18.2/Bootloader/Core/NONE.pm
/usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/auto/Bootloader/
/usr/share/licenses/perl-Bootloader/COPYING
/usr/share/man/man3/Bootloader::Core.3pm.gz
/usr/share/man/man3/Bootloader::Core::ELILO.3pm.gz
/usr/share/man/man3/Bootloader::Core::GRUB.3pm.gz
/usr/share/man/man3/Bootloader::Core::GRUB2.3pm.gz
/usr/share/man/man3/Bootloader::Core::GRUB2EFI.3pm.gz
/usr/share/man/man3/Bootloader::Core::LILO.3pm.gz
/usr/share/man/man3/Bootloader::Core::NONE.3pm.gz
/usr/share/man/man3/Bootloader::FileIO.3pm.gz
/usr/share/man/man3/Bootloader::Library.3pm.gz
/usr/share/man/man3/Bootloader::Logger.3pm.gz
/usr/share/man/man3/Bootloader::MBRTools.3pm.gz
/usr/share/man/man3/Bootloader::Path.3pm.gz
/usr/share/man/man3/Bootloader::Tools.3pm.gz
/usr/share/man/man8/update-bootloader.8.gz
/var/log/pbl.log
/var/log/YaST2/

Changelog

2018-07-05 - wfeldt@opensuse.org
- merge gh#openSUSE/perl-bootloader#116
- add --get-option to pbl (bsc#1033776, bsc#1050349)
- 0.921
2018-07-05 - bwiedemann@suse.de
- merge gh#openSUSE/perl-bootloader#115
- Avoid undefined var warning
- 0.920
2018-03-26 - kukuk@suse.de
- Use %license instead of %doc [bsc#1082318]
2017-05-12 - wfeldt@opensuse.org
- merge gh#openSUSE/perl-bootloader#113
- fix device name check (bsc#1033634, bsc#1033776)
- 0.919
2017-04-28 - mchang@suse.com
- merge gh#openSUSE/perl-bootloader#112
- implemented trusted boot/TPM support in UEFI mode (bsc#1036735,
fate#315831)
- 0.918
2017-01-24 - snwint@suse.com
- grub2: drop trailing space from saved entry
- grub2: parse initrd (bsc#1007335)
- 0.917
2016-10-18 - snwint@suse.com
- run shim-install only if secure boot is set to yes (bsc#985567)
- 0.916
2016-07-22 - snwint@suse.com
- also clear LC_ALL when setting locale
- run grub in RC_LANG locale taken from sysconfig (bsc#985946)
- 0.915
2016-07-22 - snwint@suse.com
- ensure trusted boot setting is used (fate#316553)
- 0.914
2016-05-11 - snwint@suse.com
- Don't install grub2-efi during installation (bsc#979145)
- 0.913

See Also

Package Description
perl-Bootloader-YAML-0.921-2.3.1.x86_64.rpm YAML interface for perl-Bootloader
perl-Business-ISBN-Data-20120719.001-10.1.noarch.rpm Data pack for Business::ISBN
perl-DBD-mysql-4.021-18.3.1.x86_64.rpm MySQL driver for the Perl5 Database Interface (DBI)
perl-Export-Attrs-0.1.0-2.1.noarch.rpm The Perl 6 'is export(...)' trait as a Perl 5 attribute
perl-Finance-Quote-1.47-4.3.1.noarch.rpm Get stock and mutual fund quotes from various exchanges
perl-Finance-Quote-1.47-4.8.1.noarch.rpm Get stock and mutual fund quotes from various exchanges
perl-GraphicsMagick-1.3.25-102.1.x86_64.rpm Viewer and Converter for Images - perl interface
perl-GraphicsMagick-1.3.25-105.1.x86_64.rpm Viewer and Converter for Images - perl interface
perl-GraphicsMagick-1.3.25-108.1.x86_64.rpm Viewer and Converter for Images - perl interface
perl-GraphicsMagick-1.3.25-111.1.x86_64.rpm Viewer and Converter for Images - perl interface
perl-GraphicsMagick-1.3.25-17.1.x86_64.rpm Viewer and Converter for Images - perl interface
perl-GraphicsMagick-1.3.25-20.1.x86_64.rpm Viewer and Converter for Images - perl interface
perl-GraphicsMagick-1.3.25-27.1.x86_64.rpm Viewer and Converter for Images - perl interface
perl-GraphicsMagick-1.3.25-34.1.x86_64.rpm Viewer and Converter for Images - perl interface
perl-GraphicsMagick-1.3.25-39.1.x86_64.rpm Viewer and Converter for Images - perl interface
Advertisement
Advertisement