libwx_gtk2u_aui-suse1-3.0.2-11.1.x86_64.rpm


Advertisement

Description

libwx_gtk2u_aui-suse1 - wxWidgets Library

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name libwx_gtk2u_aui-suse1
Package version 3.0.2
Package release 11.1
Package architecture x86_64
Package type rpm
Installed size 562.06 KB
Download size 161.64 KB
Official Mirror ftp.gwdg.de
Library for the wxWidgets cross-platform GUI.

Alternatives

Package Version Architecture Repository
libwx_gtk2u_aui-suse1-3.0.2-9.27.x86_64.rpm 3.0.2 x86_64 openSUSE Oss
libwx_gtk2u_aui-suse1 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libwx_baseu-suse.so.1()(64bit) -
libwx_baseu-suse.so.1(WXU_3.0)(64bit) -
libwx_gtk2u_core-suse.so.1()(64bit) -
libwx_gtk2u_core-suse.so.1(WXU_3.0)(64bit) -

Provides

Name Value
libwx_gtk2u_aui-suse.so.1()(64bit) -
libwx_gtk2u_aui-suse.so.1(WXU_3.0)(64bit) -
libwx_gtk2u_aui-suse.so.1(WXU_3.0.1)(64bit) -
libwx_gtk2u_aui-suse.so.1(WXU_3.0.2)(64bit) -
libwx_gtk2u_aui-suse1 = 3.0.2-11.1
libwx_gtk2u_aui-suse1(x86-64) = 3.0.2-11.1

Download

Type URL
Binary Package libwx_gtk2u_aui-suse1-3.0.2-11.1.x86_64.rpm
Source Package wxWidgets-3_0-3.0.2-11.1.src.rpm

Install Howto

Install libwx_gtk2u_aui-suse1 rpm package:

# zypper install libwx_gtk2u_aui-suse1

Files

Path
/usr/lib64/libwx_gtk2u_aui-suse.so.1

Changelog

2016-06-27 - davejplater@gmail.com
- Created wxWidgets-nostl to enable audacity updates in openSUSE
because all of the other Linux distributions prefer to build
wxWidgets without STL and audacity developers have no intention
of fixing audacity to build against wxWidgets built with STL.
2016-06-17 - jengelh@inai.de
- Add abs.diff to reenable successful gcc6 build
2016-02-20 - jengelh@inai.de
- Add patches from upstream to resolve crashes in normal conditions,
and when running under non-X11 wxGTK3.
0001-avoid-passing-invalid-rect-to-Refresh-closes-16819.patch
0001-Ensure-the-PangoFontFace-type-is-loaded.patch
0001-Fix-wxPrintDialog-when-used-directly-see-16821.patch
0001-set-transient-parent-for-about-dialog-closes-16823.patch
0001-Avoid-refreshing-not-currently-visible-items-in-gene.patch
0001-Avoid-Gtk-Message-GtkDialog-mapped-without-a-transie.patch
0001-Fix-wxSpinButton-best-size-for-GTK-3.12-and-later-se.patch
0001-Fix-drawing-checkbox-and-radiobutton-in-checked-stat.patch
0001-fix-crashes-in-wxGTK3-when-running-with-non-X11-back.patch
0002-Don-t-defer-wxTLW-initialization-in-wxGTK-when-not-u.patch
0003-Don-t-use-frame-extents-when-not-using-X11-in-wxGTK.patch
0004-Don-t-crash-when-switching-to-full-screen-in-non-X11.patch
0005-Don-t-use-X11-only-functions-when-not-using-X11-in-w.patch
0001-Provide-trivial-GDK_IS_X11_DISPLAY-definition-for-GT.patch
2015-03-29 - jengelh@inai.de
- Fixup Provides/Conflicts: wxWidgets-3_0 is wxGTK2, not wxGTK3,
and should conflict against experimental variants that are
shipping concurrently.
2014-12-07 - jengelh@inai.de
- Add missing directives to baselibs.conf, and also
remove wxGTK3 from baselibs.
2014-12-05 - jengelh@inai.de
- Reenable standard dependency generator. We no longer have
overlapping library SONAMEs.
2014-11-07 - jengelh@inai.de
- Update to new upstream release 3.0.2
* Fix silent data loss in wx[F]File::Write(wxString) if conversion
fails.
* Make wxString::FromCDouble() work when the global C++ locale is
not the C one.
* Fix mouse handling in wxNotebook containing wxListCtrl.
- Bump SONAME due to changed ABI, add soversion.diff.
- Don't let wxGTK3-3_0.spec build the SDL plugin (already done
by wxWidgets-3_0.spec)
2014-11-06 - jengelh@inai.de
- Restore libwx_base*.so devel symlinks [boo#904098]
2014-11-05 - jengelh@inai.de
- Replace broad Requires: Mesa-devel by pkgconfig(gl)
[Mesa-libGL-devel]
2014-07-31 - dimstar@opensuse.org
- Rename rpmlintrc to %{name}-rpmlintrc.
Follow the packaging guidelines.

See Also

Package Description
libwx_gtk2u_aui-suse1-32bit-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_core-suse-nostl1-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_core-suse1-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_core-suse1-32bit-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_gl-suse-nostl1-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_gl-suse1-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_gl-suse1-32bit-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_html-suse-nostl1-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_html-suse1-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_html-suse1-32bit-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_media-suse-nostl1-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_media-suse1-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_media-suse1-32bit-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_propgrid-suse-nostl1-3.0.2-11.1.x86_64.rpm wxWidgets Library
libwx_gtk2u_propgrid-suse1-3.0.2-11.1.x86_64.rpm wxWidgets Library
Advertisement
Advertisement