libswscale5-4.0.1-2.2.x86_64.rpm


Advertisement

Description

libswscale5 - FFmpeg image scaling and colorspace/pixel conversion library

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name libswscale5
Package version 4.0.1
Package release 2.2
Package architecture x86_64
Package type rpm
Installed size 532.39 KB
Download size 174.53 KB
Official Mirror ftp.gwdg.de
The libswscale library performs image scaling and colorspace and
pixel format conversion operations.

Alternatives

Package Version Architecture Repository
libswscale5-4.0.2-28.1.x86_64.rpm 4.0.2 x86_64 openSUSE Multimedia Libs
libswscale5-4.0.2-21.2.armv7hl.rpm 4.0.2 armv7hl Packman
libswscale5-4.0.2-21.2.aarch64.rpm 4.0.2 aarch64 Packman
libswscale5-4.0.2-21.1.x86_64.rpm 4.0.2 x86_64 Packman
libswscale5-4.0.2-13.1.x86_64.rpm 4.0.2 x86_64 openSUSE Update Oss
libswscale5-4.0.1-10.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
libswscale5-4.0.1-7.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
libswscale5 - - -

Requires

Name Value
/sbin/ldconfig -
libavutil.so.56()(64bit) -
libavutil.so.56(LIBAVUTIL_56)(64bit) -
libavutil56 = 4.0.1-2.2
libc.so.6(GLIBC_2.14)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -

Provides

Name Value
libswscale.so.5()(64bit) -
libswscale.so.5(LIBSWSCALE_5)(64bit) -
libswscale5 = 4.0.1-2.2
libswscale5(x86-64) = 4.0.1-2.2

Download

Type URL
Binary Package libswscale5-4.0.1-2.2.x86_64.rpm
Source Package ffmpeg-4-4.0.1-2.2.src.rpm

Install Howto

Install libswscale5 rpm package:

# zypper install libswscale5

Files

Path
/usr/lib64/libswscale.so.5
/usr/lib64/libswscale.so.5.1.100
/usr/share/licenses/libswscale5/COPYING.GPLv2
/usr/share/licenses/libswscale5/LICENSE.md

Changelog

2018-07-06 - tchvatal@suse.com
- Fix typo in swresample name
2018-07-04 - tchvatal@suse.com
- Conditionalize full build to be primary only on Leap15+
2018-07-03 - tchvatal@suse.com
- Add macros to allow conflicting with all other devel projects
to ensure we always install only one specific ffmpeg
2018-06-30 - tchvatal@suse.com
- Conditionalize the vidstab build to not pull it on old releases
- Conditionalize srt support to not pull it on older releases
- ------------------------------------------------------------------
2018-06-29 - 9+suse@cirno.systems
- Enable ffnvcodec when building with NVIDIA support
2018-06-29 - bjorn.lie@gmail.com
- Add pkgconfig(srt) BuildRequires and pass --enable-libsrt to
configure, enable srt support.
- Refresh patches with quilt:
* cve-2017-17555.diff
* ffmpeg-codec-choice.diff
* ffmpeg-libcdio_cdda-pkgconfig.patch
* ffmpeg-new-coder-errors.diff
2018-06-29 - 9+suse@cirno.systems
- Enable libxml2 (used by MPEG DASH demuxer)
2018-06-27 - jengelh@inai.de
- Update to new upstream release 4.0.1
* Fixed some integer overflows, undefined shifts, negative
shifts, division by 0, and a null pointer deref.
2018-06-18 - bjorn.lie@gmail.com
- Enable pkgconfig(vidstab) BuildRequires unconditionally, now
available in openSUSE.
2018-06-14 - tchvatal@suse.com
- Conditionalize openmpt build to be resolvable on Leap 42.3

See Also

Package Description
libsynctex1-1.18-32.3.1.x86_64.rpm Libraries of The Synchronization TeXnology
libsystemd0-228-29.1.x86_64.rpm Component library for systemd
libsystemd0-228-32.2.x86_64.rpm Component library for systemd
libsystemd0-228-35.1.x86_64.rpm Component library for systemd
libsystemd0-228-38.1.x86_64.rpm Component library for systemd
libsystemd0-228-41.1.x86_64.rpm Component library for systemd
libsystemd0-228-44.1.x86_64.rpm Component library for systemd
libsystemd0-228-47.1.x86_64.rpm Component library for systemd
libsystemd0-228-50.1.x86_64.rpm Component library for systemd
libsystemd0-228-53.1.x86_64.rpm Component library for systemd
libsystemd0-228-56.1.x86_64.rpm Component library for systemd
libsystemd0-32bit-228-29.1.x86_64.rpm Component library for systemd
libsystemd0-32bit-228-32.2.x86_64.rpm Component library for systemd
libsystemd0-32bit-228-35.1.x86_64.rpm Component library for systemd
libsystemd0-32bit-228-38.1.x86_64.rpm Component library for systemd
Advertisement
Advertisement