libqt4-sql-postgresql-32bit-4.8.7-17.3.1.x86_64.rpm


Advertisement

Description

libqt4-sql-postgresql-32bit - Qt 4 PostgreSQL plugin

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name libqt4-sql-postgresql-32bit
Package version 4.8.7
Package release 17.3.1
Package architecture x86_64
Package type rpm
Installed size 78.32 KB
Download size 55.45 KB
Official Mirror widehat.opensuse.org
Qt SQL plugin to support PostgreSQL servers in Qt applications.

Alternatives

Package Version Architecture Repository
libqt4-sql-postgresql-32bit - - -

Requires

Name Value
libQtCore.so.4 -
libQtSql.so.4 -
libc.so.6(GLIBC_2.1.3) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libpq.so.5 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -

Provides

Name Value
libqsqlpsql.so -
libqt4-sql-postgresql-32bit = 4.8.7-17.3.1
libqt4-sql-postgresql-32bit(x86-32) = 4.8.7-17.3.1

Download

Type URL
Binary Package libqt4-sql-postgresql-32bit-4.8.7-17.3.1.x86_64.rpm
Source Package libqt4-sql-plugins-4.8.7-17.3.1.src.rpm

Install Howto

Install libqt4-sql-postgresql-32bit rpm package:

# zypper install libqt4-sql-postgresql-32bit

Files

Path
/usr/lib/qt4/
/usr/lib/qt4/plugins/
/usr/lib/qt4/plugins/sqldrivers/libqsqlpsql.so

Changelog

2017-12-26 - fabian@ritter-vogt.de
- Change fix-build-icu59.patch to build qlocale_icu.cpp with
- std=c++11 to support ICU60 headers
2017-12-06 - fabian@ritter-vogt.de
- Add proper patch headers to:
* no-ssl3.patch
* qt4-openssl-1.1.0pre-3.patch
- Remove patch, not needed:
* qt-everywhere-opensource-src-4.8.7-gcc7.patch
2017-12-05 - ro@suse.de
- add patches from mageia to fix build with openssl-1.1
- add no-ssl3.patch
- add qt4-openssl-1.1.0pre-3.patch
- add qt-everywhere-opensource-src-4.8.7-openssl.patch
- add qt-everywhere-opensource-src-4.8.7-gcc7.patch
2017-09-10 - dimstar@opensuse.org
- BuildRequire libnsl-devel on current TW and CODE15 targets. The
library has been deprecated in glibc and is now in an own
package.
2017-09-04 - cornelis@solcon.nl
- Add fix-medium-font.diff (taken from ubuntu) to fix bolder font
in Qt4 apps (boo#956357)
2017-08-24 - fvogt@suse.com
- Force building against openSSL 1.0 (boo#1042657)
- Do not build the MySQL plugin on TW, it would cause an openSSL
version conflict
- Adjust fix-build-icu59.patch to also work if built with c++11
support
2017-05-10 - fabian@ritter-vogt.de
- Add fix-build-icu59.patch to fix building with ICU4C >= 59
- Invoke configure with sh to fix build on some older distros
2017-02-10 - alarrosa@suse.com
- Add fix-moc-parsing-with-glibc-2.25.patch to fix moc parsing
system headers from glibc 2.25 correctly.
2016-06-24 - lbeltrame@kde.org
- Add fix-gcc6-detection.diff to fix GCC6 detection (boo#986350)
2016-06-02 - matwey.kornilov@gmail.com
- Enable libqt4-devel-32bit to fix boo#982826

See Also

Package Description
libqt4-sql-postgresql-4.8.7-17.3.1.x86_64.rpm Qt 4 PostgreSQL plugin
libqt4-sql-sqlite-32bit-4.8.7-17.3.1.x86_64.rpm Qt 4 sqlite plugin
libqt4-sql-sqlite-4.8.7-17.3.1.x86_64.rpm Qt 4 sqlite plugin
libqt4-sql-unixODBC-32bit-4.8.7-17.3.1.x86_64.rpm Qt 4 unixODBC plugin
libqt4-sql-unixODBC-4.8.7-17.3.1.x86_64.rpm Qt 4 unixODBC plugin
libqt4-x11-32bit-4.8.7-17.3.1.x86_64.rpm Qt 4 GUI related libraries
libqt4-x11-4.8.7-17.3.1.x86_64.rpm Qt 4 GUI related libraries
libqt5-qtbase-common-devel-5.6.2-7.3.1.x86_64.rpm Qt 5 Core Development Binaries
libqt5-qtbase-devel-5.6.2-7.3.1.x86_64.rpm Qt Development Kit
libqt5-qtbase-examples-32bit-5.6.2-7.3.1.x86_64.rpm Qt5 base examples
libqt5-qtbase-examples-5.6.2-7.3.1.x86_64.rpm Qt5 base examples
libqt5-qtbase-private-headers-devel-5.6.2-7.3.1.noarch.rpm Non-ABI stable experimental API
libqt5-qtwebengine-32bit-5.6.2-6.2.x86_64.rpm Qt 5 WebEngine Library
libqt5-qtwebengine-5.6.2-6.2.x86_64.rpm Qt 5 WebEngine Library
libqt5-qtwebengine-devel-32bit-5.6.2-6.2.x86_64.rpm Qt Development Kit
Advertisement
Advertisement