libpostproc55-4.0.1-2.2.x86_64.rpm


Advertisement

Description

libpostproc55 - FFmpeg post-processing library

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name libpostproc55
Package version 4.0.1
Package release 2.2
Package architecture x86_64
Package type rpm
Installed size 140.25 KB
Download size 86.64 KB
Official Mirror ftp.gwdg.de
A library with video postprocessing filters, such as deblocking and
deringing filters, noise reduction, automatic contrast and brightness
correction, linear/cubic interpolating deinterlacing.

Alternatives

Package Version Architecture Repository
libpostproc55-4.0.2-23.1.x86_64.rpm 4.0.2 x86_64 openSUSE Multimedia Libs
libpostproc55-4.0.1-10.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
libpostproc55-4.0.1-7.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
libpostproc55 - - -

Requires

Name Value
/sbin/ldconfig -
libavutil.so.56()(64bit) -
libavutil.so.56(LIBAVUTIL_56)(64bit) -
libavutil56 = 4.0.1-2.2
libc.so.6(GLIBC_2.14)(64bit) -
libpthread.so.0()(64bit) -

Provides

Name Value
libpostproc.so.55()(64bit) -
libpostproc.so.55(LIBPOSTPROC_55)(64bit) -
libpostproc55 = 4.0.1-2.2
libpostproc55(x86-64) = 4.0.1-2.2

Download

Type URL
Binary Package libpostproc55-4.0.1-2.2.x86_64.rpm
Source Package ffmpeg-4-4.0.1-2.2.src.rpm

Install Howto

Install libpostproc55 rpm package:

# zypper install libpostproc55

Files

Path
/usr/lib64/libpostproc.so.55
/usr/lib64/libpostproc.so.55.1.100
/usr/share/licenses/libpostproc55/COPYING.GPLv2
/usr/share/licenses/libpostproc55/LICENSE.md

Changelog

2018-07-06 - tchvatal@suse.com
- Fix typo in swresample name
2018-07-04 - tchvatal@suse.com
- Conditionalize full build to be primary only on Leap15+
2018-07-03 - tchvatal@suse.com
- Add macros to allow conflicting with all other devel projects
to ensure we always install only one specific ffmpeg
2018-06-30 - tchvatal@suse.com
- Conditionalize the vidstab build to not pull it on old releases
- Conditionalize srt support to not pull it on older releases
- ------------------------------------------------------------------
2018-06-29 - 9+suse@cirno.systems
- Enable ffnvcodec when building with NVIDIA support
2018-06-29 - bjorn.lie@gmail.com
- Add pkgconfig(srt) BuildRequires and pass --enable-libsrt to
configure, enable srt support.
- Refresh patches with quilt:
* cve-2017-17555.diff
* ffmpeg-codec-choice.diff
* ffmpeg-libcdio_cdda-pkgconfig.patch
* ffmpeg-new-coder-errors.diff
2018-06-29 - 9+suse@cirno.systems
- Enable libxml2 (used by MPEG DASH demuxer)
2018-06-27 - jengelh@inai.de
- Update to new upstream release 4.0.1
* Fixed some integer overflows, undefined shifts, negative
shifts, division by 0, and a null pointer deref.
2018-06-18 - bjorn.lie@gmail.com
- Enable pkgconfig(vidstab) BuildRequires unconditionally, now
available in openSUSE.
2018-06-14 - tchvatal@suse.com
- Conditionalize openmpt build to be resolvable on Leap 42.3

See Also

Package Description
libpotrace0-1.15-13.1.x86_64.rpm Library for Tracing a Bitmap to Scalable Outline Image
libpq5-32bit-9.6.4-6.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-32bit-9.6.6-9.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-32bit-9.6.7-12.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-32bit-9.6.8-15.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-32bit-9.6.9-18.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-9.6.4-6.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-9.6.6-9.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-9.6.7-12.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-9.6.8-15.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-9.6.9-18.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libprocps3-3.3.9-14.1.x86_64.rpm The procps library
libprocps3-3.3.9-17.1.x86_64.rpm The procps library
libprocps3-3.3.9-20.1.x86_64.rpm The procps library
libpulse-devel-32bit-9.0-5.1.x86_64.rpm Development package for the pulseaudio library
Advertisement
Advertisement