libomp4-devel-4.0.1-5.1.x86_64.rpm


Advertisement

Description

libomp4-devel - MPI plugin for LLVM

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package filename libomp4-devel-4.0.1-5.1.x86_64.rpm
Package name libomp4-devel
Package version 4.0.1
Package release 5.1
Package architecture x86_64
Package type rpm
Category Development/Languages/Other
Homepage http://www.llvm.org
License NCSA
Maintainer -
Download size 285.54 KB
Installed size 812.37 KB
This package contains the OpenMP MPI plugin for LLVM.

Alternatives

Package Version Architecture Repository
libomp4-devel-4.0.1-2.3.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
libomp4-devel - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux-x86-64.so.2()(64bit) -
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) -
libLLVM4 -
libc.so.6(GLIBC_2.14)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -

Provides

Name Value
libomp-devel -
libomp.so()(64bit) -
libomp.so(GOMP_1.0)(64bit) -
libomp.so(GOMP_2.0)(64bit) -
libomp.so(GOMP_3.0)(64bit) -
libomp.so(GOMP_4.0)(64bit) -
libomp.so(OMP_1.0)(64bit) -
libomp.so(OMP_2.0)(64bit) -
libomp.so(OMP_3.0)(64bit) -
libomp.so(OMP_3.1)(64bit) -
libomp.so(OMP_4.0)(64bit) -
libomp.so(VERSION)(64bit) -
libomp4-devel = 4.0.1-5.1
libomp4-devel(x86-64) = 4.0.1-5.1

Conflicts

Name Value
libomp-devel -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libomp4-devel-4.0.1-5.1.x86_64.rpm
Source Package llvm4-4.0.1-5.1.src.rpm

Install Howto

Install libomp4-devel rpm package:

# zypper install libomp4-devel

Files

Path
/usr/lib64/libomp.so

Changelog

2018-05-09 - msrb@suse.com
- Do not build stage1 with debug info. It was accidentally added
with the use of %optflags. This should fix out of memory errors
on 32bit architectures and speed up build everywhere else.
(bsc#1092697)
2018-05-02 - msrb@suse.com
- Add appropriate Conflicts to make the package acceptable to Leap
42.3. It is required as rust/Firefox dependency. (bnc#1091551)
2018-03-14 - msrb@suse.com
- Remove liblldb4 and lldb4-devel from baselibs.conf. They are only
build for x86_64, so no point having them in baselibs.conf.
2018-03-13 - msrb@suse.com
- libcxx.glibc2.27.diff
* Fix build with glibc >= 2.27. Various locales in glibc 2.27
started using narrow non-break space for thousand separators.
libc++ tests must be adapted.
2018-02-07 - msrb@suse.com
- Use %optflags, except for FORTIFY_SOURCE which is not compatible
with compiler-rt.
- Exclude static libraries differently.
* Drop llvm-split-static-library-exports-into-their-own-export-file.diff
* Drop clang-split-static-library-exports-into-their-own-export-file.diff
* Update llvm-do-not-install-static-libraries.patch to not use
EXCLUDE_FROM_ALL which is not available in cmake 3.5.
- This fixes build on SLE12.
- Do not force gcc6 on OpenSUSE - fixes build.
- Reduce the amount of concurent link jobs by increasing their
memory requirement - to reduce stalls in OBS.
2018-01-31 - msrb@suse.com
- Cleanup %ifarch conditions, remove targets unintentionally added
to s390/s390x. (bnc#1078436)
2018-01-30 - msrb@suse.com
- Limit the amount of parallel link jobs, but no longer limit
compile jobs. This should prevent running out of memory during
linking while not longer slowing down compilation.
- Remove build dependency on procps
2018-01-29 - msrb@suse.com
- Reduce disk size requirement to 30GB in _constraints. We no
longer need that much since we stopped building static libraries.
2018-01-18 - msrb@suse.com
- n_clang_allow_BUILD_SHARED_LIBRARY.patch
* Allow buildling clang with BUILD_SHARED_LIBRARY while the rest
is built with LLVM_LINK_LLVM_DYLIB. (bnc#1065464)
- Remove clang-devel-static.
2018-01-10 - msrb@suse.com
- Place gold plugin to the right directory. (bnc#1073210)
* It must be in /usr/lib/bfd-plugins on all architectures.
* Remove llvm5-gold from baselibs.conf - nothing needs a 32bit
version of it and it would now conflict with the 64bit one.
- Reduce _constraints requirements on 32bit architectures.
* Since we had to disable debuginfo on them, they require much
less.

See Also

Package Description
libopencv-qt56_3-3.1.0-4.11.1.x86_64.rpm Development files for using the OpenCV library
libopencv-qt56_3-3.1.0-4.3.1.x86_64.rpm Development files for using the OpenCV library
libopencv-qt56_3-3.1.0-4.6.1.x86_64.rpm Development files for using the OpenCV library
libopencv3_1-3.1.0-4.11.1.x86_64.rpm Development files for using the OpenCV library
libopencv3_1-3.1.0-4.3.1.x86_64.rpm Development files for using the OpenCV library
libopencv3_1-3.1.0-4.6.1.x86_64.rpm Development files for using the OpenCV library
libopeniscsiusr0_2_0-2.0.876-60.1.x86_64.rpm Userspace iSCSI API
libopeniscsiusr0_2_0-2.0.876-64.1.x86_64.rpm Userspace iSCSI API
libopenjp2-7-2.1.0-16.1.x86_64.rpm Opensource JPEG 2000 Codec Implementation
libopenjp2-7-2.1.0-19.1.x86_64.rpm Opensource JPEG 2000 Codec Implementation
libopenjp2-7-2.1.0-22.1.x86_64.rpm Opensource JPEG 2000 Codec Implementation
libopenjp2-7-32bit-2.1.0-16.1.x86_64.rpm Opensource JPEG 2000 Codec Implementation
libopenjp2-7-32bit-2.1.0-19.1.x86_64.rpm Opensource JPEG 2000 Codec Implementation
libopenjp2-7-32bit-2.1.0-22.1.x86_64.rpm Opensource JPEG 2000 Codec Implementation
libopenjpeg1-1.5.2-10.1.x86_64.rpm An open-source JPEG 2000 codec
Advertisement
Advertisement