libmagic1-5.22-13.1.x86_64.rpm


Advertisement

Description

libmagic1 - Library with file's functionality

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package filename libmagic1-5.22-13.1.x86_64.rpm
Package name libmagic1
Package version 5.22
Package release 13.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.darwinsys.com/file/
License BSD-2-Clause
Maintainer -
Download size 70.17 KB
Installed size 118.91 KB
This library reads magic files and detects file types. Used by file command

Alternatives

Package Version Architecture Repository
libmagic1-5.22-16.1.x86_64.rpm 5.22 x86_64 openSUSE Update Oss
libmagic1-5.22-10.1.x86_64.rpm 5.22 x86_64 openSUSE Update Oss
libmagic1-5.19-8.15.x86_64.rpm 5.19 x86_64 openSUSE Oss
libmagic1 - - -

Requires

Name Value
/sbin/ldconfig -
file-magic = 5.22
libc.so.6(GLIBC_2.17)(64bit) -
libz.so.1()(64bit) -

Provides

Name Value
libmagic.so.1()(64bit) -
libmagic1 = 5.22-13.1
libmagic1(x86-64) = 5.22-13.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libmagic1-5.22-13.1.x86_64.rpm
Source Package file-5.22-13.1.src.rpm

Install Howto

Install libmagic1 rpm package:

# zypper install libmagic1

Files

Path
/usr/lib64/libmagic.so.1
/usr/lib64/libmagic.so.1.0.0

Changelog

2017-12-04 - werner@suse.de
- Add patches file-78c2b81ccb.patch and file-9f0601f3c0.patch which
are backports of the commits -78c2b81ccb and 9f0601f3c0 to fix
e.g. recursion bug in jpeg detection (bsc#1070958, boo#1070878)
2017-10-20 - werner@suse.de
- Add patch file-9fbe768a87.patch and patch file-91a5efbb98.patch
which are backport of the upstream commits 9fbe768a87 and
91a5efbb98 (bsc#1063269)
2017-03-17 - werner@suse.de
- Add patch file-5.22-strings.patch which is a backport for an
increased printable string length as found in file 5.30 (bsc#996511)
2015-02-13 - werner@suse.de
- Upgrade to file version 5.22 to fix boo#913650 (CVE-2014-9621),
boo#913651 (CVE-2014-9620), boo#917152 (CVE-2014-9653), and
bsc#1009966 as well
2015-01-19 - werner@suse.de
- Update to file version 5.22 (also related to bsc#913650 and bsc#913651)
* add indirect relative for TIFF/Exif
* restructure elf note printing to avoid repeated messages
* add note limit, suggested by Alexander Cherepanov
* Bail out on partial pread()'s (Alexander Cherepanov)
* Fix incorrect bounds check in file_printable (Alexander Cherepanov)
* PR/405: ignore SIGPIPE from uncompress programs
* change printable -> file_printable and use it in
more places for safety
* in ELF, instead of "(uses dynamic libraries)" when PT_INTERP
is present print the interpreter name.
- Patch file-5.18-elf.dif is modified and renamed to file-5.22-elf.dif
- Patch file-5.20.dif s modified and renamed to file-5.22.dif
2014-12-20 - meissner@suse.com
- build with PIE
2014-12-17 - werner@suse.de
- Drop patch file-5.20-CVE-2014-3710.patch as now part of upstream
- Update to file version 5.21
* Fix CVE-2014-8116 and CVE-2014-8117 (bsc#910252 and bsc#910253)
* there was an incorrect free in magic_load_buffers()
* there was an out of bounds read for some pascal strings
* there was a memory leak in magic lists
* don't interpret strings printed from files using the current
locale, convert them to ascii format first.
* there was an out of bounds read in elf note reads
* fix MacOS/X locale.h vs. xlocale.h issues
2014-12-17 - werner@suse.de
- Port and add upstream patches
0001-limit-the-number-of-program-and-section-header-numbe.patch
0002-Stop-reporting-bad-capabilities-after-the-first-few.patch
0003-reduce-recursion-level-from-20-to-10-and-make-a-symb.patch
0004-adjust-limits-better-from-NetBSD.patch
0005-bump-recursion-to-15-and-allow-it-to-be-set-from-the.patch
0006-Don-t-bail-if-there-was-no-error-buf-could-have-been.patch
to fix CVE-2014-8116 and CVE-2014-8117 (bsc#910252 and bsc#910253)
2014-10-23 - werner@suse.de
- Add patch file-5.20-CVE-2014-3710.patch to fic bsc#902367
CVE-2014-3710: file: out-of-bounds read in elf note headers
2014-10-13 - werner@suse.de
- Update to file version 5.20
* recognize encrypted CDF documents
* add magic_load_buffers from Brooks Davis
* add thumbs.db support
- Remove file-5.07-iso9660.dif as now upstream
- Remove file-5.19-gdbm.patch as now upstream
- Adapt and rename file-5.18-endian.patch to file-5.20-endian.patch
- Adapt and rename file-5.19.dif file-5.20.dif

See Also

Package Description
libmapi1-8.3.3.24-3.2.x86_64.rpm Kopano's implementation of the Messaging API
libmarkdown-devel-2.2.4-7.3.1.x86_64.rpm Markdown text to HTML converter library
libmarkdown2-2.2.4-7.3.1.x86_64.rpm Markdown text to HTML converter library
libmatroska-devel-1.4.9-4.3.1.x86_64.rpm Library to Deal with Matroska Files
libmatroska6-1.4.9-4.3.1.x86_64.rpm Library to Deal with Matroska Files
libmatroska6-32bit-1.4.9-4.3.1.x86_64.rpm Library to Deal with Matroska Files
libmbedtls9-1.3.19-18.1.x86_64.rpm Open Source embedded SSL/TLS cryptographic library
libmbedtls9-1.3.19-21.1.x86_64.rpm Open Source embedded SSL/TLS cryptographic library
libmbedtls9-1.3.19-24.1.x86_64.rpm Open Source embedded SSL/TLS cryptographic library
libmbedtls9-32bit-1.3.19-18.1.x86_64.rpm Open Source embedded SSL/TLS cryptographic library
libmbedtls9-32bit-1.3.19-21.1.x86_64.rpm Open Source embedded SSL/TLS cryptographic library
libmbedtls9-32bit-1.3.19-24.1.x86_64.rpm Open Source embedded SSL/TLS cryptographic library
libmilter-doc-8.15.2-6.1.noarch.rpm BSD Sendmail Content Management API (milter)
libmilter1_0-8.15.2-6.1.x86_64.rpm BSD Sendmail Content Management API (milter)
libminizip1-1.2.8-14.3.1.x86_64.rpm Library for manipulation with .zip archives
Advertisement
Advertisement