libMagick++-6_Q16-3-6.8.8.1-61.2.x86_64.rpm


Advertisement

Description

libMagick++-6_Q16-3 - C++ Interface for ImageMagick - runtime library

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name libMagick++-6_Q16-3
Package version 6.8.8.1
Package release 61.2
Package architecture x86_64
Package type rpm
Installed size 485.48 KB
Download size 167.00 KB
Official Mirror ftp.gwdg.de
This is Magick++, the object-oriented C++ API for the ImageMagick
image-processing library.
Magick++ supports an object model inspired by PerlMagick. Magick++
should be faster than PerlMagick since it is written in a compiled
language which is not parsed at run-time. This makes it suitable for
Web CGI programs. Images support implicit reference counting so that
copy constructors and assignment incur almost no cost. The cost of
actually copying an image (if necessary) is done just before
modification and this copy is managed automatically by Magick++.
De-referenced copies are automatically deleted. The image objects
support value (rather than pointer) semantics so it is trivial to
support multiple generations of an image in memory at one time.

Alternatives

Package Version Architecture Repository
libMagick++-6_Q16-3-6.8.8.1-67.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Test
libMagick++-6_Q16-3-6.8.8.1-64.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-58.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-55.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-52.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-49.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-46.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-43.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-40.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-37.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-34.1.x86_64.rpm 6.8.8.1 x86_64 openSUSE Update Oss
libMagick++-6_Q16-3-6.8.8.1-32.7.x86_64.rpm 6.8.8.1 x86_64 openSUSE Oss
libMagick++-6_Q16-3 - - -

Requires

Name Value
/sbin/ldconfig -
ImageMagick -
libMagickCore-6.Q16.so.1()(64bit) -
libMagickWand-6.Q16.so.1()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -

Provides

Name Value
libMagick++-6.Q16.so.3()(64bit) -
libMagick++-6_Q16-3 = 6.8.8.1-61.2
libMagick++-6_Q16-3(x86-64) = 6.8.8.1-61.2

Download

Type URL
Binary Package libMagick++-6_Q16-3-6.8.8.1-61.2.x86_64.rpm
Source Package ImageMagick-6.8.8.1-61.2.src.rpm

Install Howto

Install libMagick++-6_Q16-3 rpm package:

# zypper install libMagick++-6_Q16-3

Files

Path
/usr/lib64/libMagick++-6.Q16.so.3
/usr/lib64/libMagick++-6.Q16.so.3.0.0
/usr/share/doc/packages/libMagick++-6_Q16-3/LICENSE

Changelog

See ImageMagick-6.8.8.1-61.2.x86_64.rpm changelog.

See Also

Package Description
libMagick++-devel-32bit-6.8.8.1-34.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-37.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-40.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-43.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-46.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-49.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-52.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-55.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-58.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-61.2.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-32bit-6.8.8.1-64.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-6.8.8.1-34.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-6.8.8.1-37.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-6.8.8.1-40.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
libMagick++-devel-6.8.8.1-43.1.x86_64.rpm C++ Interface for ImageMagick - files mandatory for development
Advertisement
Advertisement