geoclue2-devel-2.4.3-5.3.1.x86_64.rpm


Advertisement

Description

geoclue2-devel - GeoLocation Framework -- Development files

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name geoclue2-devel
Package version 2.4.3
Package release 5.3.1
Package architecture x86_64
Package type rpm
Installed size 245.21 KB
Download size 44.70 KB
Official Mirror ftp.gwdg.de
GeoClue is a software framework which can be used to enable geospatial
awareness in applications. GeoClue uses the D-Bus inter-process
communication mechanism to provide location information

Alternatives

Package Version Architecture Repository
geoclue2-devel-2.4.3-4.3.x86_64.rpm 2.4.3 x86_64 openSUSE Oss
geoclue2-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
geoclue2 = 2.4.3
pkgconfig(gio-2.0) -
pkgconfig(gio-unix-2.0) -
pkgconfig(glib-2.0) -
typelib-1_0-Geoclue-2_0 = 2.4.3

Provides

Name Value
geoclue2-devel = 2.4.3-5.3.1
geoclue2-devel(x86-64) = 2.4.3-5.3.1
pkgconfig(geoclue-2.0) = 2.4.3
pkgconfig(libgeoclue-2.0) = 2.4.3

Download

Type URL
Binary Package geoclue2-devel-2.4.3-5.3.1.x86_64.rpm
Source Package geoclue2-2.4.3-5.3.1.src.rpm

Install Howto

Install geoclue2-devel rpm package:

# zypper install geoclue2-devel

Files

Path
/usr/include/libgeoclue-2.0/gclue-client.h
/usr/include/libgeoclue-2.0/gclue-enum-types.h
/usr/include/libgeoclue-2.0/gclue-enums.h
/usr/include/libgeoclue-2.0/gclue-helpers.h
/usr/include/libgeoclue-2.0/gclue-location.h
/usr/include/libgeoclue-2.0/gclue-manager.h
/usr/include/libgeoclue-2.0/gclue-simple.h
/usr/include/libgeoclue-2.0/geoclue.h
/usr/lib64/libgeoclue-2.so
/usr/lib64/pkgconfig/geoclue-2.0.pc
/usr/lib64/pkgconfig/libgeoclue-2.0.pc
/usr/share/dbus-1/interfaces/org.freedesktop.GeoClue2.Agent.xml
/usr/share/dbus-1/interfaces/org.freedesktop.GeoClue2.xml
/usr/share/doc/packages/geoclue2-devel/COPYING
/usr/share/doc/packages/geoclue2-devel/README
/usr/share/gir-1.0/Geoclue-2.0.gir

Changelog

See geoclue2-2.4.3-5.3.1.x86_64.rpm changelog.

See Also

Package Description
geotiff-1.4.2-6.3.1.x86_64.rpm Library to handle georeferenced TIFF
geotiff-devel-1.4.2-6.3.1.x86_64.rpm GeoTIFF header files
ghostscript-9.15-14.3.1.x86_64.rpm The Ghostscript interpreter for PostScript and PDF
ghostscript-9.15-14.6.1.x86_64.rpm The Ghostscript interpreter for PostScript and PDF
ghostscript-devel-9.15-14.3.1.x86_64.rpm Development files for Ghostscript
ghostscript-devel-9.15-14.6.1.x86_64.rpm Development files for Ghostscript
ghostscript-mini-9.15-14.3.1.x86_64.rpm Minimal Ghostscript for minimal build requirements
ghostscript-mini-9.15-14.6.1.x86_64.rpm Minimal Ghostscript for minimal build requirements
ghostscript-mini-devel-9.15-14.3.1.x86_64.rpm Development files for Minimal Ghostscript
ghostscript-mini-devel-9.15-14.6.1.x86_64.rpm Development files for Minimal Ghostscript
ghostscript-x11-9.15-14.3.1.x86_64.rpm X11 library for Ghostscript
ghostscript-x11-9.15-14.6.1.x86_64.rpm X11 library for Ghostscript
gifsicle-1.91-5.1.x86_64.rpm Creating and editing GIF images and animations
gimp-2.8.18-6.3.x86_64.rpm The GNU Image Manipulation Program
gimp-devel-2.8.18-6.3.x86_64.rpm The GNU Image Manipulation Program
Advertisement
Advertisement